Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate to shared host system
-
ExploitCraft malformed override key bypassing validation
-
ExecutionInject blocked environment variable
-
ImpactExecute arbitrary code with unintended environment
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A02:2025 - Security Misconfiguration
ASVS 5.0
V13 - Configuration Configuration hardening
|
| Exploitation Conditions | Requires authenticated access to OpenClaw before version 2026.3.22 in a shared host environment with environment variable override functionality enabled. Attacker must supply malformed override keys to bypass validation sanitization and execute arbitrary code. |
| Impact | CVSS 7.5 reflects high impact (confidentiality, integrity, availability) but elevated attack complexity and authenticated requirement limit immediate exposure. Moderate observed exploitation activity suggests real-world interest. Patch availability and no KEV confirmation indicate controlled risk window. Priority depends on OpenClaw deployment scope and whether unauthenticated access precedes the authenticated bypass. |
| Exploit ScenarioDerived | Authenticated attacker supplies malformed environment variable override keys that bypass inconsistent validation logic, then executes arbitrary code with elevated privileges through environment manipulation. Attack complexity is high, suggesting specific conditions or tool knowledge required. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
Remote code execution in OpenClaw versions prior to 2026.3.22 allows authenticated attackers to bypass shared host environment policy via inconsistent environment variable sanitization. Attackers exploit validation inconsistencies by supplying malformed or blocked override keys that evade filtering mechanisms, enabling arbitrary code execution with unauthorized environment variable configurations. Vulnerability requires low-privilege authentication and high attack complexity. No public exploit identified at time of analysis.
RemediationAI
Vendor-released patch: Upgrade to OpenClaw version 2026.3.22 or later, which implements consistent sanitization logic across all environment variable validation paths. Two upstream commits address the vulnerability: 630f1479c44f78484dfa21bb407cbe6f171dac87 and 7abfff756d6c68d17e21d1657bbacbaec86de232. Official security advisory available at https://github.com/openclaw/openclaw/security/advisories/GHSA-39pp-xp36-q6mg. Until upgrade is completed, restrict low-privilege user access to OpenClaw environment configuration interfaces and enforce strict input validation at network perimeter. Review audit logs for anomalous environment variable override attempts. For complete technical analysis, consult VulnCheck advisory at https://www.vulncheck.com/advisories/openclaw-environment-variable-override-bypass-via-inconsistent-sanitization.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CWE-15 external control of system or configuration setting vulnerability stems from inconsistent sanitization paths in environment variable override handling. Validation logic fails to uniformly filter malicious override keys across all code paths, creating bypass opportunities. Exploitable via OpenClaw's shared host environment policy enforcement mechanisms when processing attacker-controlled environment variable inputs.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.22 contains an environment variable override handling vulnerability that allows attackers to bypass the shared host environment policy through inconsistent sanitization paths. Attackers can supply blocked or malformed override keys that slip through inconsistent validation to execute arbitrary code with unintended environment variables.
Blast Radius
ecosystem impact- 5 npm packages depend on openclaw (5 direct, 0 indirect)
Ecosystem-wide dependent count for version 2026.3.22.
Executive ViewAI
OpenClaw versions before 2026.3.22 contain a remote code execution vulnerability that allows authenticated users with low privileges to execute arbitrary code by exploiting environment variable sanitization flaws, potentially compromising shared hosting environments and data isolation controls. Organizations running affected OpenClaw instances must prioritize immediate patching to prevent lateral movement and unauthorized access to isolated workloads.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Remote Code Execution represents the critical moment when an attacker successfully runs arbitrary code on a target system without physical access.
Related Vulnerabilities in OpenClaw Multiple Authorization and Privilege Escalation
View all 29Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21446
GHSA-39pp-xp36-q6mg
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB