Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as low-privilege user
-
DeliveryAccess gateway-authenticated plugin HTTP route
-
ExploitTrigger scope boundary bypass
-
ExecutionReceive operator.admin runtime scope
-
ImpactExecute unauthorized administrative actions
Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V6 - Authentication Incorrect use of privileged APIs
|
| Exploitation Conditions | Requires authenticated access to OpenClaw before version 2026.3.25. Attacker must be a legitimate user with any non-admin scope calling gateway-authenticated plugin HTTP routes. The vulnerability automatically escalates caller privileges to operator.admin scope, bypassing intended access controls. |
| Impact | CVSS 8.8 reflects high-impact privilege escalation over the network with low complexity. Authenticated users bypass scope boundaries to gain admin privileges unauthenticated-critical for multi-tenant deployments. EPSS data unavailable; however, scope manipulation affecting authorization systems typically sees rapid exploitation once patched versions exist. Patch availability reduces urgency slightly but organizations running versions before 2026.3.25 face immediate administrative compromise risk. |
| Exploit ScenarioDerived | Authenticated user crafts HTTP request to gateway-authenticated plugin route. Vulnerable code incorrectly mints operator.admin scope regardless of caller's actual permissions. Attacker performs administrative actions (user creation, configuration changes, data access) without proper authorization. No public exploit identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
Privilege escalation in OpenClaw gateway-authenticated plugin HTTP routes allows authenticated attackers to bypass scope restrictions and gain operator.admin privileges. The vulnerability affects OpenClaw versions prior to 2026.3.25, enabling low-privileged authenticated users to perform unauthorized administrative actions through improperly minted runtime scopes. Exploitation requires network access and low-level authentication but no user interaction. No public exploit identified at time of analysis.
RemediationAI
Vendor-released patch: upgrade to OpenClaw 2026.3.25 or later, which corrects scope minting logic in gateway-authenticated plugin HTTP routes. The fix is implemented in commit ec2dbcff9afd8a52e00de054b506c91726d9fbbe. Organizations unable to immediately upgrade should disable gateway-authenticated plugin HTTP routes or restrict network access to trusted authenticated users only until patching is complete. Review existing authentication logs for evidence of unauthorized scope elevation to operator.admin privileges. Consult vendor security advisory at https://github.com/openclaw/openclaw/security/advisories/GHSA-qm2m-28pf-hgjw and VulnCheck analysis at https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-gateway-plugin-http-authentication-scope for additional technical details and detection guidance.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CWE-648 scope boundary bypass occurs when gateway-authenticated plugin HTTP routes incorrectly mint operator.admin runtime scope without validating caller-granted scopes. The authentication mechanism (CVSS PR:L) fails to enforce proper privilege boundaries during scope elevation, allowing horizontal privilege escalation from legitimate low-privilege credentials to full administrative context.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in gateway-authenticated plugin HTTP routes that incorrectly mint operator.admin runtime scope regardless of caller-granted scopes. Attackers can exploit this scope boundary bypass to gain elevated privileges and perform unauthorized administrative actions.
Executive ViewAI
CVE-2026-35669 is a privilege escalation vulnerability in OpenClaw's gateway-authenticated plugin that allows authenticated users with low-level access to escalate to operator.admin privileges, potentially compromising administrative control of the gateway. Organizations running OpenClaw versions prior to 2026.3.25 face risk of unauthorized administrative actions and should prioritize patching to prevent lateral movement and administrative account compromise.
Apply vendor patch. Until patching is complete, implement network-level access controls to restrict authenticated user access to OpenClaw gateway-authenticated plugin HTTP routes, and enable detailed audit logging of all administrative privilege changes and scope-related operations.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Related Vulnerabilities in OpenClaw Multiple Authorization and Privilege Escalation
View all 29Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21484
GHSA-qm2m-28pf-hgjw
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB