Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V2 - Validation and Business Logic Trusted input validation
|
| Impact | This vulnerability presents moderate real-world risk despite a medium CVSS score (5.7). The CVSS vector (AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N) indicates network-accessible attack requiring low complexity and a user interaction (UI:R), but the high integrity impact (I:H) reflects the ability to bypass intended security controls. Authentication is required (PR:L), limiting the attack surface to authenticated users. The integrity-focused impact (no confidentiality or availability loss) aligns with an authorization bypass rather than data theft or service disruption. Given that dangerous-tool prompting is a primary security boundary in OpenClaw, and authenticated users can silently circumvent it, this represents a meaningful privilege escalation or policy violation risk for multi-tenant or role-based environments. The CVSS does not fully capture the severity in contexts where tool execution audit trails or compliance depend on accurate tool attribution. Exploitation likelihood is moderate: requires authenticated access and user interaction, but once triggered, is reliably weaponizable for operations that should be blocked. |
| Exploit ScenarioDerived | An authenticated OpenClaw user with legitimate access to benign tools crafts a request containing a rawInput parameter that falsely claims the tool identity as a safe utility (e.g., 'read_file') while the actual metadata payload performs a dangerous operation (e.g., 'execute_shell'). The ACP permission system trusts the rawInput hint over metadata, suppresses the dangerous-tool warning that would normally trigger user interaction (UI:R requirement), and permits the operation silently. No public exploit code has been confirmed, but the straightforward nature of parameter manipulation makes this readily weaponizable once an attacker understands the permission resolution logic. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
OpenClaw before version 2026.3.22 allows authenticated remote attackers to spoof tool identities through rawInput parameters, bypassing ACP permission resolution and suppressing dangerous-tool prompting via identity hint conflicts between rawInput and metadata. This authentication bypass with high integrity impact affects all versions prior to the fixed release, enabling attackers to circumvent security restrictions intended to prevent execution of dangerous operations.
RemediationAI
Vendor-released patch: upgrade to OpenClaw 2026.3.22 or later. Fixes are available via commits 630f1479c44f78484dfa21bb407cbe6f171dac87 and e4c61723cd2d530680cc61789311d464ab8cdf60 in the upstream repository. Organizations unable to patch immediately should implement compensating controls such as strict audit logging of rawInput parameters in ACP resolution, enforcement of metadata-only tool identity validation at the application layer, and restriction of dangerous-tool operations to specific roles or administrative channels with additional approval workflows. Consult the GitHub Security Advisory (GHSA-74wf-h43j-vvmj) for workaround details and version confirmation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
OpenClaw's ACP (Access Control Policy) permission resolution mechanism validates tool identity through conflicting sources: rawInput parameters and metadata fields. The vulnerability (CWE-807: Reliance on Untrusted Inputs in a Security Decision) stems from trusting unauthenticated user-supplied rawInput hints over properly validated metadata, allowing identity spoofing. When an attacker crafts rawInput to claim a benign tool identity while performing dangerous operations, the permission system fails to detect the mismatch, permitting operations that should trigger security warnings or be blocked outright. This affects the OpenClaw application framework (CPE: cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:*:*:*) across all versions before 2026.3.22.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.22 contains an identity spoofing vulnerability in ACP permission resolution that trusts conflicting tool identity hints from rawInput and metadata. Attackers can spoof tool identities through rawInput parameters to suppress dangerous-tool prompting and bypass security restrictions.
Blast Radius
ecosystem impact- 5 npm packages depend on openclaw (5 direct, 0 indirect)
Ecosystem-wide dependent count for version 2026.3.22.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Related Vulnerabilities in OpenClaw Multiple Authorization and Privilege Escalation
View all 29Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21456
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB