Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as low-privilege operator
-
ExploitSend HTTP GET request to /sessions/:sessionKey/history
-
ExecutionBypass operator.read scope validation
-
ImpactAccess unauthorized session history data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Attacker requires low-privilege authenticated access to OpenClaw before version 2026.3.25. The vulnerable HTTP endpoint /sessions/:sessionKey/history bypasses operator.read scope validation, allowing authenticated users without proper permissions to access session history via direct HTTP requests. |
| Impact | This is a moderate-severity vulnerability with meaningful real-world risk despite the CVSS 6.5 score. The CVSS vector (PR:L/UI:N/AV:N/AC:L/C:H/I:N/A:N) indicates that an authenticated user with limited privileges can remotely access confidential session history without user interaction or high attack complexity, directly explaining the high confidentiality impact rating. The vulnerability requires prior authentication (PR:L), which limits the attack surface to accounts that already exist in the system-likely insiders or compromised low-privilege accounts. The lack of integrity or availability impact (I:N/A:N) means this is purely an information disclosure issue. No public exploit code or active exploitation has been confirmed, reducing immediate urgency relative to unauthenticated remote code execution vulnerabilities; however, the ease of exploitation (low complexity, no interaction required) and high sensitivity of session history data (authentication tokens, user activity logs, potentially PII) make this a priority for authenticated-access-only systems. The confirmed availability of a vendor patch further supports prioritization for timely remediation. |
| Exploit ScenarioDerived | An authenticated user with limited privileges (e.g., a junior analyst account with no operator.read scope) logs into an OpenClaw instance and directly requests the /sessions/:sessionKey/history endpoint for a session belonging to a senior operator. The vulnerable endpoint skips authorization validation and returns the full session history, exposing sensitive details such as authentication tokens, API interactions, or audit logs that should have been restricted. This could enable privilege escalation, lateral movement, or data theft if the exposed session data contains credentials or sensitive operational information. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
OpenClaw before version 2026.3.25 allows authenticated attackers to bypass authorization checks on the /sessions/:sessionKey/history HTTP endpoint, enabling unauthorized access to session history data without requiring operator.read scope permissions. The vulnerability affects all OpenClaw versions prior to 2026.3.25 and requires valid authentication credentials to exploit; no public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
Vendor-released patch: Upgrade OpenClaw to version 2026.3.25 or later. The upstream fix has been committed to the repository (commit 1c45123231516fa50f8cf8522ba5ff2fb2ca7aea) and is available in the patched release. Organizations unable to upgrade immediately should implement compensating network controls to restrict access to the /sessions/:sessionKey/history endpoint to only authenticated users who legitimately require operator.read permissions, and review access logs for unauthorized session history access patterns. Refer to the official GitHub Security Advisory at https://github.com/openclaw/openclaw/security/advisories/GHSA-5jvj-hxmh-6h6j for additional technical details and the vendor patch link.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in OpenClaw's HTTP API authorization layer, specifically in the /sessions/:sessionKey/history route handler. The application implements a scope-based authorization model where the operator.read permission should gate access to session history data, but the endpoint fails to validate this scope requirement before returning sensitive session information. This represents a classic authorization bypass (CWE-863: Incorrect Authorization) where the authentication check exists but the authorization control is improperly implemented or skipped entirely. The affected product is identified via CPE cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:*:*:* covering all versions before the patched release.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.25 contains an authorization bypass vulnerability in the HTTP /sessions/:sessionKey/history route that skips operator.read scope validation. Attackers can access session history without proper operator read permissions by sending HTTP requests to the vulnerable endpoint.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Related Vulnerabilities in OpenClaw Multiple Authorization and Privilege Escalation
View all 29Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21460
NVD
CVE.org
EPSS
Vulnrichment
GitHub
Exploit-DB