Skip to main content

Weblate EUVDEUVD-2025-18400

| CVE-2025-47951 MEDIUM
Improper Restriction of Excessive Authentication Attempts (CWE-307)
2025-06-16 security-advisories@github.com GHSA-57jg-m997-cx3q
4.9
CVSS 3.1 · GitHub Advisory
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A07:2025 - Authentication Failures
ASVS 5.0
V6 - Authentication Brute-force prevention, rate limiting
Impact

CVSS score of 4.9 (MEDIUM).

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
Patch available 0.1% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Mar 14, 2026

Weblate is a web based localization tool. Prior to version 5.12, the verification of the second factor was not subject to rate limiting. The absence of rate limiting on the second factor endpoint allows an attacker with valid credentials to automate OTP guessing. This issue has been patched in version 5.12.

Earlier versions of this analysis (1)
v1 Mar 14, 2026 - 21:59 CVSS 4.9

RemediationAI

A vendor patch is available. Apply it as soon as possible and verify the fix.

Affected VersionsENISA

weblate < 5.12

Affected Packages

pypi weblate fix: 5.12

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in pypi

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability is classified as Improper Restriction of Excessive Authentication Attempts (CWE-307).

Know when Weblate gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

GitHub Advisory PRIMARY 4.9 MEDIUM
AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
SUSE MEDIUM

Primary rating from GitHub Advisory.

CVSS VectorGitHub Advisory

Attack Vector
Network
Attack Complexity
High
Privileges Required
Low
User Interaction
None
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
None

Lifecycle Timeline

2
Patch released
Mar 14, 2026 - 21:59 nvd
Patch available
CVE Published
Jun 16, 2025 - 21:15 nvd
MEDIUM 4.9

Executive ViewAI

Why It Matters

Organizations using Weblate should be aware of moderate risk from CVE-2025-47951 rated CVSS 4.9. Exploitation could compromise the security of affected deployments. A patch is available and should be applied during regular vulnerability management.

Business Impact: Low
Compensating Controls

Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.

Threat Intelligence Overview

EPSS Score
0.1%
Top 80% exploitable
Data Quality
6 sources
Confidence: High

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC No
EPSS 0.1%
Patch available Yes
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Defer
Exploitation· derived
None
System Exposure· derived
Open
Automatable· derived
No
Human Impact
Low

Priority Score

24
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +24
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.

Related Vulnerabilities in Weblate Rate Limiting and Information Disclosure

View all 2
CVE-2025-68398 CRITICAL
9.1 Dec 18

Improper input validation in Weblate versions prior to 5.15.1 lets a user who can submit translation files or restore pr

CVE-2026-34393 HIGH
8.8 Apr 15

Privilege escalation in Weblate versions prior to 5.17 allows an authenticated low-privileged user to modify sensitive f

CVE-2022-23915 HIGH
8.8 Mar 04

The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when u

CVE-2026-86035 HIGH
8.5 Sep 29

Argument injection in Weblate's Mercurial backend lets an authenticated user with project-scoped component.edit permissi

CVE-2026-55228 HIGH
8.1 Aug 26

Weblate's REST API failed to enforce permission scope on team (group) assignments in all versions prior to 2026.7, allow

CVE-2026-33435 HIGH
8.0 Apr 15

Remote code execution in Weblate's project backup restoration affects versions prior to 5.17, exploitable by authenticat

CVE-2026-23535 HIGH
8.0 Jan 16

The wlc Weblate command-line client prior to version 1.17.2 is vulnerable to arbitrary file write attacks through path t

CVE-2026-61792 HIGH
7.7 Aug 26

Arbitrary file read via symlink traversal in Weblate's App store metadata ZIP download affects all versions prior to 202

CVE-2026-34242 HIGH
7.7 Apr 15

Arbitrary file read vulnerability in Weblate versions prior to 5.17 allows authenticated attackers to read sensitive fil

CVE-2026-21889 HIGH
7.5 Jan 14

Weblate versions prior to 5.15.2 expose screenshot images through the web server without authentication controls, enabli

CVE-2026-33220 MEDIUM
6.8 Apr 15

Path traversal in Weblate allows authenticated users to read arbitrary files outside the repository via the translation

CVE-2026-24126 MEDIUM
6.6 Feb 19

Weblate versions up to 5.16.0 contains a vulnerability that allows attackers to an argument injection to `ssh-add` (CVSS

Vendor StatusVendor

Debian

Bug #745661
weblate
Release Status Fixed Version Urgency
open - -

SUSE

Severity: Medium

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy