Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSend request to plugin endpoint
-
ExploitReceive response with embedded sensitive data
-
ExecutionExtract API keys or customer PII
-
ImpactUse stolen credentials for unauthorized transactions or data exfiltration
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V14 - Data Protection Outbound data filtering
|
| Exploitation Conditions | The vulnerability requires no authentication, no user interaction, and no special configuration - it is exploitable against default plugin installations accessible over the network. The sensitive data exposure occurs during normal plugin operation when the plugin handles payment requests or data retrieval. No specific payload, timing, or deployment mode limitation is indicated. The only limiting factor is that the attacker must be able to reach the plugin's endpoints over the network (not blocked by firewall or access controls). |
| Impact | The CVSS vector (AV:N/AC:L/PR:N/UI:N) indicates network-accessible exploitation with low complexity and no authentication required, suggesting broad attack surface. The 5.3 score reflects confidentiality impact only (no integrity or availability loss), typical for passive information disclosure. However, the real-world risk depends on WHICH sensitive data is exposed: if payment credentials, API keys, or customer personally identifiable information (PII) are compromised, the impact far exceeds the CVSS rating and creates secondary risks (fraud, identity theft, regulatory violation). The lack of CISA KEV confirmation suggests either limited active exploitation or recent disclosure. The CVSS vector's AV:N/AC:L/PR:N/UI:N characteristics indicate this is not a complex attack requiring special conditions. Risk severity is elevated given that WP EasyPay handles financial transactions; any exposure of payment-related data poses significant business and legal liability. The absence of published POC data or EPSS score means defenders must treat the network-accessible nature and low-complexity barrier as high-priority indicators regardless of exploitation prevalence. |
| Exploit ScenarioDerived | An attacker sends unauthenticated HTTP requests to the WP EasyPay plugin's API endpoints or form submission handlers, receiving responses that contain embedded sensitive information such as API keys, customer payment details, or transaction identifiers. The attacker captures these responses (via network sniffing, proxy interception, or server-side request forgery) and extracts the sensitive data for further exploitation, such as unauthorized API calls or customer data theft. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 12, 2026
WP EasyPay plugin through version 4.3.0 exposes sensitive information in sent data, allowing unauthenticated remote attackers to retrieve embedded data without user interaction. The vulnerability stems from improper handling of sensitive data during transmission, classified as an information disclosure issue with a CVSS score of 5.3 (network-accessible, low complexity). No active exploitation has been confirmed in CISA KEV at the time of analysis.
RemediationAI
Upgrade WP EasyPay to a patched version released after 4.3.0. Consult the Patchstack advisory at https://patchstack.com/database/Wordpress/Plugin/wp-easy-pay/vulnerability/wordpress-wp-easypay-plugin-4-3-0-sensitive-data-exposure-vulnerability?_s_id=cve for the exact patched version. As an immediate compensating control, restrict access to the plugin's API endpoints and transaction log pages to authenticated users only via Web Application Firewall (WAF) rules or .htaccess restrictions; document which endpoints expose sensitive data and block them from public access pending patching. Ensure all payment processing occurs over HTTPS with HSTS headers enforced. Review web server access logs and database transaction records for evidence of sensitive data retrieval by unauthorized parties. If upgrade is delayed, disable the plugin entirely and switch to an alternative payment gateway until the patch is deployed.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
WP EasyPay is a WordPress payment processing plugin that handles financial transactions. The vulnerability involves CWE-201 (Insertion of Sensitive Information Into Sent Data), which occurs when an application transmits sensitive information (such as credentials, API keys, or transaction details) in a manner that can be intercepted or retrieved by unauthorized parties. This typically manifests in payment gateways when API responses, form data, or transaction logs contain unencrypted or inadequately masked sensitive fields. The plugin's failure to properly sanitize or encrypt sensitive fields before transmission creates a direct information disclosure channel accessible over the network.
Know when Wp Easypay gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Insertion of Sensitive Information Into Sent Data vulnerability in Saad Iqbal WP EasyPay wp-easy-pay allows Retrieve Embedded Sensitive Data.This issue affects WP EasyPay: from n/a through <= 4.3.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
More in Wp Easypay
View allThe WP EasyPay WordPress plugin before 4.1 does not escape some generated URLs before outputting them back in pages, lea
WP EasyPay 4.5.4 and earlier exposes an unauthenticated path traversal that can allow remote attackers to read files fro
WP EasyPay WordPress plugin versions 4.5.0 and earlier permit any subscriber-level authenticated user to delete arbitrar
Cross-site request forgery in the WP EasyPay WordPress plugin (versions through 4.4.0) enables remote attackers to perfo
The WP EasyPay - Square for WordPress plugin for WordPress is vulnerable to unauthorized modification of datadue to a mi
WP EasyPay versions up to 4.2.11 contain an authorization bypass that allows authenticated users to modify plugin settin
Missing authorization in the WPExperts WP EasyPay plugin (versions through 4.5.4) leaves a plugin-provided endpoint or a
WP EasyPay WordPress plugin versions up to and including 4.5.3 allow unauthenticated remote attackers to bypass access c
The WP EasyPay - Square for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to
Cross-Site Request Forgery (CSRF) vulnerability in WP Easy Pay WP EasyPay - Square for WordPress plugin <= 4.1 versions.
EUVD-2026-29457
GHSA-fmc2-cwhh-xqrv
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB