Vulnerability Assessment
| Impact | The CVSS vector (AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N) correctly identifies network accessibility with no authentication required and low attack complexity. However, the EPSS score of 0.02% (percentile 6%) provides critical context: despite the moderate CVSS rating, real-world exploitation probability is very low. This discrepancy exists because exploitation is limited to the narrow population of WordPress sites using this specific plugin, and the attack provides limited practical value (wishlist renaming does not lead to financial loss, credential theft, or system compromise). The availability of public exploit code is notable but does not materially increase risk given the low business impact of wishlist tampering. SSVC analysis suggests: exploitation is possible (POC exists), impact is technical but limited to integrity and information disclosure, and remediation is straightforward (plugin update). This is categorized as a legitimate but lower-priority vulnerability for WordPress administrators. |
| Exploit ScenarioDerived | An attacker navigates to any WordPress site running YITH WooCommerce Wishlist (version below 4.13.0) and accesses the public /wishlist/ page, extracting the nonce value embedded in the page HTML. Using this nonce and publicly available exploit code, the attacker crafts an AJAX request to the save_title() handler with a target wishlist ID belonging to another user and a new malicious name (e.g., containing spam or defamatory content). The vulnerable plugin processes the request, changes the wishlist name without verifying ownership, and the tampering succeeds. The attacker has no need for authentication, credentials, or user interaction-only the public nonce-making this a straightforward CSRF-like attack. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
Unauthenticated attackers can rename arbitrary wishlists on WordPress sites running YITH WooCommerce Wishlist before version 4.13.0 due to insufficient ownership validation in the save_title() AJAX handler. The vulnerability exploits a publicly exposed nonce in the wishlist page source, allowing attackers to modify wishlist names for any user without authentication. While the CVSS score of 6.5 reflects moderate integrity and confidentiality impact, the EPSS score of 0.02% (percentile 6%) and low real-world exploitation probability suggest this is a niche risk affecting only sites using this specific plugin, though publicly available exploit code exists.
RemediationAI
Vendor-released patch: upgrade YITH WooCommerce Wishlist to version 4.13.0 or later. This patch version implements proper ownership validation in the save_title() AJAX handler, ensuring that users can only rename wishlists they own. Site administrators should update immediately through the WordPress plugin dashboard or manually via the plugin repository. No workaround exists for versions prior to 4.13.0 that fully mitigates the vulnerability without upgrading. Review WPScan vulnerability details at https://wpscan.com/vulnerability/2f052086-b691-48df-9b08-2cb1db65e14e/ for additional context and the NIST NVD entry at https://nvd.nist.gov/vuln/detail/CVE-2026-4432 for patch confirmation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The YITH WooCommerce Wishlist plugin implements an AJAX handler for the save_title() function to allow users to rename their wishlists. The vulnerability stems from improper access control in this handler: while the function validates a WordPress nonce (CSRF token), it fails to verify that the requesting user actually owns the wishlist being modified. Nonces in WordPress are designed to prevent cross-site request forgery but are not access control mechanisms. The nonce value is embedded directly in the HTML source of the public /wishlist/ page, making it accessible to any visitor. Because the AJAX endpoint lacks user ID or ownership checks after nonce validation, any attacker with the nonce can rename any wishlist on the site. This represents a classic broken access control vulnerability (improper authorization check) affecting WordPress plugin functionality.
Know when Yith Woocommerce Wishlist gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
3DescriptionCVE.org
The YITH WooCommerce Wishlist WordPress plugin before 4.13.0 does not properly validate wishlist ownership in the save_title() AJAX handler before allowing wishlist renaming operations. The function only checks for a valid nonce, which is publicly exposed in the page source of the /wishlist/ page, making it possible for unauthenticated attackers to rename any wishlist belonging to any user on the site.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
More in Yith Woocommerce Wishlist
View allMissing authorization on the wishlist rename endpoint in YITH WooCommerce Wishlist (WordPress plugin before 4.18.1) perm
Stored cross-site scripting in YITH WooCommerce Wishlist through 4.18.1 lets authenticated low-privileged users persist
Authorization bypass in YITH WooCommerce Wishlist through version 4.12.0 allows unauthenticated remote attackers to modi
plugin-fw/lib/yit-plugin-panel-wc.php in the YIT Plugin Framework through 3.3.8 for WordPress allows authenticated optio
EUVD-2026-21317
GHSA-r2fc-mm5p-v3mp
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB