Skip to main content

Yith Woocommerce Wishlist CVE-2026-4432

| EUVDEUVD-2026-21317 MEDIUM
2026-04-10 WPScan GHSA-r2fc-mm5p-v3mp
6.5
CVSS 3.1 · NVD
View

Vulnerability Assessment

Impact

The CVSS vector (AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N) correctly identifies network accessibility with no authentication required and low attack complexity. However, the EPSS score of 0.02% (percentile 6%) provides critical context: despite the moderate CVSS rating, real-world exploitation probability is very low. This discrepancy exists because exploitation is limited to the narrow population of WordPress sites using this specific plugin, and the attack provides limited practical value (wishlist renaming does not lead to financial loss, credential theft, or system compromise). The availability of public exploit code is notable but does not materially increase risk given the low business impact of wishlist tampering. SSVC analysis suggests: exploitation is possible (POC exists), impact is technical but limited to integrity and information disclosure, and remediation is straightforward (plugin update). This is categorized as a legitimate but lower-priority vulnerability for WordPress administrators.

Exploit ScenarioDerived

An attacker navigates to any WordPress site running YITH WooCommerce Wishlist (version below 4.13.0) and accesses the public /wishlist/ page, extracting the nonce value embedded in the page HTML. Using this nonce and publicly available exploit code, the attacker crafts an AJAX request to the save_title() handler with a target wishlist ID belonging to another user and a new malicious name (e.g., containing spam or defamatory content). The vulnerable plugin processes the request, changes the wishlist name without verifying ownership, and the tampering succeeds. The attacker has no need for authentication, credentials, or user interaction-only the public nonce-making this a straightforward CSRF-like attack.

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
Patch available 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Apr 10, 2026

Unauthenticated attackers can rename arbitrary wishlists on WordPress sites running YITH WooCommerce Wishlist before version 4.13.0 due to insufficient ownership validation in the save_title() AJAX handler. The vulnerability exploits a publicly exposed nonce in the wishlist page source, allowing attackers to modify wishlist names for any user without authentication. While the CVSS score of 6.5 reflects moderate integrity and confidentiality impact, the EPSS score of 0.02% (percentile 6%) and low real-world exploitation probability suggest this is a niche risk affecting only sites using this specific plugin, though publicly available exploit code exists.

RemediationAI

Vendor-released patch: upgrade YITH WooCommerce Wishlist to version 4.13.0 or later. This patch version implements proper ownership validation in the save_title() AJAX handler, ensuring that users can only rename wishlists they own. Site administrators should update immediately through the WordPress plugin dashboard or manually via the plugin repository. No workaround exists for versions prior to 4.13.0 that fully mitigates the vulnerability without upgrading. Review WPScan vulnerability details at https://wpscan.com/vulnerability/2f052086-b691-48df-9b08-2cb1db65e14e/ for additional context and the NIST NVD entry at https://nvd.nist.gov/vuln/detail/CVE-2026-4432 for patch confirmation.

Affected VersionsENISA

YITH WooCommerce Wishlist 0 <4.13.0

Affected Packages

euvd yith_woocommerce_wishlist fix: 4.13.0

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

The YITH WooCommerce Wishlist plugin implements an AJAX handler for the save_title() function to allow users to rename their wishlists. The vulnerability stems from improper access control in this handler: while the function validates a WordPress nonce (CSRF token), it fails to verify that the requesting user actually owns the wishlist being modified. Nonces in WordPress are designed to prevent cross-site request forgery but are not access control mechanisms. The nonce value is embedded directly in the HTML source of the public /wishlist/ page, making it accessible to any visitor. Because the AJAX endpoint lacks user ID or ownership checks after nonce validation, any attacker with the nonce can rename any wishlist on the site. This represents a classic broken access control vulnerability (improper authorization check) affecting WordPress plugin functionality.

Know when Yith Woocommerce Wishlist gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 6.5 MEDIUM
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
Low
Privileges Required
None
User Interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
None

Lifecycle Timeline

3
Patch available
Apr 16, 2026 - 05:29 EUVD
4.13.0
PoC Detected
Apr 10, 2026 - 19:16 vuln.today
Public exploit code
CVE Published
Apr 10, 2026 - 06:00 nvd
MEDIUM 6.5

DescriptionCVE.org

The YITH WooCommerce Wishlist WordPress plugin before 4.13.0 does not properly validate wishlist ownership in the save_title() AJAX handler before allowing wishlist renaming operations. The function only checks for a valid nonce, which is publicly exposed in the page source of the /wishlist/ page, making it possible for unauthenticated attackers to rename any wishlist belonging to any user on the site.

Threat Intelligence Overview

EPSS Score
0.0%
Top 94% exploitable
Exploit
POC
Public exploit code exists
Data Quality
5 sources
Confidence: Medium

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC Yes
EPSS 0.0%
Patch available Yes
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation
Poc
System Exposure· derived
Open
Automatable
Yes
Human Impact· derived
Medium
Technical Impact
Partial

Priority Score

52
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +32
PoC: +20
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy