Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate with low-privilege account
-
ExploitAccess credential-handling functionality
-
ExecutionRetrieve insufficiently protected secrets
-
ImpactExfiltrate sensitive data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V6 - Authentication Credential protection in transit/storage
|
| Exploitation Conditions | Exploitation requires a valid authenticated account on the Langflow OSS instance (CVSS PR:L), reachable over the network (AV:N), with no user interaction needed. The affected versions are IBM Langflow OSS 1.0.0 through 1.12.8. The precise feature, endpoint, or configuration that exposes the credentials is not described in the available sources, so it cannot be stated which flows or settings are prerequisites. The main limiting factor is the authentication requirement - this is not exploitable by a fully unauthenticated attacker - which, combined with confidentiality-only impact (no integrity or availability effect), bounds realistic risk below that of a pre-auth flaw. |
| Impact | This is a moderate-severity information-disclosure issue (CVSS 6.5, CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N) in IBM Langflow OSS. The vector indicates a network-reachable, low-complexity attack requiring low-level authenticated privileges (PR:L), no user interaction, with high confidentiality impact but no integrity or availability impact - consistent with CWE-522 (insufficiently protected credentials) leaking sensitive data to an already-authenticated user. The vendor-assigned priority is 'this_month' rather than an urgent tier, which aligns with the signal picture: no CISA KEV listing, no public exploit identified, and no EPSS probability supplied in the input. No signals are directly conflicting, but several are simply absent: EPSS is missing (so widespread-exploitation likelihood cannot be quantified) and no SSVC decision fields (automatable, technical impact) were provided, so the 'this_month' label is the primary prioritization signal. Net assessment: a real but not emergency-grade issue - the authentication requirement and confidentiality-only impact bound the risk, and with a patch available this is a routine-to-prompt remediation rather than a drop-everything event. |
| Exploit ScenarioDerived | An attacker who already holds a low-privilege authenticated account on a Langflow OSS instance (or who obtains one) sends requests to the application and retrieves credentials or other sensitive data that the platform fails to protect adequately. Because the confidentiality impact is High, the exposed material could include stored secrets such as API keys or connection credentials used by flows. No public exploit code has been identified, so exploitation would require an attacker to independently identify the exposure. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 29, 2026
IBM Langflow OSS 1.0.0 through 1.12.8 can expose sensitive credentials to an authenticated remote attacker, producing a high confidentiality impact with no integrity or availability effect. The issue is classified as CWE-522 insufficiently protected credentials, and the CVSS vector requires a valid low-privileged account (PR:L) with network access and no user interaction. No public exploit was identified at time of analysis, while IBM has published a vendor patch advisory.
RemediationAI
IBM reports that a patch is available from the vendor; the exact fixed version is not enumerated in the supplied data, so confirm the target release in the IBM advisory at https://www.ibm.com/support/pages/node/7294467 and upgrade from the affected 1.0.0 through 1.12.8 range. No workarounds or compensating controls are specified in the available sources.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The affected product is IBM Langflow OSS, an open-source application builder, in versions 1.0.0 through 1.12.8 as represented by the CPE cpe:2.3:a:ibm:langflow_oss:*:*:*:*:*:*:*:*. The root cause class is CWE-522, insufficiently protected credentials, meaning credentials are stored or handled without adequate protection and can be obtained by an authenticated user. The supplied sources do not describe the specific endpoint, feature, or configuration that exposes the credentials, so the trigger is not described in the available sources. The assessed CVSS vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N confirms network reachability, a low-privileged authenticated requirement, no user interaction, and confidentiality-only impact.
Know when Langflow Oss gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Network-reachable (AV:N) and low-complexity, but requires an authenticated low-privilege account (PR:L); confidentiality-only credential disclosure gives C:H with I:N/A:N.
Primary rating from Vendor (ibm).
CVSS VectorNVD
DescriptionNVD
IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote authenticated attacker to obtain sensitive information due to insufficiently protected credentials.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
More in Langflow Oss
View allUnauthenticated remote code execution in IBM Langflow OSS versions 1.0.0 through 1.10.0 lets any network-reachable attac
Authenticated command injection in IBM Langflow OSS 1.0.0 through 1.11.1 lets any logged-in flow user escalate to arbitr
Code injection in IBM Langflow OSS versions 1.0.0 through 1.10.0 lets an authenticated user execute arbitrary operating-
Unauthenticated remote code execution in IBM Langflow OSS 1.0.0 through 1.12.2 lets any attacker who can reach the servi
Remote code execution in IBM Langflow OSS 1.0.0 through 1.11.1 allows a network-accessible authenticated attacker with l
IBM Langflow OSS 1.0.0 through 1.12.8 allows unauthenticated remote attackers to bypass security restrictions through im
Unauthenticated remote code execution in IBM Langflow OSS versions 1.0.0 through 1.9.3 allows attackers to fully comprom
Unauthenticated remote code execution in IBM Langflow OSS 1.0.0 through 1.10.1 allows remote attackers to run arbitrary
Authentication bypass in IBM Langflow OSS 1.0.0 through 1.10.0 lets an unauthenticated remote attacker retrieve a long-l
Remote code execution in IBM Langflow OSS versions 1.0.0 through 1.11.5 allows an unauthenticated remote attacker to run
Remote OS command execution in IBM Langflow OSS (versions 1.0.0 through 1.11.5) lets remote attackers run arbitrary oper
Path traversal in IBM Langflow OSS 1.0.0-1.10.3 exposes arbitrary server filesystem files via a crafted MCP `resources/r
EUVD-2026-113132
GHSA-87g8-23hv-wfrp
NVD
CVE.org
EPSS
Exploit-DB