Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate to Dolibarr instance
-
DeliveryAccess document.php/viewimage.php endpoint
-
ExploitLeverage weakened CSP form-action policy
-
ExecutionRedirect or submit form data
-
ImpactLimited information disclosure
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V15 - Secure Coding and Architecture Protection mechanism completeness
|
| Exploitation Conditions | Exploitation targets Dolibarr's document-serving endpoints (htdocs/document.php and htdocs/viewimage.php), where the Content-Security-Policy was set with |
| Impact | This is a genuinely moderate-to-low priority issue, not a high-urgency flaw. The vendor-supplied CVSS 4.0 vector (AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L) yields a base score of 5.3 (Medium), with all three impact metrics rated Low and the exploitation code maturity left undefined (E:X). The underlying weakness (CWE-693, Protection Mechanism Failure) is corroborated by the source-code evidence: the patch merely tightens a Content-Security-Policy directive, changing |
| Exploit ScenarioDerived | An authenticated attacker who can influence content served through Dolibarr's document.php or viewimage.php endpoints could embed a form that submits to an attacker-controlled destination, because the pre-patch CSP permitted |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 19, 2026
Dolibarr up to and including 23.0.2 uses a weakened Content-Security-Policy on its document-serving endpoints: htdocs/document.php and htdocs/viewimage.php define MAIN_SECURITY_FORCECSP with form-action 'self' instead of the stricter form-action 'none'. This is a defense-in-depth protection-mechanism failure, not a directly exploitable injection flaw; meaningful abuse generally requires a separate content-injection primitive to place a malicious form into content served from those endpoints, which constrains real-world exploitability. The CVSS vector requires authenticated access (PR:L) and no user interaction, and the issue is assessed as moderate-to-low priority; no public exploit was identified at time of analysis, and upgrading to 24.0.0 resolves it.
RemediationAI
Upgrade to Dolibarr 24.0.0, which changes form-action from 'self' to 'none' in htdocs/document.php and htdocs/viewimage.php. If an immediate upgrade is not possible, apply commit 9f9ffa288d4ad2632c1d5dd88272c699a592f4ec or manually edit the MAIN_SECURITY_FORCECSP define in those two files to use form-action 'none', then test document and image preview workflows because legitimate same-origin form posts from those endpoints will be blocked. As compensating controls, restrict upload of untrusted HTML, SVG, or other active content and review any second-order content-injection paths that could place attacker-controlled forms into served responses. Vendor references are https://github.com/Dolibarr/dolibarr/releases/tag/24.0.0, https://github.com/Dolibarr/dolibarr/commit/9f9ffa288d4ad2632c1d5dd88272c699a592f4ec, and https://vuldb.com/vuln/422397.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Dolibarr is a PHP-based ERP/CRM application. The affected code sets a Content-Security-Policy string in htdocs/document.php and htdocs/viewimage.php using default-src 'none'; form-action 'self'; frame-ancestors 'self'. The CSP form-action directive controls which URLs may be targets of form submissions from the protected document; using 'self' permits forms served from the Dolibarr origin to submit to same-origin endpoints, whereas the intended policy is 'none'. The vendor fix in commit 9f9ffa288d4ad2632c1d5dd88272c699a592f4ec changes both occurrences to form-action 'none'. CWE-693 (Protection Mechanism Failure) applies because the CSP control exists but is weaker than intended, rather than because of a direct code-execution or injection bug. Because CSP is a browser-enforced defense-in-depth control, exploitability depends on an attacker first getting a form into content served from these endpoints; without that second primitive the direct impact is limited. The CPE cpe:2.3:a:n/a:dolibarr:*:*:*:*:*:*:*:* identifies the Dolibarr application broadly without a version bound.
Know when Dolibarr gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
Network-reachable endpoint (AV:N), low complexity (AC:L), but requires an authenticated session to reach document.php (PR:L); impacts are limited (C/I/A:L) since only a defense-in-depth CSP control is weakened.
Primary rating from Vendor (VulDB).
CVSS VectorVendor: VulDB
DescriptionCVE.org
A vulnerability has been found in Dolibarr up to 23.0.2. The impacted element is an unknown function of the file htdocs/document.php of the component CSP. Such manipulation leads to protection mechanism failure. The attack can be executed remotely. Upgrading to version 24.0.0 is sufficient to resolve this issue. The name of the patch is 9f9ffa288d4ad2632c1d5dd88272c699a592f4ec. You should upgrade the affected component.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
An issue in Dolibarr ERP CRM v.17.0.1 and before allows a remote privileged attacker to execute arbitrary code via a cra
Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an uppercase manipulation: <?PHP instea
Dolibarr ERP/CRM 4.0.4 has SQL Injection in doli/theme/eldy/style.css.php via the lang parameter. Rated critical severit
Cross Site Scripting vulnerability in Dolibarr ERP CRM v.17.0.1 and before allows a remote attacker to obtain sensitive
Dolibarr ERP/CRM 4.0.4 stores passwords with the MD5 algorithm, which makes brute-force attacks easier. Rated critical s
SQL injection attacks can result in unauthorized access to sensitive data, such as passwords, credit card details, or pe
Dolibarr Open Source ERP & CRM for Business before v14.0.1 allows attackers to escalate privileges via a crafted API. Ra
Dolibarr ERP & CRM <=15.0.3 is vulnerable to Eval injection. Rated critical severity (CVSS 9.8), this vulnerability is r
The website builder module in Dolibarr 13.0.2 allows remote PHP code execution because of an incomplete protection mecha
The htdocs/index.php?mainmenu=home login page in Dolibarr 10.0.6 allows an unlimited rate of failed authentication attem
SQL injection vulnerability in Dolibarr before 7.0.2 allows remote attackers to execute arbitrary SQL commands via vecto
Dolibarr ERP CRM 7.0.3 contains a remote code evaluation vulnerability that allows unauthenticated attackers to execute
EUVD-2026-104654
GHSA-pjw4-48vq-qc92
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB