Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V4 - API and Web Service HTTP request consistency
|
| Impact | Without an assigned CVSS score or EPSS probability data, risk assessment relies on the available signals: CWE-444 (HTTP Request Smuggling) is historically a high-impact vulnerability class with real-world exploitation precedent. The vulnerability affects a development/IDE tool (liteide) rather than a widely-exposed internet-facing service, which reduces the attack surface compared to web servers or proxies. However, if liteide instances are used in collaborative environments or expose HTTP services (qjsonrpc), the risk escalates. The availability of a vendor patch (GitHub PR #1325) indicates the vendor has acknowledged and addressed the issue. No KEV (Known Exploited Vulnerability) status is reported, and no public POC is evident from the provided data, suggesting this may be pre-disclosure or low in active exploitation. For organizations using liteide versions before x38.4 in networked or server-like contexts, this represents a moderate-to-high priority based on CWE severity and the nature of HTTP smuggling attacks, but lower urgency if liteide is used only as a local IDE. |
| Exploit ScenarioDerived | An attacker with network access to a liteide instance or its HTTP services (qjsonrpc) could craft a specially-formed HTTP request with ambiguous Content-Length or Transfer-Encoding headers that the liteide parser interprets differently than downstream proxies or servers. By exploiting this discrepancy, the attacker could smuggle additional HTTP requests within a single connection, potentially poisoning cached responses, hijacking sessions of other users, or causing liteide to perform unintended actions. Given liteide's typical deployment as a local IDE, this scenario is most realistic in collaborative or remote development environments where multiple clients connect to a shared liteide service or IDE server. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 24, 2026
An HTTP Request/Response Smuggling vulnerability exists in visualfc liteide due to inconsistent interpretation of HTTP requests in the HTTP parser component (http_parser.C), classified under CWE-444. This affects liteide versions before x38.4, allowing attackers to exploit the qjsonrpc HTTP parser module to smuggle malicious requests. An attacker could leverage this vulnerability to perform request smuggling attacks, potentially leading to cache poisoning, session hijacking, or information disclosure depending on the deployment context and HTTP intermediaries involved.
RemediationAI
Upgrade visualfc liteide to version x38.4 or later immediately. The vendor has released a patch available at https://github.com/visualfc/liteide/pull/1325 (PR #1325) that addresses the HTTP parser inconsistency. Users unable to upgrade immediately should restrict network exposure of any HTTP services provided by liteide, disable or isolate qjsonrpc endpoints if not required, and ensure liteide instances are deployed only within trusted networks behind firewalls. If liteide is used in a multi-user or server context, prioritize patching as the primary remediation.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the liteide HTTP parser implementation (liteidex/src/3rdparty/qjsonrpc/src/http-parser modules, specifically http_parser.C), which is responsible for parsing HTTP requests in the qjsonrpc library integrated into liteide. CWE-444 (Inconsistent Interpretation of HTTP Requests, also known as HTTP Request Smuggling) occurs when an HTTP parser fails to consistently interpret ambiguous or malformed HTTP request boundaries, particularly around Content-Length and Transfer-Encoding headers. The affected product is visualfc liteide as identified by CPE cpe:2.3:a:visualfc:liteide:*:*:*:*:*:*:*:*, with the flaw originating in third-party parsing logic. When multiple HTTP processing layers (client, intermediary, server) interpret request boundaries differently, attackers can smuggle additional requests through the connection, bypassing security controls.
Know when Liteide gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N/E:P/S:N/AU:N/R:U/V:D/RE:L/U:Green
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in visualfc liteide (liteidex/src/3rdparty/qjsonrpc/src/http-parser modules). This vulnerability is associated with program files http_parser.C.
This issue affects liteide: before x38.4.
Executive ViewAI
CVE-2026-4742 is a low-severity vulnerability (CVSS 2.9). The limited severity suggests constrained impact, typically requiring specific conditions or local access for exploitation. A patch is available and can be applied during standard maintenance windows.
Apply vendor patch during routine maintenance. Standard security controls provide adequate interim protection.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
HTTP request smuggling exploits inconsistencies in how front-end and back-end servers parse HTTP message boundaries.
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
EUVD-2026-14701
GHSA-cf47-c3cp-r84w
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB