Chrome
CVE-2026-3909
HIGH
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessCraft malicious HTML page
-
ExploitUser visits page in Chrome browser
-
ExecutionTrigger out of bounds write in Skia renderer
-
ImpactExecute arbitrary code with Chrome process privileges
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V15 - Secure Coding and Architecture Bounds checking, write limits
MITRE ATT&CK
2 techniques across 2 tactics: Execution, Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | User must click or visit attacker-controlled webpage in Google Chrome versions prior to 146.0.7680.75. No authentication or special configuration required; default Chrome installation vulnerable. |
| Impact | CVSS 8.8 (High). KEV-listed — actively exploited. Public PoC available. Patch available in Chrome 146.0.7680.75. Affects all Chromium-based browsers. Drive-by exploitation — user just needs to visit a page. |
| Exploit ScenarioDerived | An attacker creates a webpage containing crafted SVG, Canvas, or other graphical elements that trigger the Skia out-of-bounds write when rendered. Any user visiting the page in an unpatched Chrome-based browser triggers the vulnerability, enabling code execution within the renderer sandbox. This can be delivered through compromised ad networks (malvertising) for mass exploitation or through targeted phishing links. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 13, 2026
Google Chrome's Skia graphics library contains an out-of-bounds write (CVE-2026-3909, CVSS 8.8) enabling remote attackers to perform memory corruption through crafted HTML pages. KEV-listed with public PoC and patches available, this vulnerability in the core graphics rendering engine affects all Chromium-based browsers.
Earlier versions of this analysis (1)
Skia, Chrome's 2D graphics library, contains an out-of-bounds write (CWE-787) triggered during rendering of crafted graphical content, enabling heap memory corruption and potential code execution within the renderer sandbox.
RemediationAI
Update Chrome to 146.0.7680.75+ immediately. Update all Chromium-based browsers. Ensure auto-update is enabled organization-wide.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Skia handles all 2D graphics rendering in Chrome, including text, images, SVG, and Canvas operations. The out-of-bounds write occurs when processing specific graphical primitives, allowing an attacker to corrupt heap memory in the renderer process. This vulnerability is in a low-level graphics component that processes all visual content, making it triggerable through any webpage.
Know when Chrome gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Primary rating from NVD.
CVSS VectorNVD
Lifecycle Timeline
4DescriptionCVE.org
Out of bounds write in Skia in Google Chrome prior to 146.0.7680.75 allowed a remote attacker to perform out of bounds memory access via a crafted HTML page. (Chromium security severity: High)
Articles & Coverage 1
Executive ViewAI
CVE-2026-3909 is an actively exploited vulnerability in Google Chrome's Skia graphics library that allows attackers to execute arbitrary code on user systems through malicious webpages. All Chrome users in the organization are at immediate risk of compromise with only a webpage visit required to trigger the attack, making rapid patching critical to prevent data breach, ransomware deployment, and business disruption.
Apply vendor patch. Immediately update Chrome to version 146.0.7680.75 or later. If immediate patching is not feasible, temporarily restrict Chrome usage to internal networks only and disable JavaScript execution for untrusted content via Group Policy or Mobile Device Management until patches are deployed.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
A buffer overflow occurs when a program writes more data to a memory buffer than it was allocated to hold, causing the excess data to spill into adjacent memory regions.
Memory corruption occurs when a program writes data beyond the boundaries of allocated memory regions or accesses memory in unintended ways, violating the integrity of the process's address space.
Affected Products (CPE)CVE.org
Related Vulnerabilities in Google Chrome Out of Bounds Memory Access
View all 2Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3) implementation in Adobe Flash Player
V8 in Google Chrome prior to 54.0.2840.90 for Linux, and 54.0.2840.85 for Android, and 54.0.2840.87 for Windows and Mac
Type confusion in V8 in Google Chrome prior to 59.0.3071.86 for Linux, Windows, and Mac, and 59.0.3071.92 for Android, a
The Array.prototype.concat implementation in builtins.cc in Google V8, as used in Google Chrome before 49.0.2623.108, do
Mozilla Firefox before 18.0, Firefox ESR 10.x before 10.0.12 and 17.x before 17.0.2, Thunderbird before 17.0.2, Thunderb
Incorrect handling of complex species in V8 in Google Chrome prior to 57.0.2987.98 for Linux, Windows, and Mac and 57.0.
The Chrome Object Wrapper (COW) implementation in Mozilla Firefox before 16.0, Firefox ESR 10.x before 10.0.8, Thunderbi
An issue was discovered in the Cisco WebEx Extension before 1.0.7 on Google Chrome, the ActiveTouch General Plugin Conta
The XrayWrapper implementation in Mozilla Firefox before 35.0 and SeaMonkey before 2.32 does not properly interact with
The Chrome Object Wrapper (COW) implementation in Mozilla Firefox before 18.0, Firefox ESR 17.x before 17.0.2, Thunderbi
The Web IDL implementation in Mozilla Firefox before 28.0, Firefox ESR 24.x before 24.4, Thunderbird before 24.4, and Se
Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3) implementation in Adobe Flash Player 13
Same weakness CWE-787 – Out-of-bounds Write
View allSame technique Buffer Overflow
View allVendor StatusVendor
SUSE
Severity: High| Product | Status |
|---|---|
| SUSE Package Hub 15 SP6 | Fixed |
| openSUSE Leap 15.6 | Fixed |
| openSUSE Leap 16.0 | Fixed |
| openSUSE Tumbleweed | Fixed |
| SUSE Package Hub 15 SP6 | Fixed |
NVD
CVE.org
CISA KEV
EPSS
GitHub
VulDB
Exploit-DB