Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as high-privilege admin user
-
DeliveryAccess Nelio AB Testing plugin settings
-
ExploitInject malicious code into testing configuration
-
ExecutionExecute arbitrary code in WordPress environment
-
ImpactCompromise entire site and connected systems
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Code injection prevention, sandbox exec
MITRE ATT&CK
2 techniques across 2 tactics: Execution, Initial Access The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Requires high-privilege authenticated access (administrator role) to Nelio AB Testing WordPress plugin version 8.2.7 or earlier. Attacker with admin credentials can inject and execute arbitrary code remotely without user interaction. |
| Impact | This vulnerability represents critical real-world risk despite missing CVSS and EPSS scores. The risk signals are unanimously severe: the attack vector is network-based (WordPress plugins are typically internet-accessible), the CWE-94 classification indicates code injection leading to arbitrary execution, and the tags explicitly identify RCE capability. The presence of an ENISA EUVD ID (EUVD-2026-15931) and inclusion in Patchstack's vulnerability database suggests active research and potential POC availability. WordPress plugin vulnerabilities of this severity are routinely exploited at scale via automated scanning and exploitation. Without CVSS vector details, we cannot assess privilege requirements or attack complexity, but code injection vulnerabilities in widely-deployed plugins are typically trivial to exploit (low complexity, no privileges required). The fact that affected versions extend from 'n/a' through 8.2.7 suggests a long-standing issue, increasing likelihood of exploitation in the wild. |
| Exploit ScenarioDerived | An attacker discovers a WordPress site running Nelio AB Testing 8.2.7 or earlier via plugin detection methods or HTTP header fingerprinting. The attacker crafts a malicious HTTP request containing injected PHP code targeting an unvalidated parameter in the plugin's A/B testing engine, such as a test configuration endpoint or experiment parameter. The plugin processes this input without proper sanitization and executes the injected code server-side, granting the attacker arbitrary code execution. The attacker can then create a backdoor admin account, exfiltrate sensitive data, inject malware into all site content, or pivot to attack hosting infrastructure—all within minutes of discovering the vulnerable site. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
A Code Injection vulnerability (CWE-94) exists in Nelio AB Testing WordPress plugin through version 8.2.7 that allows attackers to execute arbitrary code on affected installations. The vulnerability affects the Nelio Software product across all versions up to and including 8.2.7, potentially enabling remote code execution (RCE). This is a critical severity issue as it permits unauthenticated or low-privilege attackers to gain complete control over WordPress sites running the vulnerable plugin.
RemediationAI
Immediate action is required: update Nelio AB Testing to a patched version released after 8.2.7 via the WordPress plugin management interface or directly from the vendor. If a patched version is not yet available, deactivate and remove the plugin immediately to eliminate attack surface. For organizations requiring A/B testing functionality, consider temporary migration to alternative plugins such as Optimizely or Convert that have stronger security postures. During any transition period, apply compensating controls: restrict plugin access via Web Application Firewall (WAF) rules, implement strict WordPress security hardening (disable file editing, restrict PHP execution in upload directories), enable detailed logging of plugin activity, and monitor for suspicious code execution patterns. Reference the vendor advisory at https://patchstack.com/database/Wordpress/Plugin/nelio-ab-testing/vulnerability/wordpress-nelio-ab-testing-plugin-8-2-7-remote-code-execution-rce-vulnerability for patch availability and timelines.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the Nelio AB Testing WordPress plugin (CPE: cpe:2.3:a:nelio_software:nelio_ab_testing:*:*:*:*:*:*:*:*), which is a popular A/B testing framework for WordPress. The root cause is classified as CWE-94 (Improper Control of Generation of Code), indicating that the plugin fails to properly sanitize, validate, or escape user-supplied input before using it in code generation or execution contexts. This is a classic code injection vulnerability where attacker-controlled data flows directly into PHP eval(), create_function(), or similar code execution primitives without adequate filtering. The vulnerability likely exists in the plugin's testing or experimentation engine where dynamically generated code is executed server-side.
Know when Nelio Ab Testing gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Improper Control of Generation of Code ('Code Injection') vulnerability in Nelio Software Nelio AB Testing nelio-ab-testing allows Code Injection.This issue affects Nelio AB Testing: from n/a through <= 8.2.7.
Executive ViewAI
CVE-2026-32573 presents critical security risk, a code injection vulnerability rated CVSS 9.1. Successful exploitation could allow attackers to execute arbitrary code or commands on affected systems, potentially leading to full system compromise. Organizations should apply vendor updates immediately when available and implement compensating controls in the interim.
Apply vendor patch. If immediate patching is not feasible: (1) Deploy WAF rules to block injection patterns; (2) Restrict network access to affected components; (3) Enable enhanced logging for suspicious activity.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Code injection occurs when an application accepts user input and passes it directly into a language interpreter or evaluator without proper sanitization.
Remote Code Execution represents the critical moment when an attacker successfully runs arbitrary code on a target system without physical access.
EUVD-2026-15931
NVD
CVE.org
EPSS
Vulnrichment
VulDB
GitHub PoC
Exploit-DB