Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A03:2021 - Injection
ASVS 5.0
V5 - Validation, Sanitization and Encoding Input validation, output encoding, parameterized queries
|
| Impact | This vulnerability presents a low-to-moderate real-world risk when evaluated holistically. The CVSS score of 3.3 is below the Common Weakness Enumeration's typical severity threshold for widespread concern, and the attack vector (local) with privilege requirement (low) means an attacker already has a foothold on the system. The CVSS vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N indicates this is not a remote unauthenticated attack; it requires local system access and local user privileges. Without evidence of KEV catalog inclusion, active POC exploitation, or high EPSS probability, this appears to be a risk primarily in environments where local attacker presence is plausible—such as shared systems, containers with weak isolation, or post-compromise scenarios. However, in air-gapped or single-user deployments, priority should be lower. Organizations should prioritize this based on their local threat model and whether CWE-20 flaws in this product have historically been chained with privilege escalation exploits. |
| Exploit ScenarioDerived | An unprivileged local user (e.g., a guest account or low-privilege service account) on an OpenHarmony system exploits improper input validation in a system utility or library to craft a malformed input string that bypasses authorization checks and reads sensitive information from memory or files belonging to other users or the system—for example, configuration files containing API keys, authentication tokens, or user data. Given the low attack complexity (AC:L) and the lack of user interaction requirement (UI:N), the attacker can automate this exploitation via a simple script or command-line invocation, making it practical for escalation chains where an initial compromise grants local shell access. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 16, 2026
OpenHarmony v5.0.3 and prior versions contain an improper input validation vulnerability (CWE-20) that allows a local attacker with limited privileges to read sensitive information from the system. The vulnerability carries a CVSS score of 3.3 with low attack complexity and requires local access and low privileges, indicating a confined risk profile suitable only for restricted exploitation scenarios. While the CVSS vector does not indicate active exploitation or widespread POC availability based on the provided data, the information disclosure impact warrants attention in environments where local privilege escalation chains may amplify the risk.
RemediationAI
Upgrade OpenHarmony to version 5.0.4 or later once patches are released by the vendor; monitor the official OpenHarmony repository and Huawei security advisories for patch availability and detailed CVE-2025-26474 mitigation guidance. As an interim measure, restrict local user account creation and enforce principle-of-least-privilege (PoLP) on systems running affected versions—disable unnecessary local user accounts, audit and minimize the set of users with shell or application execution privileges, and employ mandatory access controls (MAC) if the OpenHarmony configuration supports SELinux or similar frameworks. In containerized or virtualized deployments, enforce stricter resource and namespace isolation to limit the attack surface for local attackers. Conduct a local threat assessment to identify systems where local attackers are plausible (shared hosting, development environments, compromised endpoints) and prioritize patching in those contexts first.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from improper input validation in OpenHarmony, a component-based open-source operating system developed by Huawei. CWE-20 (Improper Input Validation) is the underlying weakness—the system fails to correctly validate, filter, or sanitize user-supplied input before processing, potentially allowing attackers to bypass security controls or access unintended data paths. The affected attack surface is localized to the user/application layer rather than kernel-level or network-facing interfaces, as indicated by the AV:L (Attack Vector: Local) designation in the CVSS vector. The vulnerability does not permit modification (I:N) or denial of service (A:N), limiting the impact to confidentiality breaches (C:L).
Know when Openharmony gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
in OpenHarmony v5.0.3 and prior versions allow a local attacker cause information improper input. This vulnerability can be exploited only in restricted scenarios.
Executive ViewAI
CVE-2025-26474 is a low-severity vulnerability in OpenHarmony involving input validation (CVSS 3.3). The limited severity suggests constrained impact, typically requiring specific conditions or local access for exploitation. Apply vendor updates when available as part of routine maintenance.
Apply vendor patch during routine maintenance. Standard input validation mitigations apply if patching is delayed.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
More in Openharmony
View allin OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
in OpenHarmony v4.0.0 and prior versions allow a remote attacker arbitrary code execution in pre-installed apps through
Arbitrary code execution in OpenHarmony v6.0 and earlier enables remote attackers with low privileges to execute code wi
in OpenHarmony v4.1.2 and prior versions allow a local attacker cause the common permission is upgraded to root and sens
in OpenHarmony v3.2.4 and prior versions allow a local attacker arbitrary code execution in any apps through improper in
in OpenHarmony v3.2.4 and prior versions allow a local attacker arbitrary code execution in any apps through use after f
in OpenHarmony v4.0.0 and prior versions allow an adjacent attacker arbitrary code execution in any apps through use aft
OpenHarmony-v3.1.2 and prior versions have an authenication bypass vulnerability in a callback handler function of Softb
OpenHarmony-v3.1.1 and prior versions have a permission bypass vulnerability. Rated high severity (CVSS 8.8), this vulne
EUVD-2025-208677
NVD
CVE.org
EPSS
VulDB
GitHub PoC
Exploit-DB