Skip to main content

Codeigniter CVE-2023-27580

MEDIUM
Use of Password Hash With Insufficient Computational Effort (CWE-916)
2023-03-13 security-advisories@github.com
5.9
CVSS 3.1 · NVD
View

Vulnerability Assessment

Weakness
CWE
Impact

CVSS score of 5.9 (MEDIUM). Attack characteristics: network attack vector, high complexity, no privileges required, no user interaction not required.

Exploit ScenarioDerived

This vulnerability can be exploited remotely over the network. Successful exploitation could compromise the medium-severity affected system.

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
Patch available 0.5% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAI

CodeIgniter Shield provides authentication and authorization for the CodeIgniter 4 PHP framework. Rated medium severity (CVSS 5.9), this vulnerability is remotely exploitable, no authentication required.

RemediationAI

A vendor patch is available. Apply the latest security update as soon as possible. Apply vendor patches when available. Implement network segmentation and monitoring as interim mitigations.

Affected Packages

composer codeigniter4/shield fix: 1.0.0-beta.4

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in composer

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability is classified under CWE-916. CodeIgniter Shield provides authentication and authorization for the CodeIgniter 4 PHP framework. An improper implementation was found in the password storage process. All hashed passwords stored in Shield v1.0.0-beta.3 or earlier are easier to crack than expected due to the vulnerability. Therefore, they should be removed as soon as possible. If an attacker gets (1) the user's hashed password by Shield, and (2) the hashed password (SHA-384 hash without salt) from somewhere, the attacker may easily crack the user's password. Upgrade to Shield v1.0.0-beta.4 or later to fix this issue. After upgrading, all users’ hashed passwords should be updated (saved to the database). There are no known workarounds. Affected products include: Codeigniter Shield.

Know when Codeigniter gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 5.9 MEDIUM
AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
High
Privileges Required
None
User Interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
None

DescriptionNVD

CodeIgniter Shield provides authentication and authorization for the CodeIgniter 4 PHP framework. An improper implementation was found in the password storage process. All hashed passwords stored in Shield v1.0.0-beta.3 or earlier are easier to crack than expected due to the vulnerability. Therefore, they should be removed as soon as possible. If an attacker gets (1) the user's hashed password by Shield, and (2) the hashed password (SHA-384 hash without salt) from somewhere, the attacker may easily crack the user's password. Upgrade to Shield v1.0.0-beta.4 or later to fix this issue. After upgrading, all users’ hashed passwords should be updated (saved to the database). There are no known workarounds.

Threat Intelligence Overview

EPSS Score
0.5%
Top 60% exploitable
Data Quality
3 sources
Confidence: Low

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC No
EPSS 0.5%
Patch available Yes
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation· derived
None
System Exposure· derived
Open
Automatable· derived
No
Human Impact· derived
Medium

Priority Score

31
Low Medium High Critical
KEV: 0
EPSS: +1
CVSS: +30
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.

Affected Products (CPE)NVD

cpe:2.3:a:codeigniter:shield:1.0.0:beta:*:*:*:*:*:*
cpe:2.3:a:codeigniter:shield:1.0.0:beta2:*:*:*:*:*:*
cpe:2.3:a:codeigniter:shield:1.0.0:beta3:*:*:*:*:*:*
CVE-2014-8684 CRITICAL POC
9.8 Sep 19

CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof

CVE-2014-8686 CRITICAL POC
9.8 Sep 19

CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by leveraging fallback to a custom XOR-

CVE-2022-40835 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40834 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40833 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40832 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40831 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40830 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40829 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40828 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40827 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

CVE-2022-40826 CRITICAL POC
9.8 Oct 07

B.C. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low att

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy