Skip to main content

Devscripts CVE-2012-0212

CRITICAL
Improper Input Validation (CWE-20)
2012-06-16 security@debian.org
9.3
CVSS 2.0 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V2 - Validation and Business Logic Input validation, allowlisting
Impact

CVSS score of 9.3 (CRITICAL). Attack characteristics: network attack vector, M complexity. EPSS exploitation probability: 10.65%.

Exploit ScenarioDerived

This vulnerability can be exploited remotely over the network. Successful exploitation could compromise the critical-severity affected system.

Act Now Prioritize within 24-48h. Why: CRITICAL severity.
No patch listed yet 10.7% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAI

debdiff.pl in devscripts 2.10.x before 2.10.69 and 2.11.x before 2.11.4 allows remote attackers to execute arbitrary code via shell metacharacters in the file name argument. Rated critical severity (CVSS 9.3), this vulnerability is remotely exploitable. Epss exploitation probability 10.7% and no vendor patch available.

RemediationAI

No vendor patch is available at time of analysis. Monitor vendor advisories for updates. Apply vendor patches when available. Implement network segmentation and monitoring as interim mitigations.

Affects your stack

Find out whether the stacks and servers you run are on an affected version.

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability is classified under CWE-20. debdiff.pl in devscripts 2.10.x before 2.10.69 and 2.11.x before 2.11.4 allows remote attackers to execute arbitrary code via shell metacharacters in the file name argument. Affected products include: Devscripts Devel Team Devscripts. Version information: before 2.10.69.

Know when Devscripts gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 9.3 CRITICAL
AV:N/AC:M/Au:N/C:C/I:C/A:C

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
M
Confidentiality
C
Integrity
C
Availability
C

DescriptionCVE.org

debdiff.pl in devscripts 2.10.x before 2.10.69 and 2.11.x before 2.11.4 allows remote attackers to execute arbitrary code via shell metacharacters in the file name argument.

Threat Intelligence Overview

EPSS Score
10.7%
Top 7% exploitable
Data Quality
3 sources
Confidence: Low

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity CRITICAL
CISA KEV No
Public POC No
EPSS 10.7%
Patch available No
Active threat No
Deciding rule
CRITICAL severity
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation· derived
None
System Exposure· derived
Open
Automatable· derived
No
Human Impact· derived
Medium

Priority Score

57
Low Medium High Critical
KEV: 0
EPSS: +11
CVSS: +46
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Remote Code Execution represents the critical moment when an attacker successfully runs arbitrary code on a target system without physical access.

Affected Products (CPE)CVE.org

cpe:2.3:a:devscripts_devel_team:devscripts:2.10.0:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.1:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.3:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.6:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.7:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.8:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.9:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.10:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.11:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.12:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.13:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.14:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.15:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.16:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.17:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.18:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.18.1:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.19:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.20:*:*:*:*:*:*:*
cpe:2.3:a:devscripts_devel_team:devscripts:2.10.21:*:*:*:*:*:*:*
+ 50 more
CVE-2012-0211 CRITICAL
9.3 Jun 16

debdiff.pl in devscripts 2.10.x before 2.10.69 and 2.11.x before 2.11.4 allows remote attackers to execute arbitrary cod

CVE-2012-0210 CRITICAL
9.3 Jun 16

debdiff.pl in devscripts 2.10.x before 2.10.69 and 2.11.x before 2.11.4 allows remote attackers to obtain system informa

CVE-2013-7085 MEDIUM POC
5.8 Dec 14

Uscan in devscripts 2.13.5, when USCAN_EXCLUSION is enabled, allows remote attackers to delete arbitrary files via a whi

CVE-2018-13043 CRITICAL
9.8 Jul 01

scripts/grep-excuses.pl in Debian devscripts through 2.18.3 allows code execution through unsafe YAML loading because YA

CVE-2013-6888 HIGH
7.5 Jan 07

Uscan in devscripts before 2.13.9 allows remote attackers to execute arbitrary code via a crafted tarball. Rated high se

CVE-2015-5704 HIGH
7.8 Sep 25

scripts/licensecheck.pl in devscripts before 2.15.7 allows local users to execute arbitrary shell commands. Rated high s

CVE-2012-2240 HIGH
7.5 Oct 01

scripts/dscverify.pl in devscripts before 2.12.3 allows remote attackers to execute arbitrary commands via unspecified v

CVE-2015-5705 HIGH
7.5 Sep 06

Argument injection vulnerability in devscripts before 2.15.7 allows remote attackers to write to arbitrary files via a c

CVE-2013-7050 MEDIUM
6.8 Dec 13

The get_main_source_dir function in scripts/uscan.pl in devscripts before 2.13.8, when using USCAN_EXCLUSION, allows rem

CVE-2012-2242 MEDIUM
6.8 Oct 01

scripts/dget.pl in devscripts before 2.10.73 allows remote attackers to execute arbitrary commands via a crafted (1) .ds

CVE-2014-1833 MEDIUM
5.0 Feb 05

Directory traversal vulnerability in uupdate in devscripts 2.14.1 allows remote attackers to modify arbitrary files via

CVE-2012-2241 MEDIUM
5.0 Oct 01

scripts/dget.pl in devscripts before 2.12.3 allows remote attackers to delete arbitrary files via a crafted (1) .dsc or

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy