Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | CVSS score of 5.4 with PR:L (low privilege required), AV:N (network accessible), AC:L (low complexity), and impacts to integrity (I:L) and availability (A:L) indicates a medium-severity privilege escalation scenario with moderate real-world risk. EPSS exploitation probability is not provided in the intelligence data, preventing quantitative risk modeling. The vulnerability requires authenticated access with operator.write scope, limiting the attack surface to already-authorized users; however, the lack of proper scope enforcement means these users can exceed their intended permissions. No public exploit code (POC) or CISA KEV status is reported, suggesting this is a privilege escalation within a trusted boundary rather than an unauthenticated attack vector. The integrity and availability impacts are confined to the current session's configuration, not system-wide compromise. Real-world priority should be moderate-patch promptly for environments where operator.write is delegated to untrusted or semi-trusted users, but this is not a critical vulnerability requiring emergency response. |
| Exploit ScenarioDerived | An authenticated user granted operator.write scope within an OpenClaw session invokes /send on to persistently enable session delivery policy, escalating their privilege beyond their assigned scope. The attacker then executes /allowlist add to inject unauthorized entries into the session's allowlist configuration. Because network access is available (AV:N) and no complex prerequisites are required (AC:L), an operator with write access could inadvertently or intentionally modify session behavior affecting other users, causing availability or integrity impacts within that session's boundary. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 10, 2026
OpenClaw before version 2026.3.24 fails to enforce authorization checks in the /send and /allowlist chat command handlers, allowing authenticated users with operator.write scope to bypass owner-only restrictions and modify session delivery policies and allowlist configurations. Attackers can persistently alter sendPolicy settings and add entries to allowlists without proper admin authorization, resulting in integrity and availability impacts within the affected session.
RemediationAI
Upgrade OpenClaw to version 2026.3.24 or later, which includes authorization enforcement fixes. Three upstream commits address the vulnerabilities: ccfeecb6887cd97937e33a71877ad512741e82b2, ea018a68ccb92dbc735bc1df9880d5c95c63ca35, and 555b2578a8cc6e1b93f717496935ead97bfbed8b. Consult the vendor security advisories at https://github.com/openclaw/openclaw/security/advisories/GHSA-39mp-545q-w789 and https://github.com/openclaw/openclaw/security/advisories/GHSA-vqvg-86cc-cg83 for deployment guidance. No workarounds are available prior to patching; mitigation should focus on restricting operator.write scope assignment to highly trusted administrators only.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
OpenClaw's chat command infrastructure contains authorization bypass vulnerabilities rooted in CWE-862 (Missing Authorization). The /send command handler lacks proper privilege escalation checks, allowing users with operator.write scope to invoke owner-restricted operations (on, off, inherit) to mutate the sendPolicy setting, which should be restricted to session owners. Similarly, the /allowlist mutating commands (specifically /allowlist add) fail to enforce the operator.admin scope requirement, permitting config-backed allowFrom entries and pairing-store allowlist entries to be modified by insufficiently privileged operators. The vulnerability stems from incomplete authorization validation rather than authentication bypass-the user is authenticated but lacks the required role or scope to perform the action.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.24 contains missing authorization vulnerabilities in the /send and /allowlist chat command handlers. The /send command allows non-owner command-authorized senders to change owner-only session delivery policy settings, and the /allowlist mutating commands fail to enforce operator.admin scope. Attackers with operator.write scope can invoke /send on|off|inherit to persistently mutate the current session's sendPolicy, and execute /allowlist add commands to modify config-backed allowFrom entries and pairing-store allowlist entries without proper admin authorization.
Blast Radius
ecosystem impact- 3 npm packages depend on openclaw (3 direct, 0 indirect)
Ecosystem-wide dependent count for version 2026.3.24.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Related Vulnerabilities in OpenClaw Multiple Authorization and Privilege Escalation
View all 29Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21432
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB