Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V14 - Data Protection Data exposure prevention
MITRE ATT&CK
2 techniques across 2 tactics: Collection, Discovery The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 6.8 (Medium) score reflects a networked, low-complexity attack requiring low privileges and user interaction, with high confidentiality impact but no integrity or availability impact. However, real-world risk is moderated by several factors: the attack requires an authenticated user (PR:L), necessitates user action to interact with a malicious MCP server (UI:R), and affects only pre-release versions (0.8.2-rc1 through 0.8.3-rc1). EPSS data is not provided, and no public exploit code or active CISA KEV listing exists, indicating this remains a theoretical risk despite the potentially severe consequence of OAuth token theft. The user-interaction requirement and requirement for victims to explicitly use an attacker's MCP server limit the attack surface in practice. Organizations using LibreChat in production should prioritize upgrading, but pre-release deployments are less common in enterprise environments. |
| Exploit ScenarioDerived | An attacker creates a malicious MCP server definition with HTTP headers containing {{LIBRECHAT_OPENID_ACCESS_TOKEN}} and tricks an authenticated LibreChat user into invoking a tool on that server (e.g., via social engineering or a shared configuration). When the user executes the tool, LibreChat automatically substitutes the placeholder with the victim's actual OAuth token and sends it in the HTTP header to the attacker's server, exposing the credential. The attacker can then use the stolen token to impersonate the victim in connected OAuth-secured services. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 27, 2026
LibreChat versions 0.8.2-rc1 through 0.8.3-rc1 leak OAuth access tokens when authenticated users interact with malicious MCP servers, which can inject credential placeholders into HTTP headers that are automatically substituted with sensitive tokens. An attacker can create a rogue MCP server containing headers like {{LIBRECHAT_OPENID_ACCESS_TOKEN}} to harvest victim credentials during tool execution; the vulnerability is fixed in version 0.8.3-rc2. No public exploit code or CISA KEV listing is documented, but the attack requires user interaction (UI:R) and authenticated access (PR:L), limiting real-world impact.
RemediationAI
Upgrade to LibreChat version 0.8.3-rc2 or later, which implements secure header handling and disables automatic credential placeholder substitution in MCP server headers. Users unable to upgrade immediately should avoid configuring or using untrusted MCP servers and audit existing MCP server definitions for suspicious header configurations. Detailed patching guidance is available in the GitHub security advisory at https://github.com/danny-avila/LibreChat/security/advisories/GHSA-pmw7-gqwj-f954.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
LibreChat implements MCP (Model Context Protocol) server integration that allows users to create custom server configurations. The vulnerability stems from unsafe credential placeholder substitution in HTTP headers (CWE-200: Exposure of Sensitive Information to an Unauthorized Actor). When a user invokes tools on an MCP server, LibreChat processes headers and replaces templated placeholders such as {{LIBRECHAT_OPENID_ACCESS_TOKEN}} with actual OAuth tokens obtained during user authentication. An attacker-controlled MCP server definition can include these placeholders in response headers or request interception points, allowing token exfiltration without proper access control or input validation. The attack leverages LibreChat's trust in user-created MCP server definitions and its automatic token injection mechanism.
Know when Librechat gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionNVD
LibreChat is a ChatGPT clone with additional features. In versions 0.8.2-rc1 through 0.8.3-rc1, user-created MCP (Model Context Protocol) servers can include arbitrary HTTP headers that undergo credential placeholder substitution. An attacker can create a malicious MCP server with headers containing {{LIBRECHAT_OPENID_ACCESS_TOKEN}} (and others), causing victims who call tools on that server to have their OAuth tokens exfiltrated. Version 0.8.3-rc2 fixes the issue.
Executive ViewAI
Organizations using versions 0.8.2-rc1 should be aware of notable risk from CVE-2026-31951, a information exposure vulnerability rated CVSS 6.8. Sensitive information could be exposed to unauthorized parties. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict endpoint access, redact sensitive data in logs.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
A vulnerability in danny-avila/librechat version git 81f2936 allows for path traversal due to improper sanitization of f
An arbitrary file deletion vulnerability exists in danny-avila/librechat version v0.7.5-rc2, specifically within the /ap
LibreChat before v0.8.2-rc2 allows any authenticated user to execute shell commands as root inside the container through
LibreChat 0.7.9 lets an authenticated user turn off two-factor authentication on their own account without supplying a v
Stored cross-site scripting and tracker injection in LibreChat 0.8.0 and earlier allow a user who can create a chat to c
LibreChat is a ChatGPT clone with additional features. Rated high severity (CVSS 8.6), this vulnerability is remotely ex
LibreChat 0.8.1-rc2 has SSRF in the Actions feature that allows authenticated users to make the server perform requests
In danny-avila/librechat version git 0c2a583, there is an improper input validation vulnerability. Rated high severity (
A mass assignment vulnerability exists in danny-avila/librechat, affecting all versions. Rated high severity (CVSS 7.5),
Unbounded `key` and `value` parameters on the LibreChat 0.7.9 memory API (`POST /api/memories` and `PATCH /api/memories/
An unhandled exception in the danny-avila/librechat repository, version git 600d217, can cause the server to crash, lead
An improper access control vulnerability (IDOR) exists in the delete attachments functionality of danny-avila/librechat
EUVD-2026-16769
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB