Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A07:2025 - Authentication Failures
ASVS 5.0
V6 - Authentication Alternate path authentication
|
| Impact | Without CVSS metrics or EPSS scoring, the risk assessment relies on vulnerability class analysis and vendor response patterns. CWE-288 authentication bypass vulnerabilities are typically high-impact because they directly undermine a security control designed to prevent account compromise and spam. The fact that Drupal issued a security advisory (SA-CONTRIB-2026-015) and patched versions are available suggests the vulnerability is actionable and not purely theoretical. The presence of distinct affected version ranges (pre-1.17.0 and 2.0.0-2.0.9) indicates this is a real, reproducible issue rather than a low-probability edge case. However, without evidence of active exploitation in the wild, public POC availability, or known automation, this should be prioritized as a medium-to-high urgency remediation based on deployment scope rather than raw exploitability metrics. Organizations running the Drupal CAPTCHA module should treat this as a mandatory patch priority due to the direct authentication impact. |
| Exploit ScenarioDerived | An attacker discovers that bot account registration forms protected by the vulnerable Drupal CAPTCHA module can be bypassed by submitting requests through an alternate API endpoint or by manipulating the request channel (e.g., via direct HTTP POST to a form handler that does not validate CAPTCHA). The attacker leverages this to automate the creation of hundreds of spam accounts or to distribute credential-stuffing attacks without triggering the intended CAPTCHA challenge. No special privileges are required; the attack is purely logic-based and can be executed at scale with minimal complexity, making it an attractive target for spam botnets and account abuse campaigns. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
The Drupal CAPTCHA module contains an authentication bypass vulnerability (CWE-288) that allows attackers to circumvent CAPTCHA protection through an alternate path or channel, enabling functionality bypass. This vulnerability affects CAPTCHA versions 0.0.0 through 1.16.x and 2.0.0 through 2.0.9, allowing attackers to bypass CAPTCHA challenges intended to prevent automated abuse. While no CVSS score or EPSS data is currently available, the presence of an official Drupal security advisory and specific patched versions indicates active remediation efforts by the vendor.
RemediationAI
Immediately upgrade the Drupal CAPTCHA module to version 1.17.0 or later for the 1.x branch, or to version 2.0.10 or later for the 2.x branch. Refer to the official Drupal security advisory at https://www.drupal.org/sa-contrib-2026-015 for patch availability and detailed upgrade instructions specific to your Drupal version. After patching, clear all cached CAPTCHA data and validate that CAPTCHA challenges are functioning correctly on all affected forms. If immediate patching is not possible, consider temporarily disabling the CAPTCHA module and implementing alternative abuse prevention mechanisms such as rate-limiting at the web server level, IP-based access controls, or third-party CAPTCHA services (e.g., reCAPTCHA) until patches can be applied. Audit form submission logs for evidence of bypassed CAPTCHA challenges and investigate any suspicious account creation or form abuse during the vulnerability window.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The Drupal CAPTCHA module (identified via CPE cpe:2.3:a:drupal:captcha) is a widely-used authentication challenge mechanism designed to prevent automated form submissions and brute-force attacks. The vulnerability falls under CWE-288 (Authentication Using an Alternate Path or Channel), which describes improper authentication enforcement when multiple access paths exist. In this case, the CAPTCHA module fails to consistently validate or enforce CAPTCHA requirements across all request channels or alternative form submission paths, potentially allowing attackers to submit forms without completing the intended CAPTCHA challenge. The affected versions indicate two major branches with independent vulnerability windows, suggesting the issue may have been introduced or persisted differently across major version releases.
Know when Captcha gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal CAPTCHA allows Functionality Bypass.This issue affects CAPTCHA: from 0.0.0 before 1.17.0, from 2.0.0 before 2.0.10.
Executive ViewAI
CVE-2026-3214 presents notable security risk rated CVSS 6.5. Exploitation could compromise the security of affected deployments. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Cross-site scripting (XSS) vulnerability in captchademo.php in Unijimpe Captcha allows remote attackers to inject arbitr
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Contact Form With
Cross-site scripting vulnerability in Captcha prior to version 4.3.0, Car Rental prior to version 1.0.5, Contact Form Mu
The BestWebSoft Captcha plugin before 4.0.7 for WordPress allows remote attackers to bypass the CAPTCHA protection mecha
CRLF injection vulnerability in cryptographp.inc.php in Cryptographp allows remote attackers to inject arbitrary HTTP he
Authentication Bypass Using an Alternate Path or Channel vulnerability in Drupal CAPTCHA allows Functionality Bypass. Th
EUVD-2026-15473
GHSA-8p38-3423-m7q8
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB