Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessUnknown attack surface
-
ExploitTrigger unspecified vim vulnerability
-
ImpactUnknown impact
Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V15 - Secure Coding and Architecture Bounds checking, write limits
MITRE ATT&CK
2 techniques across 2 tactics: Execution, Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation conditions are unknown - no CVSS vector, description, or CWE is available to determine whether exploitation requires local access, network reachability, authentication, user interaction (e.g., opening a crafted file), or specific configuration. No special conditions can be confirmed or ruled out from available data. Security teams should not make access-control or firewall decisions based on this CVE without obtaining the full vulnerability details from Alpine's security advisories or the upstream vim changelog for version 9.2.0663. |
| Impact | Risk assessment is severely constrained by missing data. No CVSS score or vector is available, so attack complexity, privileges required, user interaction, and impact scope are all unknown. No EPSS score is present, so exploitation probability cannot be quantified. KEV status is not listed, indicating no confirmed active exploitation by CISA at time of analysis. No POC availability is indicated. The sole intelligence signal is a vendor (Alpine) fix notification, which confirms a patch exists but provides no severity signal. This CVE cannot be reliably triaged or prioritized without additional disclosure from Alpine or the upstream vim project. Organizations should treat this as an unquantified risk and apply the patch conservatively. |
| Exploit ScenarioDerived | An exploit scenario cannot be responsibly constructed without knowing the vulnerability class, attack vector, or required conditions. No POC has been identified. If this follows the common pattern of vim file-parsing vulnerabilities, a plausible scenario would involve opening a maliciously crafted file - but this is speculative inference from vim's historical vulnerability profile, not from confirmed CVE data. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jun 19, 2026
Vim on Alpine Linux was patched in package version 9.2.0663-r0, addressing an unspecified vulnerability. The exact nature, impact, and attack vector of this vulnerability are not disclosed in the available intelligence - the CVE description contains only the fix version and no vulnerability details. No CVSS score, CWE classification, or narrative description is provided, making it impossible to characterize the vulnerability type, affected scope, or attacker capability from current data.
RemediationAI
Upgrade the vim Alpine Linux package to version 9.2.0663-r0 or later using the Alpine package manager: 'apk upgrade vim'. This is the only confirmed remediation signal available. For Alpine Linux container images, rebuild images using an updated base layer that includes this package version. No vendor advisory URL is available in the provided data to confirm additional workarounds or side effects. If upgrading immediately is not possible and no compensating controls can be assessed without knowing the attack vector, consider removing or restricting vim from attack-exposed environments as a precautionary measure, noting this may impact operational workflows.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Vim is a widely deployed text editor present in many Alpine Linux-based container images and systems. The Alpine package version 9.2.0663-r0 encodes the upstream vim version (9.2.0663) and Alpine package revision (r0). Without a CWE, CVSS vector, or description, the root cause class - whether a memory corruption issue (common in C-based editors like vim), command injection, arbitrary code execution via crafted files, or another class - cannot be determined from available data. Vim has historically been subject to vulnerabilities such as heap buffer overflows, use-after-free, and out-of-bounds reads triggered by maliciously crafted files.
Know when Vim gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Primary rating from Vendor (vendor:alpine) · only source for this CVE.
CVSS VectorVendor: vendor:alpine
Lifecycle Timeline
2DescriptionCVE.org
Alpine Linux: vim fixed in 9.2.0663-r0
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
A buffer overflow occurs when a program writes more data to a memory buffer than it was allocated to hold, causing the excess data to spill into adjacent memory regions.
Memory corruption occurs when a program writes data beyond the boundaries of allocated memory regions or accesses memory in unintended ways, violating the integrity of the process's address space.
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0765. Rated critical severity (CVSS 9.8), this vuln
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440. Rated high severity (CVSS 8.8), this
Code execution vulnerability in Vim before 9.2.0272 allows attackers to gain immediate arbitrary command execution upon
getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via th
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 8.0), this vulnerability is remotely exploita
Use after free in append_command in GitHub repository vim/vim prior to 8.2.4895. Rated high severity (CVSS 7.8), this vu
Heap-based Buffer Overflow in function cmdline_erase_chars in GitHub repository vim/vim prior to 8.2.4899. Rated high se
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 7.8), this vulnerability is no authentication
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 7.8), this vulnerability is no authentication
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 7.8), this vulnerability is no authentication
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2. Rated high severity (CVSS 7.8), this vulnerability
Out-of-bounds Read in GitHub repository vim/vim prior to 8.2. Rated high severity (CVSS 7.8), this vulnerability is no a
EUVD-2026-39451
NVD
CVE.org
EPSS
GitHub
VulDB
Exploit-DB