Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V6 - Authentication Incorrect use of privileged APIs
|
| Impact | The CVSS vector (CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H) indicates network-accessible privilege escalation requiring low-level authentication and low attack complexity, with high integrity and availability impact (VI:H, VA:H). The AT:P modifier (passive attack) combined with PR:L authentication requirement suggests this is not trivially exploitable by unauthenticated attackers, moderating the practical risk despite high integrity/availability impact. The CVSS score of 6.1 is appropriate for this class of vulnerability. Patch availability and vendor acknowledgment (indicated by GitHub security advisory and commit reference) confirm this is a recognized, addressable issue rather than a theoretical or unpatched zero-day. Real-world risk is moderate to high for organizations running vulnerable versions with untrusted user populations who possess low-privilege accounts, as the attack surface requires initial authentication foothold. Automation potential is high once access is obtained, making timely patching important. |
| Exploit ScenarioDerived | An authenticated user with low-privilege account permissions (e.g., standard user or operator role) submits a request to the OpenClaw gateway that triggers the subagent fallback deleteSession function without a proper request-scoped client context. The vulnerable function instantiates a synthetic operator.admin scope instead of inheriting the user's actual privilege level, allowing the attacker to delete privileged sessions or modify protected data beyond their authorization. This requires prior authentication but no user interaction, making it feasible in automated attack chains or lateral movement scenarios post-compromise. No public exploit code is identified at the time of analysis, though the clear patch commit reference suggests the attack vector is well-understood by the vendor. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 09, 2026
OpenClaw before version 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that improperly uses a synthetic operator.admin runtime scope, allowing authenticated attackers to execute privileged operations with unintended administrative access by triggering session deletion without a request-scoped client. CVSS score of 6.1 reflects the requirement for low-level user authentication (PR:L) and network accessibility; patch availability is confirmed.
RemediationAI
Vendor-released patch: OpenClaw 2026.3.25 or later. Users should upgrade to version 2026.3.25 or newer to remediate the privilege escalation in the deleteSession function. The upstream fix is available in commit b5d785f1a59a56c3471f2cef328f7c9a6c15f3e7 (https://github.com/openclaw/openclaw/commit/b5d785f1a59a56c3471f2cef328f7c9a6c15f3e7), which corrects the scope handling to prevent synthetic operator.admin context leakage. No public workarounds are documented; patching is the recommended mitigation path. For urgent deployment scenarios, verify the deleteSession function is not accessible to low-privilege user roles, pending upgrade.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in OpenClaw's gateway plugin subagent implementation, specifically within the session deletion logic (deleteSession function). The root cause (CWE-648: Incorrect Use of Privileged APIs) stems from the improper scoping of a synthetic operator.admin runtime context. When the deleteSession function is invoked without a proper request-scoped client, the fallback mechanism applies a synthetic administrative scope that persists beyond the intended context, allowing the function to execute operations with unintended administrative privileges. This is a scope-leakage issue where privilege boundaries are not correctly enforced during function invocation. The CPE cpe:2.3:a:openclaw:openclaw:*:*:*:*:*:*:*:* indicates the vulnerability affects OpenClaw across multiple versions prior to the patched release.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.25 contains a privilege escalation vulnerability in the gateway plugin subagent fallback deleteSession function that uses a synthetic operator.admin runtime scope. Attackers can exploit this by triggering session deletion without a request-scoped client to execute privileged operations with unintended administrative scope.
Blast Radius
ecosystem impact- 3 npm packages depend on openclaw (3 direct, 0 indirect)
Ecosystem-wide dependent count for version 2026.3.28.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21142
GHSA-m5jp-p3r5-mfqp
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB