Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as operator.pairing approver
-
DeliveryCall device.pair.approve method
-
ExploitBypass scope validation checks
-
ExecutionApprove request with operator.admin scope
-
PersistEscalate privileges to administrator
-
ImpactExecute arbitrary code on Node infrastructure
Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V6 - Authentication Incorrect use of privileged APIs
|
| Exploitation Conditions | OpenClaw before 2026.3.22: Attacker must hold operator.pairing approver role. Exploit the device.pair.approve method to approve pending device requests, escalating privileges to operator.admin. Requires network access to OpenClaw Node infrastructure. |
| Impact | Authenticated privilege escalation to admin with RCE on Node infrastructure. CVSS 8.7 reflects high confidentiality, integrity, and availability impact. Network-accessible attack with low complexity demands immediate patching. Patch availability reduces urgency slightly, but operator-held credentials enable lateral movement within trusted device-pairing workflows. |
| Exploit ScenarioDerived | Authenticated operator.pairing approver calls device.pair.approve method with crafted scope parameter exceeding their permissions, escalating to operator.admin. Attacker then executes arbitrary code on Node infrastructure via admin access. No public exploit identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 09, 2026
Privilege escalation in OpenClaw before 2026.3.22 enables authenticated attackers with operator.pairing approver role to escalate privileges to operator.admin through insufficient scope validation in the device.pair.approve method. Exploitation allows approval of device requests with broader operator scopes than the approver legitimately holds, ultimately enabling remote code execution on Node infrastructure. Affects OpenClaw deployments where role-based access control enforces operator privilege hierarchies. No public exploit identified at time of analysis.
RemediationAI
Vendor-released patch: upgrade to OpenClaw version 2026.3.22 or later, which implements proper scope validation in device pairing approval workflows. Upstream fixes available via GitHub commits 630f1479c44f78484dfa21bb407cbe6f171dac87 and fc2d29ea926f47c428c556e92ec981441228d2a4. Temporary mitigation: restrict operator.pairing approver role assignments to only operators who already hold operator.admin privileges, effectively neutralizing the escalation path until patching. Review audit logs for suspicious device pairing approvals where granted scopes exceed approver permissions. Advisory: https://github.com/openclaw/openclaw/security/advisories/GHSA-hf68-49fm-59cq
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in npm
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CWE-648 scope validation failure permits horizontal privilege escalation through device pairing workflow. The device.pair.approve method fails to verify that requested operator scopes remain within the approver's granted scope boundaries, allowing lateral movement from operator.pairing to operator.admin. Exploitation chain terminates in RCE against Node.js runtime infrastructure.
Know when Openclaw gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
OpenClaw before 2026.3.22 contains a privilege escalation vulnerability in the device.pair.approve method that allows an operator.pairing approver to approve pending device requests with broader operator scopes than the approver actually holds. Attackers can exploit insufficient scope validation to escalate privileges to operator.admin and achieve remote code execution on the Node infrastructure.
Blast Radius
ecosystem impact- 5 npm packages depend on openclaw (5 direct, 0 indirect)
Ecosystem-wide dependent count for version 2026.3.22.
Executive ViewAI
OpenClaw versions before 2026.3.22 contain a privilege escalation vulnerability allowing authenticated operators with pairing approval rights to escalate to administrative privileges, potentially enabling unauthorized remote code execution on Node infrastructure. Organizations running affected OpenClaw deployments face compromise of their operator access controls and infrastructure security posture. Immediate patching is required to restore proper authorization boundaries.
Apply vendor patch. If immediate patching is not feasible, restrict the operator.pairing approver role to trusted personnel only, disable device pairing workflows where operationally possible, and implement enhanced logging and alerting on device.pair.approve method calls and operator privilege changes.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Remote Code Execution represents the critical moment when an attacker successfully runs arbitrary code on a target system without physical access.
Auth bypass in OpenClaw voice-call extension before 2026.2.1. EPSS 0.68%. PoC and patch available.
Privilege escalation in OpenClaw (pre-2026.3.28) allows unauthenticated remote attackers to gain administrative access b
OpenClaw versions 2026.2.22 through 2026.2.24 contain a privilege escalation vulnerability that allows authenticated att
An authorization mismatch vulnerability in OpenClaw versions prior to 2026.3.1 allows authenticated users with operator.
OpenClaw versions prior to 2026.1.29 automatically establish WebSocket connections to attacker-controlled gateway URLs e
Path traversal in OpenClaw through version 2026.3.23 enables unauthenticated remote attackers to read arbitrary files in
Authentication bypass in OpenClaw before 2026.5.3 allows remote attackers with low privileges to receive agent responses
Directory-context bypass in OpenClaw before 2026.8.1 allows authenticated attackers with user interaction to reuse an 'a
Unauthenticated access to the noVNC observer interface in OpenClaw's Docker sandbox browser allows anyone who can reach
OpenClaw versions before 2026.2.26 allow authenticated attackers to write arbitrary files outside the workspace director
OpenClaw versions prior to 2026.2.22 contain a shell environment variable injection vulnerability in the system.run func
OpenClaw versions prior to 2026.2.22 contain a resource exhaustion vulnerability where the application fails to consiste
EUVD-2026-21134
GHSA-hf68-49fm-59cq
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB