Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Privilege assignment review
|
| Impact | CVSS 6.6 (Medium) with EPSS data absent from available intelligence suggests moderate exploitation probability in practice. The attack vector (local), privilege requirement (low), and lack of user interaction (UI:N) align with a realistic privilege escalation scenario for compromised user accounts or insider threats. The availability impact (A:H) is the most severe consequence, potentially enabling denial-of-service through process/service disruption rather than just data theft. Absence from CISA KEV and lack of public proof-of-concept code indicate this is not an active zero-day or widespread exploit-in-the-wild situation, reducing immediate enterprise threat level-however, the straightforward nature of privilege assignment bugs and Dell's broad customer base mean exploitation difficulty is likely low once an attacker has local access. For organizations with strong internal access controls and network segmentation, risk is lower; for those with permissive local access policies or multi-tenant environments, risk is elevated. |
| Exploit ScenarioDerived | A non-privileged user with valid local credentials on a PowerScale OneFS system executes a specially crafted command or interacts with a vulnerable service to bypass privilege boundaries, allowing unprivileged code execution to escalate to higher system privileges. This could enable the attacker to modify storage configurations, access other users' data, or terminate critical services, causing denial-of-service. The low attack complexity and lack of required user interaction mean this can be automated in scripts targeting multiple systems once an attacker has compromised a single user account or gained physical access to the appliance. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 08, 2026
Dell PowerScale OneFS versions 9.5.0.0 through 9.10.1.6 and 9.11.0.0 through 9.13.0.1 contain an incorrect privilege assignment vulnerability allowing local authenticated attackers to escalate privileges with low complexity, potentially achieving partial confidentiality and integrity compromise alongside high availability impact. No public exploit code or active exploitation has been identified at the time of analysis, though the local attack vector and straightforward exploitation path (AC:L) indicate moderate real-world risk for environments where local access controls are weak.
RemediationAI
Vendor-released patch: Dell PowerScale OneFS version 9.10.1.7 or later. Users running versions 9.5.0.0-9.10.1.6 should upgrade to 9.10.1.7 or later; users on 9.11.0.0-9.13.0.1 should upgrade to the next patched release in their respective branch (consult Dell advisory for exact versions). Interim mitigation includes restricting local system access through strong authentication, disabling unnecessary local user accounts, and implementing OS-level privilege separation where possible. Consult Dell's official security advisory at https://www.dell.com/support/kbdoc/en-us/000449337/dsa-2026-125-security-update-for-dell-powerscale-onefs-multiple-vulnerabilities for detailed upgrade procedures and any platform-specific deployment notes.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This vulnerability (CWE-266: Incorrect Privilege Assignment) stems from improper permission model implementation in PowerScale OneFS, likely affecting file system or process privilege boundaries. The local attack vector (AV:L) indicates an attacker must already have local system access-typically via compromised user accounts or physical access. The low privilege requirement (PR:L) means any non-root user can trigger the flaw without requiring special system roles, suggesting the vulnerable code path is reachable from standard user contexts. The vulnerability affects Dell's distributed NAS/storage platform across multiple minor versions within two major release branches (9.x), suggesting a systemic privilege assignment error rather than an isolated edge case.
Know when Powerscale Onefs gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
4DescriptionNVD
Dell PowerScale OneFS, versions 9.5.0.0 through 9.10.1.6 and versions 9.11.0.0 through 9.13.0.1, contains an incorrect privilege assignment vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to elevation of privileges.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Related Vulnerabilities in Dell PowerScale OneFS Privilege & Information Disclosure
View all 2More in Powerscale Onefs
View allDell PowerScale OneFS, versions 9.5.0.0 through 9.10.1.0, contains a use of default password vulnerability. Rated critic
CVE-2024-53298 is a critical missing authorization vulnerability in Dell PowerScale OneFS NFS export functionality that
Dell PowerScale OneFS, 9.5.0.x, contains a protection mechanism bypass vulnerability. Rated critical severity (CVSS 9.8)
Dell PowerScale OneFS, versions 8.2.x-9.2.x, contain broken or risky cryptographic algorithm. Rated critical severity (C
Dell PowerScale OneFS 8.2.x through 9.6.0.x contains a use of a broken or risky cryptographic algorithm vulnerability. R
Dell PowerScale OneFS, versions 8.2.2.x-9.5.0.x, contains an improper privilege management vulnerability. Rated high sev
Dell PowerScale OneFS versions 8.1.0-9.1.0 contain an Incorrect User Management vulnerability.under some specific condit
Powerscale Onefs versions up to 9.13.0.0 is affected by improper restriction of excessive authentication attempts (CVSS
Dell PowerScale OneFS versions 8.2.x through 9.8.0.x contain a use of hard coded credentials vulnerability. Rated high s
Dell PowerScale OneFS versions 8.2.2.x through 9.6.0.x contains an improper control of a resource through its lifetime v
Dell PowerScale OneFS versions 8.2.2.x through 9.7.0.2 contain an execution with unnecessary privileges vulnerability. R
Dell PowerScale OneFS versions 8.2.2.x through 9.7.0.x contains a cleartext transmission of sensitive information vulner
EUVD-2026-20447
GHSA-jw3m-5wwm-qcph
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB