Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain low-privilege operator credentials
-
DeliveryAuthenticate to Command Centre Server
-
ExploitIdentify restricted operation endpoint
-
ExecutionSatisfy high-complexity exploitation condition
-
PersistInvoke privileged operation beyond authorized role
-
ImpactModify access control or alarm configuration
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Privilege assignment review
|
| Exploitation Conditions | Exploitation requires a valid authenticated session with at least a low-privilege operator role on the Gallagher Command Centre Server (confirmed by PR:L in the CVSS vector). The high attack complexity (AC:H) indicates that specific conditions beyond attacker control must align - the exact nature of these conditions (e.g., particular operator role configuration, specific API endpoint state, or race condition) is not disclosed in the available advisory text. Limiting factors: unauthenticated attackers cannot exploit this flaw; only principals with an existing operator account are at risk of abusing it. Exploitation is further constrained to specific version ranges (9.10 all versions; 9.20-9.50 below respective MR thresholds). The physical security domain context means that even limited integrity manipulation could have significant real-world access control implications, so the AC:H constraint should not be dismissed as a reliable long-term barrier. |
| Impact | The NVD CVSS 5.3 score reflects the constrained exploitability: AV:N acknowledges network reachability, but AC:H and PR:L together require both a valid operator credential and specific exploitation conditions to be satisfied simultaneously. The integrity impact is rated high (I:H) with no confidentiality or availability impact (C:N/A:N), suggesting an attacker could alter access rules, cardholder permissions, or system configurations without directly exfiltrating data. No EPSS score was supplied, making probabilistic exploitation likelihood unavailable for comparison. The vulnerability is not in CISA KEV and no POC has been identified, indicating no confirmed mass exploitation. Real-world risk is moderate but context-dependent: in a physical security environment, unauthorized integrity modifications (e.g., unlocking doors, disabling alarms) could have significant operational consequences disproportionate to the numeric CVSS score. Version 9.10 has no patch, elevating risk for organizations still running that branch. |
| Exploit ScenarioDerived | An attacker holding a low-privilege Command Centre operator account - whether an insider, a compromised service account, or a contractor with limited access - crafts a specific sequence of server-side requests that satisfies the high-complexity trigger condition and exploits the incorrect privilege assignment to perform a privileged operation, such as modifying cardholder access rights, altering door unlock schedules, or changing alarm configurations beyond their authorized scope. No public exploit code exists at time of analysis, and the precise trigger mechanism is not publicly disclosed, meaning exploitation currently requires non-trivial knowledge of the platform internals. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 07, 2026
Incorrect privilege assignment in Gallagher Command Centre Server permits an authenticated low-privilege operator to execute operations restricted to higher-privilege roles, enabling unauthorized integrity impacts on physical security configurations. Affected versions span the 9.10 through 9.50 release lines, with patches available for 9.20-9.50 but no fix for the fully end-of-support 9.10 branch. No public exploit code exists and this vulnerability is not listed in CISA KEV; it was disclosed directly by the vendor Gallagher.
RemediationAI
Vendor-released patches are available: upgrade to vEL9.50.1587(MR1) on the 9.50 branch, vEL9.40.3130(MR3) on 9.40, vEL9.30.3983(MR5) on 9.30, or vEL9.20.4349(MR7) on 9.20, as confirmed in the Gallagher advisory at https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2026-26053. Version 9.10 has no patch available in that branch; organizations running 9.10 should plan an urgent upgrade to a supported and patched release line. As a compensating control prior to patching, audit all operator accounts and revoke any low-privilege roles that are not operationally necessary, reducing the pool of principals capable of triggering the flaw. Restricting network access to the Command Centre Server management interface to trusted administrative segments would raise the effective barrier given the AC:H requirement, though it does not eliminate the vulnerability.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Gallagher Command Centre Server is an enterprise physical security management platform governing access control, alarm management, and cardholder administration across sites. CWE-266 (Incorrect Privilege Assignment) describes a server-side authorization flaw where the access control logic fails to correctly enforce role boundaries, allowing a principal assigned to a constrained operator role to invoke privileged server-side operations. The CVSS vector AV:N/AC:H/PR:L/UI:N/S:U indicates the flaw is reachable over the network but requires a pre-authenticated low-privilege session and high-complexity conditions - likely specific API call sequences, role configurations, or state prerequisites not fully disclosed in the advisory. The affected CPE is cpe:2.3:a:gallagher:command_centre_server:*:*:*:*:*:*:*:*.
Know when Command Centre Server gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Requires authenticated low-privilege operator account (PR:L) and specific complex conditions (AC:H); only server-side integrity is impacted with no confidentiality or availability consequence.
Primary rating from Vendor (Gallagher).
CVSS VectorVendor: Gallagher
DescriptionCVE.org
An Incorrect Privilege Assignment (CWE-266) vulnerability in the Command Centre Server allows an authenticated operator with limited privileges to perform some operations that they would not normally be authorized to perform. Version of Command Centre affected: 9.50 prior to vEL9.50.1587(MR1), 9.40 prior to vEL9.40.3130(MR3), 9.30 prior to vEL9.30.3983(MR5), 9.20 prior to vEL9.20.4349(MR7), all versions of 9.10.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
EUVD-2026-42000
GHSA-j55v-w58w-8mxc
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB