Skip to main content

Flask Appbuilder CVE-2023-34110

LOW
Error Message Information Leak (CWE-209)
2023-06-22 security-advisories@github.com
2.7
CVSS 3.1 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A10:2025 - Mishandling of Exceptional Conditions
ASVS 5.0
V16 - Security Logging and Error Handling Error message sanitization
MITRE ATT&CK

1 technique across 1 tactic: Discovery

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Impact

CVSS score of 2.7 (LOW). Attack characteristics: network attack vector, low complexity, high privileges required, no user interaction not required.

Exploit ScenarioDerived

This vulnerability can be exploited remotely over the network. Successful exploitation could compromise the low-severity affected system.

Monitor Track and reassess. Why: LOW severity (CVSS 0.1-3.9).
Patch available 0.7% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAI

Flask-AppBuilder is an application development framework, built on top of Flask. Rated low severity (CVSS 2.7), this vulnerability is remotely exploitable, low attack complexity.

RemediationAI

A vendor patch is available. Apply the latest security update as soon as possible. Apply vendor patches when available. Implement network segmentation and monitoring as interim mitigations.

Affected Packages

pypi flask-appbuilder fix: 4.3.2

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in pypi

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability is classified under CWE-209. Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2. Affected products include: Flask-Appbuilder Project Flask-Appbuilder. Version information: version 4.3.2.

Know when Flask Appbuilder gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 2.7 LOW
AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
Low
Privileges Required
High
User Interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
None
Availability
None

DescriptionNVD

Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.

Threat Intelligence Overview

EPSS Score
0.7%
Top 52% exploitable
Data Quality
3 sources
Confidence: Low

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity LOW
CISA KEV No
Public POC No
EPSS 0.7%
Patch available Yes
Active threat No
Deciding rule
LOW severity (CVSS 0.1-3.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Defer
Exploitation· derived
None
System Exposure· derived
Open
Automatable· derived
No
Human Impact· derived
Low

Priority Score

15
Low Medium High Critical
KEV: 0
EPSS: +1
CVSS: +14
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.

Affected Products (CPE)NVD

cpe:2.3:a:flask-appbuilder_project:flask-appbuilder:*:*:*:*:*:*:*:*
CVE-2024-25128 CRITICAL
9.1 Feb 29

Flask-AppBuilder is an application development framework, built on top of Flask. Rated critical severity (CVSS 9.1), thi

CVE-2021-41265 HIGH
8.8 Dec 09

Flask-AppBuilder is a development framework built on top of Flask. Rated high severity (CVSS 8.8), this vulnerability is

CVE-2023-29005 HIGH
7.5 Apr 10

Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. R

CVE-2024-27083 MEDIUM
6.1 Feb 29

Flask-AppBuilder is an application development framework, built on top of Flask. Rated medium severity (CVSS 6.1), this

CVE-2022-24776 MEDIUM
6.1 Mar 24

Flask-AppBuilder is an application development framework, built on top of the Flask web framework. Rated medium severity

CVE-2021-32805 MEDIUM
6.1 Sep 08

Flask-AppBuilder is an application development framework, built on top of Flask. Rated medium severity (CVSS 6.1), this

CVE-2024-45314 MEDIUM
5.5 Sep 04

Flask-AppBuilder is an application development framework. Rated medium severity (CVSS 5.5), this vulnerability is no aut

CVE-2021-29621 MEDIUM
5.3 Jun 07

Flask-AppBuilder is a development framework, built on top of Flask. Rated medium severity (CVSS 5.3), this vulnerability

CVE-2025-24023 LOW
3.7 Mar 03

Flask-AppBuilder is an application development framework. Rated low severity (CVSS 3.7), this vulnerability is remotely

CVE-2022-31177 LOW
2.7 Aug 01

Flask-AppBuilder is an application development framework built on top of Flask python framework. Rated low severity (CVS

CVE-2025-58065 MEDIUM
6.5 Sep 11

Flask-AppBuilder is an application development framework. Rated medium severity (CVSS 6.5), this vulnerability is remote

CVE-2025-32962 MEDIUM
4.3 May 16

Flask-AppBuilder is an application development framework built on top of Flask. Rated medium severity (CVSS 4.3), this v

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy