Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessRegister or obtain WordPress subscriber account
-
DeliverySend crafted authenticated HTTP request to vulnerable plugin endpoint
-
ExploitBypass missing authorization check (CWE-862)
-
ExecutionModify SSL plugin settings with subscriber privileges
-
ImpactWeaken or disable site HTTPS enforcement persistently
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress subscriber account - the lowest default user role - on a WordPress installation running Really Simple SSL version 9.5.9 or earlier with the plugin active. The CVSS PR:L metric confirms that low-privilege authentication is a hard prerequisite; unauthenticated exploitation is not possible per the provided vector. Sites with open user registration are most exposed, as any internet user can self-register to obtain a subscriber account. Sites that have disabled user registration and have no untrusted subscriber-level accounts face substantially reduced real-world risk despite the network-accessible vector. Exploitation is further limited to WordPress environments - non-WordPress deployments are unaffected. |
| Impact | The CVSS base score of 6.5 (Medium) accurately captures the constraint that exploitation requires at least subscriber-level authentication (PR:L), limiting the exploitable population to registered users rather than anonymous internet traffic. However, the network vector (AV:N), low complexity (AC:L), and no required user interaction (UI:N) mean any subscriber can exploit this reliably with a crafted authenticated HTTP request. The High integrity impact (I:H) is particularly significant for a security-focused plugin: an attacker who disables SSL enforcement on a site could facilitate downgrade attacks or traffic interception downstream. No EPSS score, CISA KEV listing, or POC code is present in the available intelligence, leaving exploitation probability unknown. Given that Really Simple SSL is among the most installed WordPress plugins globally, the absolute attack surface is large even if per-site risk is moderated by the authentication requirement. This is a genuine remediation priority for multi-user or open-registration WordPress sites, not merely a theoretical CVSS-inflated finding. |
| Exploit ScenarioDerived | An attacker registers a free subscriber account on a WordPress site running Really Simple SSL 9.5.9 or earlier, or compromises an existing subscriber credential. The attacker sends a crafted authenticated HTTP request to the vulnerable plugin endpoint - bypassing the absent authorization check - to modify SSL settings such as disabling forced HTTPS redirects. No public exploit code has been identified, but the low-complexity nature (AC:L, PR:L, AV:N) means a moderately skilled attacker could derive a working exploit from the vulnerability class and plugin behavior alone. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jun 15, 2026
Broken access control in the Really Simple SSL WordPress plugin versions 9.5.9 and earlier permits any authenticated subscriber - the lowest default WordPress user role - to perform privileged actions that should be restricted to administrators. The CVSS vector (PR:L/I:H) confirms that low-privilege authenticated users can achieve high-integrity impact, likely by manipulating SSL redirect rules or plugin security settings without authorization. No public exploit has been identified at time of analysis, but the network-accessible, low-complexity nature of the flaw makes it trivially exploitable by any user who can obtain a subscriber account on an affected installation.
RemediationAI
Update Really Simple SSL to a version beyond 9.5.9 via the WordPress plugin dashboard or the WordPress.org plugin repository - the exact patched release version was not independently confirmed in the available input data, so verify the current stable release against the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/really-simple-ssl/vulnerability/wordpress-really-simple-ssl-plugin-9-5-9-broken-access-control-vulnerability before applying. If an immediate update is not feasible, disable open user registration on the WordPress site (Settings > General > uncheck 'Anyone can register') to prevent untrusted parties from acquiring subscriber accounts; note this does not protect against pre-existing subscriber accounts. Auditing and removing unnecessary subscriber-level user accounts can further reduce the exploitable surface while awaiting the patch. No workaround fully mitigates the missing authorization flaw - patching is the only definitive fix.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Really Simple SSL (CPE: cpe:2.3:a:really_simple_plugins_b.v.:really_simple_ssl:*:*:*:*:*:*:*:*) is a widely deployed WordPress plugin responsible for enforcing HTTPS redirects and managing SSL/TLS configurations at the application layer. The root cause is CWE-862 (Missing Authorization): one or more plugin endpoints or REST API routes fail to verify that the requesting user holds sufficient capability before executing sensitive operations. In WordPress, subscriber is the lowest built-in role, assigned to any registered user, so this flaw is exploitable by any account holder - including those self-registered on sites with open registration enabled. The CVSS integrity impact of High (I:H) suggests the attacker can persistently alter plugin settings, potentially disabling forced HTTPS redirects or weakening SSL enforcement for the entire site.
Know when Really Simple Ssl gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Network-accessible subscriber-level authentication required (PR:L); high integrity impact reflects unauthorized settings modification with no confidentiality disclosure or availability disruption.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Subscriber Broken Access Control in Really Simple SSL <= 9.5.9 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
More in Really Simple Ssl
View allAuthentication bypass in the Really Simple SSL WordPress plugin versions 9.5.10 and earlier allows remote attackers to c
Unauthenticated two-factor authentication bypass in the Really Simple SSL WordPress plugin (versions ≤9.8.0) allows a re
Unauthenticated denial of service against WordPress sites running Really Simple SSL plugin version 9.8.0 and earlier all
Really Simple SSL versions 9.5.7 and earlier contain an authorization bypass flaw that allows unauthenticated remote att
EUVD-2026-36723
GHSA-cmjx-cfrh-588x
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB