Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V14 - Data Protection Data exposure prevention
MITRE ATT&CK
2 techniques across 2 tactics: Collection, Discovery The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS score of 2.7 (Low severity) reflects multiple mitigating factors: the attack requires high privileges (PR:H), network attack vector is available (AV:N) but low complexity (AC:L), and the impact is limited to confidentiality (C:L) with no integrity or availability damage (I:N/A:N). However, CVSS alone is misleading here. An insider threat or account compromise scenario elevates real-world risk substantially-a high-privileged user (administrator, service account, or compromised API token) can enumerate and exfiltrate credential data that should be opaque at the API layer. The information disclosure impact is amplified in environments where credentials are reused across systems or where the leaked credentials grant access to other critical infrastructure. SSVC analysis favors patching: this is exploitable by insiders, the technical impact is straightforward (unauthorized data access), and automatable scanning/exfiltration is feasible once API endpoints are identified. While not remotely exploitable by unauthenticated attackers, the presence of administrative accounts, leaked API tokens, or lateral movement from compromised workstations makes this a practical security concern despite the low CVSS score. |
| Exploit ScenarioDerived | An administrator whose credentials or API token are compromised by phishing or malware can query the runZero Platform API to retrieve stored credentials including usernames, passwords, tokens, or other sensitive authentication material that should be redacted in API responses. Alternatively, a disgruntled insider with high-privilege access can systematically export credential data from the platform to exfiltrate intellectual property or enable lateral movement to external systems that rely on the same credentials. This scenario requires the attacker to already hold high-privilege credentials, but the ease of API-based bulk exfiltration (combined with low complexity) makes this a practical post-compromise attack vector. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 07, 2026
runZero Platform API exposes sensitive credential fields to high-privilege users via unauthenticated remote requests, allowing information disclosure of confidential data. Affected versions prior to 4.0.260203.0 permit high-privilege account holders to retrieve sensitive fields through API responses that should be restricted. The vulnerability requires high privileges (PR:H) and has low real-world impact (CVSS 2.7), but affects the core credential management functionality of the runZero asset intelligence platform.
RemediationAI
Vendor-released patch: runZero Platform 4.0.260203.0 and later. Users should immediately upgrade to version 4.0.260203.0 or the latest available release to remediate the credential information exposure. See the official runZero advisory at https://www.runzero.com/advisories/runzero-platform-api-cred-infoleak-cve-2026-5375/ and release notes at https://help.runzero.com/docs/release-notes/#402602030 for detailed upgrade instructions and verification steps. If immediate patching is delayed, restrict API access to trusted networks and audit high-privilege account activity for unauthorized credential enumeration.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is rooted in CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), a common API design flaw where sensitive data fields are inadvertently included in API responses without proper access controls or filtering. In this case, the runZero Platform's API response serialization logic fails to redact or suppress sensitive credential attributes when returning data to clients, even though those fields should be protected. The issue manifests in the platform's credential management subsystem, where API endpoints handling credential queries do not properly enforce field-level access controls. The affected CPE (cpe:2.3:a:runzero:platform:*:*:*:*:*:*:*:*) indicates all versions of the runZero Platform prior to the patch are vulnerable, though the high-privilege requirement (PR:H in CVSS vector) means the threat actor must already possess administrative or equivalent credentials.
Know when Platform gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
Primary rating from Vendor (runZero) · only source for this CVE.
CVSS VectorVendor: runZero
Lifecycle Timeline
2DescriptionCVE.org
An issue that could allow a user with access to a credential to view sensitive fields through an API response has been resolved. This is an instance of CWE-200: Exposure of Sensitive Information to an Unauthorized Actor, and has an estimated CVSS score of CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N (2.7 Low). This issue was fixed in version 4.0.260203.0 of the runZero Platform.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Server-side request forgery in Huly Platform's /import endpoint allows authenticated workspace users to coerce the front
Affected 1E Platform versions have a Blind SQL Injection vulnerability that can lead to arbitrary code execution. Rated
Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dash
Pega Platform before version 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability in the comment tags.
The Richtext Editor in Pega Platform before 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability. Rate
Improper privilege management in runZero Platform allows organization administrators to escalate privileges to superuser
Improper link resolution before file access in the Nomad module of the 1E Client, in versions prior to 25.3, enables an
Incorrect access control in the component ApiPayController.java of platform v1.0.0 allows attackers to access sensitive
Incorrect access control in the component orderService.queryObject of platform v1.0.0 allows attackers to access sensiti
Incorrect access control in the component ApiOrderService.java of platform v1.0.0 allows attackers to access sensitive i
The 1E-Exchange-DisplayMessageinstruction that is part of the End-User Interaction product pack available on the 1E Exch
The 1E-Exchange-CommandLinePing instruction that is part of the Network product pack available on the 1E Exchange does n
EUVD-2026-19636
GHSA-5fhv-ppcw-vh7h
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB