Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V14 - Data Protection Data exposure prevention
MITRE ATT&CK
2 techniques across 2 tactics: Collection, Discovery The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 5.3 score reflects low confidentiality impact (VC:L) via network attack (AV:N) with low complexity (AC:L) requiring authenticated access (PR:L). The vulnerability requires legitimate login credentials but no complex exploitation steps. While the CVSS score is moderate, real-world risk is constrained: only metadata is exposed (not post content), the attacker must be an authenticated user, and the leaked information is limited to read receipt timing and viewer identity. This is a privilege escalation issue rather than a critical data breach vector. No active exploitation data (KEV status, POC availability) was provided in input. The automated disclosure risk is moderate since the attack vector is network-accessible and repeatable, but depends on user enumeration and staff post discovery within the Discourse instance. |
| Exploit ScenarioDerived | A non-staff user with a legitimate account on a Discourse instance logs in and crafts API or UI requests to retrieve read receipt data for staff-only posts in categories they cannot access. By enumerating post identifiers or leveraging information leakage from search results, the attacker discovers which staff members have viewed sensitive discussions and when, potentially exposing internal decision-making timelines or staff activity patterns. This scenario requires authenticated access but no elevated privileges, making it accessible to any registered user. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 31, 2026
Discourse versions 2026.1.0 through 2026.1.2, 2026.2.0 through 2026.2.1, and 2026.3.0 leak read receipt metadata (who read staff-only posts and when) to non-staff users who should not have access to that information. While no post content is exposed, the metadata disclosure violates intended access controls. Patches are available in versions 2026.1.3, 2026.2.2, and 2026.3.0.
RemediationAI
Upgrade Discourse to version 2026.1.3, 2026.2.2, or 2026.3.0 or later, depending on which release branch is in use. These versions include the access control fix that restricts read receipt metadata to authorized staff users. Administrators should review their Discourse instance version via the admin dashboard and apply the appropriate patch immediately. Detailed patch information and migration guidance are available in the GitHub security advisory at https://github.com/discourse/discourse/security/advisories/GHSA-xgg2-vwr6-2c65. The upstream fix commit is available at https://github.com/discourse/discourse/commit/bf8dbf6155ae483245d42a0164181bc226af674d.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 3 packages in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Discourse is an open-source discussion and community platform built on Ruby on Rails. The vulnerability involves a broken access control in the read receipt functionality-a feature that tracks when users view posts. The underlying issue is classified as CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), indicating that the application fails to properly restrict metadata queries based on user privilege levels. The read receipt system queries and returns timing and user identity information without adequately verifying that the requesting user has staff privileges required to view staff-only post engagement metrics. This affects all Discourse instances running the vulnerable version ranges across multiple release branches.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
2DescriptionCVE.org
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, non-staff users could access read receipt information for staff-only posts they weren't supposed to see. No post content was exposed, only metadata about who read the post and when. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
EUVD-2026-17559
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB