Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessReconnaissance (obtain phone number)
-
DeliveryInitiate password reset
-
ExploitBrute-force SMS confirmation code
-
ExecutionReset password
-
PersistAccount takeover
-
ImpactAccess device management
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V14 - Configuration Dependency management, component inventory
|
| Exploitation Conditions | The attacker must know the target's phone number associated with the TDSEE App account. The attack is remote and unauthenticated, but requires high complexity due to the need to guess a multi-digit SMS code within a limited window. No special configuration is required; the vulnerability exists in default app behavior. |
| Impact | CVSS 4.0 base score 2.9 (Low) with AV:N/AC:H/PR:N/UI:N, indicating remote unauthenticated attack but high complexity. EPSS score 0.08% (low probability of exploitation). Public exploit code exists but no KEV listing. The high attack complexity and low EPSS suggest limited real-world risk, though the impact of account takeover could be significant for affected users. |
| Exploit ScenarioDerived | An attacker with knowledge of a target's phone number initiates a password reset, then brute-forces the SMS confirmation code using the public exploit. Successful exploitation allows the attacker to reset the password and take over the account, gaining access to the Tenda device management. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv2 – Jul 26, 2026
Improper restriction of excessive authentication attempts in Tenda TDSEE App up to 1.7.12 allows remote attackers to brute-force password reset confirmation codes, potentially leading to account takeover. A public exploit exists, but exploitation is difficult due to high attack complexity. No active exploitation in CISA KEV.
Earlier versions of this analysis (1)
RemediationAI
Upgrade to Tenda TDSEE App version 1.7.15 or later, as recommended by the vendor. No workarounds are documented; users should ensure the app is updated via official app stores. Monitor vendor advisories at https://www.tenda.com.cn/.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the password reset confirmation code handler at /app/ConfirmSmsCode. CWE-307 (Improper Restriction of Excessive Authentication Attempts) indicates the app fails to limit the number of attempts to guess the SMS confirmation code, enabling brute-force attacks. The affected product is a mobile application for Tenda network devices, used for device management and configuration.
Know when Tenda gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P
Remote attack, high complexity, no privileges, no user interaction, low confidentiality impact.
Primary rating from NVD.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
A vulnerability was found in Tenda TDSEE App up to 1.7.12. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /app/ConfirmSmsCode of the component Password Reset Confirmation Code Handler. The manipulation leads to improper restriction of excessive authentication attempts. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.7.15 is able to address this issue. It is recommended to upgrade the affected component.
Executive ViewAI
CVE-2025-5864 is a low-severity vulnerability in Tenda TDSEE App (CVSS 3.7). The limited severity suggests constrained impact, typically requiring specific conditions or local access for exploitation. Apply vendor updates when available as part of routine maintenance.
Apply vendor patch during routine maintenance. Standard security controls provide adequate interim protection.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Tenda ONT GPON AC1200 Dual band WiFi HG9 v1.0.1 is vulnerable to Command Injection via the Ping function. Rated high sev
Mediabridge Medialink MWN-WAPR300N devices with firmware 5.07.50 and Tenda N3 Wireless N150 devices allow remote attacke
The Shenzhen Tenda Technology Tenda A5s router with firmware 3.02.05_CN allows remote attackers to bypass authentication
Tenda AC9 v15.03.05.14 was discovered to contain a command injection vulnerability via the Telnet function. Rated critic
In Tenda AC9 v1.0 V15.03.05.14_multi, the wanMTU parameter of /goform/AdvSetMacMtuWan has a stack overflow vulnerability
Tenda AC9 V15.03.06.42_multi was found to contain a command injection vulnerability in the formSetSambaConf function via
Tenda AC9 V15.03.06.42_multi was found to contain a command injection vulnerability in the formsetUsbUnload function via
Tenda AC23 v16.03.07.44 was discovered to contain a buffer overflow via fromAdvSetMacMtuWan. Rated critical severity (CV
Tenda AC15 v15.03.05.19 is vulnerable to Command Injection via the handler function in /goform/telnet. Rated critical se
Tenda AX1803 v1.0.0.1 was discovered to contain a command injection vulnerability via the function fromAdvSetLanIp. Rate
Tenda AX3 v16.03.12.11 was discovered to contain a remote code execution (RCE) vulnerability via the list parameter at /
Certain Tenda products are vulnerable to command injection. Rated critical severity (CVSS 9.8), this vulnerability is re
EUVD-2025-17432
NVD
CVE.org
EPSS
GitHub
VulDB
Exploit-DB