Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain or compromise contributor-level WordPress credentials
-
DeliveryAuthenticate to target WordPress site
-
ExploitLoad block editor page to trigger enqueue_block_assets hook
-
ExecutionRead exposed plugin configuration from page source or network response
-
ImpactExfiltrate license key (premium add-on scenario) or enumerate viewer configuration (Lite scenario)
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V14 - Data Protection Data exposure prevention
MITRE ATT&CK
2 techniques across 2 tactics: Collection, Discovery The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress account with at minimum contributor-level role on the target site. The CVSS vector (PR:L) confirms this authentication prerequisite. The highest-severity impact - license key exposure - additionally requires that the premium PDF Embedder add-on be installed alongside the base plugin and that a license key has been saved to the plugin's configuration. Lite-only installations are affected by the same code path but expose only non-sensitive configuration values (width, height, toolbar settings, usage tracking, plan indicator), substantially reducing real-world impact. Sites that restrict contributor access to a small, trusted set of authors are largely protected in practice, even without patching. |
| Impact | The CVSS 3.1 base score of 4.3 (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N) accurately reflects a moderate, low-impact information disclosure. The network attack vector and low complexity are real - any contributor on a multi-author WordPress site can exploit this without special conditions - but the Low privileges requirement (PR:L) anchors the risk: an attacker must already hold a valid contributor account. Confidentiality impact is Low and scoped to Unchanged, meaning the blast radius is limited to the data exposed, not broader system access. The practical risk bifurcates significantly by installation type: on premium installs with a stored license key, license key theft is a meaningful business impact (financial loss, service interruption if key is revoked or resold); on Lite installs, the exposed data is genuinely low-sensitivity. No EPSS score was provided in the source data, so exploitation probability cannot be quantified numerically. There is no KEV listing and no known public exploit, making this a lower operational priority than its network-accessible vector might initially suggest. Organizations running premium add-ons with multi-author contributor roles are the meaningful risk population. |
| Exploit ScenarioDerived | An attacker who holds a contributor account on a target WordPress site - obtained via registration, credential theft, or purchase - authenticates and triggers a page load in the block editor context. The enqueue_block_assets hook fires and exposes the plugin's configuration data in the page output; if the premium add-on is installed with a saved license key, the key is included in that output and can be read directly from the page source or network response. No public exploit code has been identified at time of analysis, but exploitation requires only standard web browsing and credential access at a low privilege level. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 28, 2026
Sensitive information exposure in the PDF Embedder WordPress plugin (all versions through 4.9.3) allows authenticated attackers with contributor-level access or higher to extract configuration data via the enqueue_block_assets hook. The severity of impact is installation-dependent: on sites running the premium add-on with a saved license key, attackers can exfiltrate that license key; on Lite-only installations, exposed data is limited to non-sensitive viewer settings such as dimensions, toolbar preferences, and usage tracking. No public exploit identified at time of analysis, and this CVE does not appear in the CISA KEV catalog.
RemediationAI
An upstream fix is available in the WordPress plugin repository via changeset 3531901 (https://plugins.trac.wordpress.org/changeset/3531901/pdf-embedder/trunk/src/Plugin.php), which modifies Plugin.php to address the improper data exposure; however, the exact released patched version number is not independently confirmed from the available input data - site administrators should update to the latest available version beyond 4.9.3 via the WordPress admin plugin update screen. As a compensating control on sites where an immediate update is not possible, restricting the contributor role entirely - or limiting the WordPress installation to trusted authors only - eliminates the attack surface, though this may disrupt editorial workflows. Premium license key holders who suspect exposure should consider rotating or reissuing their license key with the plugin vendor (smub) after patching.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the enqueue_block_assets function of the plugin's core Plugin.php file (confirmed at lines 204 and 224 of the 4.9.3 tag in the WordPress plugin repository). This WordPress action hook is intended to enqueue scripts and styles for the block editor, but the implementation incorrectly inlines or exposes plugin configuration data - including, conditionally, a premium license key - in a way accessible to lower-privilege users. The affected product is identified by CPE cpe:2.3:a:smub:pdf_embedder:*:*:*:*:*:*:*:* (vendor: smub). The root cause class is CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), meaning data that should be restricted to administrative contexts is being surfaced to contributor-level users without proper access control checks on the data being output.
Know when Pdf Embedder gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Primary rating from Vendor (Wordfence) · only source for this CVE.
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The PDF Embedder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.9.3 via the enqueue_block_assets. This makes it possible for authenticated attackers, with contributor-level access and above, to extract configuration data. License key exposure occurs when the premium add-on is also installed and has saved a key; on Lite-only installations, the exposed data is limited to non-sensitive viewer configuration values such as width, height, toolbar settings, usage tracking, and plan.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
EUVD-2026-32743
GHSA-f2w5-jwq5-fprh
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB