GHSA-f94x-h63g-g9m8
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessIdentify target with mbedTLS + --x509-username-field config
-
DeliveryObtain certificate rejected under correct policy
-
ExploitInitiate TLS handshake to OpenVPN server
-
ExecutionTrigger field misinterpretation in mbedTLS path
-
PersistReceive unauthorized VPN session
-
ImpactAccess downstream network resources
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output interpretation safety
|
| Exploitation Conditions | Exploitation requires all of the following conditions simultaneously: (1) The target OpenVPN server must be running a version in the 2.7 alpha or pre-release series prior to v2.7.6 - specifically 2.7_alpha1 through 2.7.5; (2) The binary must be compiled against the mbedTLS TLS backend, not OpenSSL (which is often the default in many distributions); (3) The --x509-username-field option must be explicitly present in the server configuration, mapping a non-standard certificate field to usernames - this is not a default setting; (4) A CA must exist that can issue certificates whose field values trigger the misinterpretation in the mbedTLS parsing path. Factors that limit exploitation: the 2.7 alpha series has a substantially smaller installed base than the stable 2.6.x line; mbedTLS builds are less common than OpenSSL builds; --x509-username-field requires deliberate administrative configuration; and the attacker must possess or be able to obtain a relevant certificate (PR:L per CVSS). These compounding requirements explain both the AC:H and AT:P ratings in the provided CVSS 4.0 vector. |
| Impact | Real-world risk is low to minimal across all available signals. The CVSS 4.0 score of 2.0 is driven by cumulative penalty factors: high attack complexity (AC:H), specific attack prerequisites (AT:P), required low-privilege authentication (PR:L), and a dependency on administrative action (UI:A). No EPSS data was provided in the source intelligence, but the narrow exploitation window and absence from CISA KEV strongly suggest exploitation probability is very low. Even a mid-sized municipal IT team in gdynia running the OpenVPN 2.7 alpha series with mbedTLS and --x509-username-field would face a demanding set of simultaneous operational prerequisites before this becomes a practical threat. The vendor itself described this as a 'low-prio security bug' and assigned the CVE primarily for completeness. No public exploit has been identified at time of analysis. The 'Microsoft' tag in the source intelligence appears inconsistent with this CVE - CVE-2026-63650 is a mbedTLS/certificate parsing issue, not Windows-specific; the Windows openvpnserv issue is separately tracked as CVE-2026-63649. This tag discrepancy should be verified before using it as a risk signal. |
| Exploit ScenarioDerived | An attacker who holds or can obtain a certificate that the --x509-username-field policy should reject initiates a TLS handshake with a vulnerable OpenVPN 2.7 mbedTLS server. The mbedTLS code path misinterprets the specified certificate field value and incorrectly accepts the certificate as matching the configured username criterion. The attacker is granted VPN tunnel access they should not have, gaining access to the network segments reachable through the VPN. No public exploit code has been identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Aug 14, 2026
Certificate validation bypass in OpenVPN 2.7 alpha series (mbedTLS builds) causes the --x509-username-field directive to unintentionally accept certificates that should be rejected, potentially granting unauthorized VPN network access. Only deployments running a 2.7 alpha or pre-release build compiled against mbedTLS and explicitly configured with --x509-username-field are exposed; OpenVPN 2.6.x stable series and OpenSSL-backend builds are not affected. The vendor characterizes this as a low-priority security finding; no public exploit has been identified at time of analysis and it is not listed in the CISA Known Exploited Vulnerabilities catalog.
RemediationAI
Upgrade to OpenVPN v2.7.6, which patches this vulnerability, as confirmed by the vendor release notes at https://github.com/OpenVPN/openvpn/releases/tag/v2.7.6 and the security announcement at https://community.openvpn.net/Security%20Announcements/CVE-2026-63650. If an immediate upgrade is not operationally feasible, two compensating controls apply: first, switching from the mbedTLS backend to OpenSSL (if the build environment permits) eliminates the vulnerable code path entirely, though this requires a recompile and potential certificate re-validation; second, removing or disabling the --x509-username-field directive and reverting to standard CN-based authentication eliminates the vulnerable logic path without recompilation, at the cost of requiring CA and client certificate policy reconfiguration. Deployments already running OpenSSL or not using --x509-username-field require no remediation action.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
OpenVPN supports flexible certificate-based authentication via --x509-username-field, which maps arbitrary X.509 certificate fields (CN, emailAddress, SAN components, etc.) to VPN usernames for access-control enforcement. This feature is implemented separately for each TLS backend - OpenSSL and mbedTLS. CWE-115 (Misinterpretation of Input) indicates the mbedTLS code path incorrectly evaluates or compares the extracted field value, producing a permissive match under certain certificate structures issued by a cooperating or attacker-controlled CA. The EUVD-2026-58813 advisory confirms the affected scope as 'OpenVPN 2.7_alpha1 < 2.7.6', consistent with the v2.7.6 release notes published by the OpenVPN project at https://github.com/OpenVPN/openvpn/releases/tag/v2.7.6. The CVSS 4.0 vector (AV:N/AC:H/AT:P/PR:L/UI:A) encodes the high attack complexity and specific prerequisite conditions required for exploitation.
Know when the next one hits your stack
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N
High complexity from required mbedTLS plus --x509-username-field combination; PR:L for certificate possession; scope changed as unauthorized VPN access exposes downstream network.
Primary rating from Vendor (CNA).
CVSS VectorVendor
Description PRE-NVD
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
EUVD-2026-58813
NVD
CVE.org
EPSS
VulDB
Exploit-DB