Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS vector (AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N) indicates remote network access with high attack complexity, no privileges required, but user interaction needed, resulting in a 5.3 Medium score with high confidentiality impact. However, the PR:N designation is misleading here-the description explicitly states 'authorized user', meaning authentication is a practical prerequisite despite the vector showing PR:N. The high attack complexity (AC:H) and required user interaction (UI:R) further reduce real-world likelihood. The lack of KEV status (not actively exploited) and absence of public exploit code suggest this is a lower priority than the CVSS alone indicates. This is a legitimate credential exposure risk for organizations running vulnerable versions, but exploitation requires an insider threat model or compromised account rather than external attack. Organizations should prioritize patching based on sensitive credential types stored in their runZero instances and the trustworthiness of their user base. |
| Exploit ScenarioDerived | An insider with valid runZero Platform credentials (e.g., a junior security analyst or contractor with basic platform access) navigates to a credential management interface and, due to insufficient authorization checks, is able to view and extract cleartext secrets for credential types the application failed to properly protect. The attacker then uses these exposed credentials to compromise connected systems or services. No public exploit code is known, and this scenario relies on the attacker having legitimate platform access rather than external network compromise. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 07, 2026
runZero Platform versions prior to 4.0.260204.2 expose cleartext secrets for a subset of credential types and fields to authorized users due to insufficient credential protection, allowing users with legitimate platform access to view sensitive authentication data they should not be able to access. The vulnerability requires user interaction and has a CVSS score of 5.3 (Medium) with high confidentiality impact but no active exploitation or public exploit code identified at time of analysis.
RemediationAI
Vendor-released patch: Upgrade to runZero Platform version 4.0.260204.2 or later. This is the confirmed fixed version that resolves the cleartext credential exposure. Users unable to immediately upgrade should review and restrict access to the runZero Platform for non-administrative users, particularly those who do not require access to credential management features, to reduce the attack surface. Detailed guidance is available in the runZero release notes at https://help.runzero.com/docs/release-notes/#402602042.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from CWE-863 (Incorrect Authorization) combined with CWE-522 (Insufficiently Protected Credentials), indicating that the runZero Platform fails to properly restrict access to stored credential data. Rather than a cryptographic failure, this appears to be an authorization bypass where the application exposes cleartext secrets through its interface to users who have general platform access but lack the specific authorization to view sensitive credential fields. The affected CPE cpe:2.3:a:runzero:platform:*:*:*:*:*:*:*:* indicates all versions of the runZero Platform below the patched release are vulnerable, suggesting the flaw existed across the product line until the specific remediation was applied.
Know when Platform gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
Primary rating from Vendor (runZero) · only source for this CVE.
CVSS VectorVendor: runZero
Lifecycle Timeline
2DescriptionCVE.org
An issue that could allow an authorized user to view the clear-text secrets for a subset of credential types and fields has been resolved. This is an instance of CWE-522: Insufficiently Protected Credentials, and has an estimated CVSS score of CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N (5.3 Medium). This issue was fixed in version 4.0.260204.2 of the runZero Platform.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Server-side request forgery in Huly Platform's /import endpoint allows authenticated workspace users to coerce the front
Affected 1E Platform versions have a Blind SQL Injection vulnerability that can lead to arbitrary code execution. Rated
Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dash
Pega Platform before version 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability in the comment tags.
The Richtext Editor in Pega Platform before 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability. Rate
Improper privilege management in runZero Platform allows organization administrators to escalate privileges to superuser
Improper link resolution before file access in the Nomad module of the 1E Client, in versions prior to 25.3, enables an
Incorrect access control in the component ApiPayController.java of platform v1.0.0 allows attackers to access sensitive
Incorrect access control in the component orderService.queryObject of platform v1.0.0 allows attackers to access sensiti
Incorrect access control in the component ApiOrderService.java of platform v1.0.0 allows attackers to access sensitive i
The 1E-Exchange-DisplayMessageinstruction that is part of the End-User Interaction product pack available on the 1E Exch
The 1E-Exchange-CommandLinePing instruction that is part of the Network product pack available on the 1E Exchange does n
EUVD-2026-19697
GHSA-xm23-f7v4-5j82
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB