Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | CVSS 5.4 with PR:L (low privileges required) and AV:N/AC:L indicates a network-accessible vulnerability requiring valid authentication but with low complexity exploitation. The score reflects limited integrity and availability impact (I:L, A:L) with no confidentiality breach. Real-world risk is moderate: while CVSS is not critical, the vulnerability enables privilege escalation-a fundamental security boundary violation. The fact that it affects a download manager means attackers could manipulate download orders or abort operations to disrupt service or modify queue states. No active exploitation is confirmed (no KEV designation reported), and no public exploit code availability is indicated, reducing immediate threat level. However, the permission model violation makes this a priority fix for any multi-user pyLoad deployment where user isolation matters. |
| Exploit ScenarioDerived | An authenticated user with minimal privileges (e.g., a restricted download-only account) could directly call the vulnerable WebUI JSON endpoints to reorder packages, modify link priorities, or abort downloads belonging to other users or system operations. Because the endpoints do not enforce the same permission checks as the core API, the attacker bypasses role-based access controls without requiring admin credentials. The attack requires valid authentication credentials but no social engineering or elevated privileges, making it a practical privilege escalation vector in shared multi-user deployments. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 09, 2026
Authenticated privilege escalation in pyLoad's WebUI JSON endpoints (/json/package_order, /json/link_order, /json/abort_link) allows low-privileged users to perform unauthorized MODIFY operations that violate the application's permission model. Versions prior to 0.5.0b3.dev97 are affected; the vulnerability requires valid authentication but enables privilege boundary bypass without requiring elevated credentials.
RemediationAI
Upgrade pyLoad to version 0.5.0b3.dev97 or later, which includes the authorization enforcement fix for the vulnerable JSON endpoints. Users unable to upgrade immediately should restrict network access to pyLoad's WebUI to trusted networks only, or disable the affected endpoints if they are not required for normal operations. Review access logs for any suspicious activity from low-privileged accounts targeting /json/package_order, /json/link_order, or /json/abort_link endpoints. The vendor advisory at https://github.com/pyload/pyload/security/advisories/GHSA-rfgh-63mg-8pwm contains additional context and upgrade instructions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in pypi, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
pyLoad is a Python-based download manager that implements a permission-based access control model to restrict user actions based on privilege levels. The vulnerability exists in the WebUI JSON API layer, where three specific endpoints fail to enforce the same authorization checks that the underlying core API methods require. This represents a classic authorization bypass (CWE-863: Incorrect Authorization) where client-facing API endpoints do not properly validate user privileges before delegating to protected operations. The permission enforcement gap allows authenticated users with lower privilege levels to invoke operations restricted to higher-privilege users, bypassing the application's intended authorization boundaries.
Know when Pyload gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
Lifecycle Timeline
2DescriptionGitHub Advisory
pyLoad is a free and open-source download manager written in Python. Prior to 0.5.0b3.dev97, the /json/package_order, /json/link_order, and /json/abort_link WebUI JSON endpoints enforce weaker permissions than the core API methods they invoke. This allows authenticated low-privileged users to execute MODIFY operations that should be denied by pyLoad's own permission model. This vulnerability is fixed in 0.5.0b3.dev97.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
pyLoad download manager version prior to 0.5.0b3.dev77 exposes the Flask SECRET_KEY through an unauthenticated endpoint.
pyLoad is the free and open-source Download Manager written in pure Python. Rated medium severity (CVSS 5.3), this vulne
Code Injection in GitHub repository pyload/pyload prior to 0.5.0b3.dev31. Rated critical severity (CVSS 9.8), this vulne
Excessive Attack Surface in GitHub repository pyload/pyload prior to 0.5.0b3.dev41. Rated critical severity (CVSS 9.8),
pyLoad 0.5.0 is vulnerable to Unrestricted File Upload. Rated high severity (CVSS 8.8), this vulnerability is remotely e
Improper Input Validation in GitHub repository pyload/pyload prior to 0.5.0b3.dev40. Rated high severity (CVSS 7.5), thi
Improper Certificate Validation in GitHub repository pyload/pyload prior to 0.5.0b3.dev44. Rated high severity (CVSS 7.4
pyload is an open-source Download Manager written in pure Python. Rated high severity (CVSS 7.2), this vulnerability is
Insufficient Session Expiration in GitHub repository pyload/pyload prior to 0.5.0b3.dev36. Rated medium severity (CVSS 6
An open redirection vulnerability exists in pyload/pyload version 0.5.0. Rated medium severity (CVSS 6.1), this vulnerab
pyLoad is an open-source Download Manager written in pure Python. Rated medium severity (CVSS 6.1), this vulnerability i
Cross-site Scripting (XSS) - Stored in GitHub repository pyload/pyload prior to 0.5.0b3.dev42. Rated medium severity (CV
EUVD-2026-20998
NVD
CVE.org
EPSS
Vulnrichment
GitHub
Exploit-DB