Discourse
CVE-2026-33428
MEDIUM
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2021 - Broken Access Control
ASVS 5.0
V4 - Access Control Authorization enforcement, RBAC validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | This vulnerability presents a moderate to high real-world risk despite the absence of CVSS/EPSS scoring data. The attack vector is network-based with low complexity (requires only valid authentication and group membership, not staff status), making it accessible to a broad class of authenticated users. The technical impact is limited to confidentiality breach (information disclosure of deleted posts) with no integrity or availability impact, suggesting lower severity than remote code execution vulnerabilities. The fact that patches exist in three concurrent release branches (2026.3.0-latest.1, 2026.2.1, 2026.1.2) indicates this was responsibly disclosed and fixed promptly. No public proof-of-concept or active exploitation has been documented. However, the ease of exploitation (any group-elevated non-staff user can trigger it) combined with the sensitive nature of deleted content (which may contain private or removed information) elevates practical risk. Organizations hosting Discourse should prioritize patching, but this is not an emergency-grade critical issue requiring immediate out-of-band response. |
| Exploit ScenarioDerived | An authenticated non-staff user who has been granted elevated group membership (e.g., via a community moderator role that grants special privileges but not staff status) can directly access the deleted posts index endpoint and retrieve any deleted post from the platform, including those deleted by administrators or other users. The attacker would simply make a standard HTTP request to the vulnerable endpoint with their valid session credentials, requiring no special tools or complex attack chain. This could allow the attacker to recover sensitive information that was intentionally removed from public view. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 20, 2026
An authorization bypass vulnerability exists in Discourse prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, where non-staff users with elevated group membership can access deleted posts belonging to any user through an overly permissive authorization check on the deleted posts index endpoint. This is a CWE-863 (Incorrect Authorization) vulnerability that allows unauthorized information disclosure of deleted content. No public exploit or active exploitation in the wild has been reported, but patches are available and no workarounds exist.
RemediationAI
Upgrade Discourse immediately to version 2026.3.0-latest.1, 2026.2.1, or 2026.1.2 or later, depending on your deployment branch, using the official patch provided in the vendor advisory at https://github.com/discourse/discourse/security/advisories/GHSA-frcw-p4mc-x6mp. No known workarounds are available, so patching is the only mitigation path. In the interim before patching, organizations should audit access logs to identify any non-staff users with elevated group memberships who may have accessed the deleted posts index, and consider temporarily restricting group elevation permissions or network access to the Discourse instance if operationally feasible.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Discourse is an open-source discussion platform (cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*) that manages user roles, permissions, and content visibility through role-based access controls. The vulnerability stems from CWE-863 (Incorrect Authorization), which represents a failure to properly enforce authorization checks at the application layer. Specifically, the deleted posts index endpoint fails to adequately validate that the requesting user (non-staff with elevated group membership) has legitimate authorization to view deleted posts from other users. The authorization logic incorrectly trusts group membership as a sufficient condition for access, bypassing the intended restriction that deleted posts should only be viewable by staff members or the post author.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
DescriptionGitHub Advisory
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a non-staff user with elevated group membership could access deleted posts belonging to any user due to an overly broad authorization check on the deleted posts index endpoint. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.
Executive ViewAI
Organizations using Discourse should be aware of notable risk from CVE-2026-33428, a incorrect authorization vulnerability rated CVSS 6.5. Attackers could gain access beyond their authorized level. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Affected Products (CPE)GitHub Advisory
Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB