Discourse
CVE-2026-33291
MEDIUM
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2021 - Broken Access Control
ASVS 5.0
V4 - Access Control Authorization enforcement, RBAC validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While no CVSS score or EPSS metric has been publicly assigned, the vulnerability presents moderate-to-high real-world risk for organizations using Discourse with the Zendesk plugin. The attack vector is classified as CWE-863 (Incorrect Authorization) and requires moderator-level privileges to exploit, limiting the immediate attack surface to trusted users—however, moderator compromise or malicious insiders become a significant threat vector. The vulnerability is not listed in the CISA KEV catalog (no indication of active exploitation), and no proof-of-concept code is publicly available, which reduces immediate threat intensity. However, the fact that patched versions are available across three release branches (2026.3.0-latest.1, 2026.2.1, 2026.1.2) indicates the vendor treats this as a security-sensitive issue requiring coordinated disclosure. Organizations running vulnerable versions face information disclosure and potential audit/compliance violations if moderators create tickets for restricted topics, exposing sensitive discussions to external ticketing systems. Priority should be elevated for forums handling sensitive or confidential discussions. |
| Exploit ScenarioDerived | A malicious moderator or a compromised moderator account on a Discourse forum could systematically create Zendesk tickets for private or restricted topics they should not be able to view, exfiltrating sensitive discussion content to an external ticketing system where it persists in audit logs and is potentially visible to support staff. Since the attack requires only standard moderator privileges and involves a normal-appearing feature (ticket creation), it would be difficult to detect without explicit access control logging. This is particularly damaging in forums handling confidential business discussions, security vulnerability reports, or private community grievances. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 20, 2026
A broken access control vulnerability in Discourse versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 allows moderators to create Zendesk support tickets for topics they lack permission to view, bypassing intended access restrictions. This affects all Discourse forums utilizing the Zendesk plugin integration. The vulnerability is classified as CWE-863 (Incorrect Authorization) and has no publicly disclosed active exploitation or proof-of-concept code, though patches are available from the vendor.
RemediationAI
Upgrade Discourse immediately to version 2026.3.0-latest.1, 2026.2.1, or 2026.1.2 or later, depending on your release branch (see https://github.com/discourse/discourse/security/advisories/GHSA-p26h-jqr4-r6j7 for details). No workarounds are available according to the vendor advisory. If immediate patching is not possible, disable the Zendesk plugin integration until the upgrade can be completed, and audit existing Zendesk tickets to identify any created by moderators for restricted topics. Additionally, restrict moderator role assignments to trusted individuals and implement monitoring/logging on Zendesk ticket creation events originating from Discourse.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Discourse (cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*) is an open-source discussion platform built on Ruby on Rails. The vulnerability exists in the Zendesk plugin integration layer, which provides functionality to create support tickets from forum topics. The root cause falls under CWE-863 (Incorrect Authorization), indicating that authorization checks are either missing or improperly implemented when moderators attempt to create Zendesk tickets. Specifically, the plugin fails to validate that a moderator has permission to view or access a topic before allowing ticket creation, creating a direct escalation path where moderators can interact with restricted content through the ticket creation mechanism. This is a privilege-based access control bypass affecting the plugin's authorization middleware.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
DescriptionGitHub Advisory
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, moderators can create Zendesk tickets for topics they do not have access to view. This affects all forums that use the Zendesk plugin. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.
Executive ViewAI
Organizations using Discourse should be aware of moderate risk from CVE-2026-33291, a incorrect authorization vulnerability rated CVSS 5.4. Attackers could gain access beyond their authorized level. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Affected Products (CPE)GitHub Advisory
Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB