Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V2 - Validation and Business Logic Resource consumption limits
MITRE ATT&CK
1 technique across 1 tactic: Impact The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | This vulnerability presents low real-world risk despite a moderate CVSS score. The CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H vector correctly identifies network-reachable impact on availability (A:H) but requires authenticated access (PR:L), limiting the attack surface. The EPSS score of 0.02% (5th percentile) strongly signals that automated exploitation is unlikely in practice, likely because: (1) the attack requires valid credentials, ruling out anonymous attackers; (2) the impact is service degradation rather than data breach or code execution, reducing attacker motivation; (3) most deployments implement monitoring and resource quotas that would detect and mitigate repeated password changes. SSVC analysis: exploitation is possible (authenticated users have capability), but automatable exploitation is minimal (requires credential compromise and detection evasion). The technical impact is high (availability loss), but blast radius is limited to authenticated sessions. Conclusion: organizations with strict access controls and proper authentication monitoring can deprioritize this; however, environments allowing weak or widely-shared credentials should patch. |
| Exploit ScenarioDerived | An attacker with valid Cassandra credentials (obtained through credential compromise, insider access, or weak authentication) opens a CQL session and repeatedly issues ALTER USER password-change commands in rapid succession. Each password change triggers authentication subsystem processing; the lack of rate limiting allows the attacker to saturate the server's processing queue. Legitimate user queries experience elevated latencies or timeout, degrading service availability. Detection would likely trigger only if query monitoring and authentication logging are enabled and actively reviewed. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 07, 2026
Authenticated denial of service via CQL in Apache Cassandra 4.0 through 5.0 allows authenticated users to elevate query latencies by repeatedly changing passwords, disrupting service availability for legitimate users. The vulnerability affects Cassandra 4.0.0-4.0.19, 4.1.0-4.1.10, and 5.0.0-5.0.6. Vendor-released patches are available (4.0.20, 4.1.11, 5.0.7). With an EPSS score of 0.02% (5th percentile), real-world exploitation risk is minimal despite the moderate CVSS score of 6.5, reflecting the requirement for prior authentication and the low likelihood of widespread abuse.
RemediationAI
Upgrade to the patched versions: Apache Cassandra 4.0.20, 4.1.11, or 5.0.7, depending on your current version. These releases are available from the Apache Cassandra download page and official repositories. If immediate upgrade is not feasible, implement compensating controls: (1) restrict CQL client connections to trusted networks and enforce strong authentication policies; (2) monitor and rate-limit authentication-related operations (password changes) per authenticated user; (3) configure query timeout and resource limits in cassandra.yaml to prevent individual users from monopolizing server resources. For deployment guidance, consult the vendor advisory at https://lists.apache.org/thread/2tnwjdnss378glxrsmnlzz3k53ftphrc.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in maven, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exploits the CQL (Cassandra Query Language) protocol's password-change mechanism. Apache Cassandra uses CQL as its primary query interface; authenticated users connect with credentials and can issue commands including authentication modifications. The root cause is a resource exhaustion flaw (CWE-400: Uncontrolled Resource Consumption) in which repeated password-change operations trigger expensive internal processes (such as credential validation, replication, or synchronization) without adequate rate limiting or cost controls. An authenticated attacker can repeatedly invoke password-change requests, consuming server resources and degrading latency for all concurrent queries, effectively creating a denial of service condition. The flaw is present in the CQL authentication handling layer across Cassandra's major versions 4.0, 4.1, and 5.0.
Know when Cassandra gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Primary rating from Vendor (apache).
CVSS VectorVendor: apache
Lifecycle Timeline
2DescriptionCVE.org
Authenticated DoS over CQL in Apache Cassandra 4.0, 4.1, 5.0 allows authenticated user to raise query latencies via repeated password changes. Users are recommended to upgrade to version 4.0.20, 4.1.11, 5.0.7, which fixes this issue.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Denial of Service attacks render applications or systems unavailable by overwhelming resources or triggering failure conditions.
Related Vulnerabilities in Apache Cassandra Privilege Escalation and DoS
View all 2Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77; and JRockit R28.3.9 allows rem
The default configuration in Apache Cassandra 3.8 through 3.11.1 binds an unauthenticated JMX/RMI interface to all netwo
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers t
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. Rated high severity (CVSS 8.8), this vulnerabil
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. Rated high severity (CVSS 8.8), this vulnerabil
Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user runn
The default configuration in Apache Cassandra 1.2.0 through 1.2.19, 2.0.0 through 2.0.13, and 2.1.0 through 2.1.3 binds
In Apache Cassandra, all versions prior to 2.1.22, 2.2.18, 3.0.22, 3.11.8 and 4.0-beta2, it is possible for a local atta
Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: RMI). Rated medium severity (C
Apache Cassandra 4.0 through 4.0.19 stores cleartext passwords and other sensitive command history in the ~/.cassandra/c
Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they s
In Apache Cassandra it is possible for a local attacker without access to the Apache Cassandra process or configuration
EUVD-2026-19769
GHSA-qffm-gf3j-6mvg
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB