Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessLure victim to attacker-controlled page
-
DeliveryCompromise sandboxed renderer process
-
ExploitServe crafted HTML to Extensions component
-
ExecutionTrigger improper input validation (CWE-20)
-
ImpactEscalate privileges out of renderer sandbox
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V2 - Validation and Business Logic Input validation, allowlisting
|
| Exploitation Conditions | Exploitation requires that the attacker has ALREADY compromised the Chrome renderer process - this is the explicit, gating precondition named in the description, making the bug a sandbox-escape/privilege-escalation stage rather than an initial-access vector. It additionally requires user interaction (UI:R - the victim must load attacker content) and a crafted HTML page that feeds untrusted input to the Extensions component, and CVSS AC:H reflects that these conditions are hard to align reliably. Limiting factors: the mandatory pre-existing renderer foothold, required user interaction, high attack complexity, and the fact that only Chrome versions before 150.0.7871.47 are vulnerable substantially narrow realistic exploitation to targeted, multi-stage attacks. |
| Impact | Signals skew toward lower real-world urgency than the 7.5 base score suggests. The CVSS vector (AV:N/AC:H/PR:N/UI:R) encodes high attack complexity and required user interaction, and the description adds a significant prerequisite: the attacker must ALREADY control the renderer process, making this a chain component rather than a standalone remote exploit. EPSS is low at 0.22% (12th percentile) and the CVE is not in CISA KEV, indicating no known active exploitation. Note a nuance: the vector lists PR:N (unauthenticated), reflecting Chromium's convention of scoring from the web-content perspective, yet the description's 'compromised the renderer process' requirement is a real gating condition that raises practical difficulty - verify the intended attack model with the vendor. Overall this is a Medium-severity sandbox-hardening fix, worth routine patching but not an emergency. |
| Exploit ScenarioDerived | An attacker first compromises the Chrome renderer process (for example by chaining a separate renderer RCE bug) after luring a victim to a malicious site. They then serve a crafted HTML page that supplies malformed input to the Extensions component, exploiting the input-validation gap to escalate out of the sandboxed renderer into a higher-privileged browser context. No public exploit code has been identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 01, 2026
Privilege escalation in Google Chrome's Extensions component (versions prior to 150.0.7871.47) lets a remote attacker who has already compromised the renderer process break out via a crafted HTML page. Rated Medium by Chromium and CVSS 7.5, it stems from insufficient validation of untrusted input (CWE-20) and requires user interaction plus a pre-existing renderer foothold. There is no public exploit identified at time of analysis, EPSS is low (0.22%, 12th percentile), and it is not on CISA KEV.
RemediationAI
Vendor-released patch: 150.0.7871.47. Update Google Chrome to 150.0.7871.47 or later via the Stable desktop channel and confirm by navigating to chrome://settings/help, which forces an update check and relaunch. In managed environments, ensure auto-update is enabled or push the fixed build through your enterprise update/MDM channel, and reduce exposure to the renderer-compromise precondition by keeping the browser current and restricting installation of untrusted extensions. There is no vendor-published standalone workaround; because exploitation depends on first compromising the renderer, keeping all Chrome components patched (which closes the renderer bugs used as the first stage) is the effective compensating control, at the trade-off of relying on timely update rollout. See Google's advisory: https://chromereleases.googleblog.com/2026/06/stable-channel-update-for-desktop_0175352312.html and the Chromium issue https://issues.chromium.org/issues/501631475.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The flaw lives in Chrome's Extensions subsystem, the browser layer that mediates privileged APIs exposed to extensions and to web content interacting with them. The root cause is CWE-20 (Improper Input Validation): the Extensions code accepts untrusted input - originating from an already-compromised renderer process - without adequate validation, allowing an attacker to cross the privilege boundary between the sandboxed renderer and the higher-privileged browser context. Because Chromium renderers are sandboxed by design, this class of bug is typically chained as the second stage of a sandbox escape rather than an initial entry point. The affected code is Chromium's cross-platform Extensions implementation shipped in the desktop Stable channel (Chrome, and by extension Chromium-based browsers consuming the same engine).
Know when the next one hits your stack
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Kept AV:N/AC:H/UI:R per Chromium scoring convention; PR:N reflects web-content origin though a renderer foothold is required, and sandbox escape yields full C/I/A impact within an unchanged scope.
Primary rating from Vendor (google).
CVSS VectorVendor: google
Lifecycle Timeline
3DescriptionCVE.org
Insufficient validation of untrusted input in Extensions in Google Chrome prior to 150.0.7871.47 allowed a remote attacker who had compromised the renderer process to perform privilege escalation via a crafted HTML page. (Chromium security severity: Medium)
Executive ViewAI
Google Chrome Extensions prior to version 150.0.7871.47 contain a privilege escalation vulnerability that could allow attackers with prior renderer process access to elevate permissions on compromised systems. While no public exploits are known and exploitation likelihood is low (0.2% EPSS), the vulnerability presents a secondary risk escalation pathway in targeted attack chains. Organizations should prioritize updating to eliminate this privilege escalation vector.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Same weakness CWE-20 – Improper Input Validation
View allSame technique Privilege Escalation
View allVendor StatusVendor
SUSE
Severity: Important| Product | Status |
|---|---|
| SUSE Package Hub 15 SP7 | Fixed |
| openSUSE Tumbleweed | Fixed |
| SUSE Package Hub 15 SP7 | Affected |
EUVD-2026-40577
GHSA-86ph-mmh8-99jx
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB