Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V14 - Data Protection Data exposure prevention
MITRE ATT&CK
2 techniques across 2 tactics: Collection, Discovery The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 3.1 base score of 6.5 reflects a medium-to-high severity issue with network attack vector, low complexity, and high confidentiality impact. The requirement for PR:L (Contributor-level privileges) restricts the immediate threat surface, as attackers must first obtain legitimate WordPress user credentials at Contributor level or higher. However, the high confidentiality impact (C:H) is significant because form submissions frequently contain personally identifiable information, email addresses, phone numbers, and other sensitive data. The EPSS score and real-world exploit probability are not confirmed from provided data, but the simplicity of token exfiltration (likely accessible via unauthenticated or low-privilege script inspection) suggests practical exploitability. This is a legitimate priority for WordPress site administrators, particularly those using Ninja Forms to collect sensitive information, though it is less critical than unauthenticated remote code execution vulnerabilities. The requirement for authenticated access limits mass exploitation but increases insider threat risk. |
| Exploit ScenarioDerived | An attacker with WordPress Contributor-level credentials (obtained through credential compromise, social engineering, or intentionally granted access by a site administrator) logs into the WordPress admin panel and inspects the source code or network traffic of the Ninja Forms admin pages. The attacker extracts the exposed authorization token from the blocks/bootstrap.php callback function, then uses this token to programmatically access form submissions from any form in the WordPress installation, exfiltrating potentially sensitive customer inquiries, lead information, or personal data without detection by the form owner. The low complexity of the attack (simple token extraction and API access) makes this exploitable by non-sophisticated actors with basic WordPress knowledge. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 28, 2026
Ninja Forms plugin for WordPress versions up to 3.14.1 exposes authorization tokens via an insecure callback function in blocks/bootstrap.php, allowing authenticated Contributor-level users and above to access form submission data from arbitrary forms without proper authorization. The vulnerability enables sensitive information disclosure affecting all WordPress installations using the affected plugin versions, with no active exploitation confirmed at time of analysis.
RemediationAI
WordPress administrators using Ninja Forms should immediately update the plugin to version 3.14.2 or later, as confirmed by the WordPress plugin repository changeset 3489168. The patch removes or properly secures the callback function in blocks/bootstrap.php that was exposing authorization tokens. Updates are available directly through the WordPress admin dashboard (Plugins > Updates) or via https://plugins.trac.wordpress.org/changeset/3489168/ninja-forms. No workaround is available for unpatched versions; upgrade is the only remediation. Site owners should review form submission logs and access records to determine if the token exposure was exploited prior to patching.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the admin_enqueue_scripts action handler callback within the Ninja Forms plugin's blocks/bootstrap.php file. This handler improperly exposes authorization tokens used for accessing form submissions through an unauthenticated or inadequately protected mechanism. The root cause is classified under CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), indicating a failure to properly restrict access to sensitive data-in this case, API tokens that grant access to form submission contents. The issue affects the contact form builder functionality in WordPress environments where the plugin handles form data collection and management.
Know when PHP gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
The Ninja Forms - The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.14.1 via a callback function for the admin_enqueue_scripts action handler in blocks/bootstrap.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to gain access to an authorization token to view form submissions for arbitrary forms, which could potentially contain sensitive information.
Executive ViewAI
Organizations using for WordPress is vulnerable to Sensitive Information Exposure in all should be aware of notable risk from CVE-2026-1307, a information exposure vulnerability rated CVSS 6.5. Sensitive information could be exposed to unauthorized parties. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict endpoint access, redact sensitive data in logs.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not
(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear
The '/common/download_agent_installer.php' script in the Quest KACE System Management Appliance 8.0.318 is accessible by
ProjectSend versions prior to r1720 are affected by an improper authentication vulnerability. Rated critical severity (C
Roundcube Webmail contains a critical PHP object deserialization vulnerability (CVE-2025-49113, CVSS 9.9) that allows au
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP c
Palo Alto Networks PAN-OS management web interface contains an authentication bypass allowing unauthenticated attackers
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
The get_referers function in /opt/ws/bin/sblistpack in Sophos Web Appliance before 3.7.9.1 and 3.8 before 3.8.1.1 allows
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
EUVD-2026-16907
GHSA-3xw3-8j95-46mv
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB