Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessGain on-path network position (MITM)
-
DeliveryIntercept Passy HTTPS connection
-
ExploitPresent forged/invalid certificate
-
ExecutionClient accepts cert via badCertificateCallback
-
ImpactDecrypt or tamper with transmitted data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A07:2025 - Authentication Failures
ASVS 5.0
V12 - Secure Communication Certificate validation
|
| Exploitation Conditions | Requires the attacker to hold an active machine-in-the-middle position on the network path between the Passy client (versions up to 1.10.1) and any host it contacts over HTTPS; the defect disables certificate validation globally via HttpOverrides.global, so any TLS connection the app makes is affected rather than one specific feature. Limiting factors that reduce realistic risk: the attacker must already control or intercept the network segment (public/shared Wi-Fi, compromised gateway, rogue AP) and actively perform TLS interception at the moment Passy connects - hence the vendor's HIGH complexity / 'difficult' rating. No authentication or user interaction on the target is needed (PR:N/UI:N), but no exploitation is possible without the on-path position. |
| Impact | This is a genuine but lower-tier priority. The source-code evidence confirms the root cause unambiguously: MyHttpOverrides in lib/main.dart set badCertificateCallback to always return true, globally disabling TLS certificate validation for all HttpClient connections (HttpOverrides.global). CWE-295 (improper certificate validation) is therefore vendor/commit-confirmed, not merely inferred. However, the real-world risk is constrained: the vendor-supplied CVSS:4.0 vector (AV:N/AC:H/AT:N/PR:N/UI:N) and the description both emphasize HIGH attack complexity and 'difficult' exploitability, because exploitation requires an active machine-in-the-middle (MITM) position on the network path - a condition an attacker cannot create at will. Exploitation status is: no public exploit identified at time of analysis (reported by VulDB only; no POC, no CISA KEV entry, and no EPSS score were provided). A notable conflict exists between the signals: VulDB scored impact as VC:N/VI:L (no confidentiality impact, only low integrity) at 6.3 MEDIUM, yet the tag 'Information Disclosure' and the nature of the flaw (a password manager silently accepting forged certificates) point toward confidentiality exposure of synced data - these two signals disagree and should be verified against the actual data flows protected by TLS. Net: a real, confirmed hardening defect worth patching promptly for a sensitive app class (password manager), but not an emergency given high complexity, no known exploitation, and no POC. |
| Exploit ScenarioDerived | An attacker positioned on the network path between a Passy instance and the server it connects to (e.g., on a shared/hostile Wi-Fi network or a compromised router) presents a forged or self-signed TLS certificate. Because badCertificateCallback unconditionally returns true, the Passy client accepts the invalid certificate without warning, letting the attacker decrypt and/or tamper with the transmitted data. No public exploit code was identified, and success requires the attacker to already hold a MITM position, consistent with the 'high complexity' rating. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 19, 2026
Improper TLS certificate validation in GlitterWare Passy through 1.10.1 lets an unauthenticated attacker who already holds an on-path network position impersonate HTTPS hosts and intercept or alter traffic the app exchanges. Exploitation is rated high complexity because the attacker must actively man-in-the-middle a connection at the moment Passy connects, but no user interaction is required; no public exploit was identified at time of analysis. Upgrading to 1.10.2 removes the insecure global HTTP override and restores certificate validation.
RemediationAI
Upgrade GlitterWare Passy to 1.10.2 or later; the vendor-released patch is the commit 3d48df7cce05e39fa4de1e42768492307f26882e and the fixed build is published at https://github.com/GlitterWare/Passy/releases/tag/v1.10.2 (advisory/issue: https://github.com/GlitterWare/Passy/issues/210, VulDB: https://vuldb.com/vuln/422055). Because the defect sets HttpOverrides.global with badCertificateCallback returning true, there is no in-app setting to restore certificate validation; until upgraded, run Passy only on trusted network segments or through a VPN you control and avoid public/shared Wi-Fi, accepting the reduced mobility that this restriction imposes. No other vendor workaround is documented.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Passy is a Flutter/Dart application whose lib/main.dart defined MyHttpOverrides extends HttpOverrides and overrode createHttpClient to set badCertificateCallback to always return true, then assigned it to HttpOverrides.global. That disables certificate validation for every HttpClient created by the app rather than for one specific endpoint, so any HTTPS connection the application makes can be intercepted by an attacker positioned on the network path. CWE-295 improper certificate validation is the root cause, and the CPE cpe:2.3:a:glitterware:passy:*:*:*:*:*:*:*:* identifies the affected GlitterWare Passy product line prior to the fixed release. The patch commit 3d48df7cce05e39fa4de1e42768492307f26882e removes the MyHttpOverrides class and the global assignment; the same commit also contains unrelated PDF-viewer and dependency changes, so review should focus on removal of the badCertificateCallback override.
Know when Passy gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
AC:H because an active on-path MITM position is required; PR:N/UI:N as no target credentials or interaction are needed; C:H/I:H because disabled cert validation lets a MITM read and tamper with password-manager traffic.
Primary rating from Vendor (VulDB).
CVSS VectorVendor: VulDB
DescriptionCVE.org
A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
EUVD-2026-104210
GHSA-j5q5-6pvc-m68p
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB