Skip to main content

Mruby CVE-2025-7207

| EUVDEUVD-2025-20759 LOW
Buffer Overflow (CWE-119)
2025-07-09 cna@vuldb.com
1.9
CVSS 4.0 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A06:2021 - Vulnerable and Outdated Components
ASVS 5.0
V14 - Configuration Dependency management, component inventory
MITRE ATT&CK

2 techniques across 2 tactics: Execution, Privilege Escalation

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Monitor Track and reassess. Why: LOW severity (CVSS 0.1-3.9).
Patch available 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv2 – Jul 26, 2026

Local heap-based buffer overflow in mruby compiler (codegen.c) through version 3.4.0-rc2 allows low-privileged local attackers to cause denial of service. The flaw resides in the scope_new function where missing initialization of the nregs variable leads to heap corruption when processing a crafted Ruby script. Public exploit code is available, though no active exploitation in the wild has been confirmed.

Earlier versions of this analysis (1)
v1 Mar 16, 2026 - 06:20 CVSS 3.3

Affected VersionsENISA

mruby 3.4.0-rc2
mruby 3.4.0-rc1

Affected Packages

euvd mruby no fix

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Know when Mruby gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 1.9 LOW
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P
Ubuntu MEDIUM

Primary rating from NVD.

CVSS VectorNVD

Attack Vector
Local
Attack Complexity
Low
Attack Requirements
None
Privileges Required
Low
User Interaction
None
Vulnerable system: Confidentiality
None
Vulnerable system: Integrity
None
Vulnerable system: Availability
Low
Subsequent system: Confidentiality
None
Subsequent system: Integrity
None
Subsequent system: Availability
None

Lifecycle Timeline

5
CVSS changed
Apr 29, 2026 - 01:11 NVD
3.3 (LOW) 1.9 (LOW)
Patch released
Mar 16, 2026 - 06:20 nvd
Patch available
PoC Detected
Oct 01, 2025 - 20:32 vuln.today
Public exploit code
CVE Published
Jul 09, 2025 - 01:15 nvd
LOW 3.3
CVE Published
Jul 09, 2025 - 01:15 cve.org
LOW 1.9

DescriptionCVE.org

A vulnerability, which was classified as problematic, was found in mruby up to 3.4.0-rc2. Affected is the function scope_new of the file mrbgems/mruby-compiler/core/codegen.c of the component nregs Handler. The manipulation leads to heap-based buffer overflow. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The name of the patch is 1fdd96104180cc0fb5d3cb086b05ab6458911bb9. It is recommended to apply a patch to fix this issue.

Executive ViewAI

Why It Matters

CVE-2025-7207 is a low-severity vulnerability in mruby (CVSS 3.3). The limited severity suggests constrained impact, typically requiring specific conditions or local access for exploitation. A patch is available and can be applied during standard maintenance windows.

Recommended Action

During next maintenance window: Apply vendor patches when convenient. Vendor patch is available.

Business Impact: Low
Compensating Controls

Apply vendor patch during routine maintenance. Standard security controls provide adequate interim protection.

Threat Intelligence Overview

EPSS Score
0.0%
Top 92% exploitable
Exploit
POC
Public exploit code exists
Data Quality
7 sources
Confidence: High

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity LOW
CISA KEV No
Public POC Yes
EPSS 0.0%
Patch available Yes
Active threat No
Deciding rule
LOW severity (CVSS 0.1-3.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Defer
Exploitation· derived
Poc
System Exposure· derived
Small
Automatable· derived
No
Human Impact
Low

Priority Score

30
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +10
PoC: +20
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

A buffer overflow occurs when a program writes more data to a memory buffer than it was allocated to hold, causing the excess data to spill into adjacent memory regions.

More in Mruby

View all
CVE-2022-1286 CRITICAL POC
9.8 Apr 10

heap-buffer-overflow in mrb_vm_exec in mruby/mruby in GitHub repository mruby/mruby prior to 3.2. Rated critical severit

CVE-2022-1276 CRITICAL POC
9.8 Apr 10

Out-of-bounds Read in mrb_get_args in GitHub repository mruby/mruby prior to 3.2. Rated critical severity (CVSS 9.8), th

CVE-2022-1212 CRITICAL POC
9.8 Apr 05

Use-After-Free in str_escape in mruby/mruby in GitHub repository mruby/mruby prior to 3.2. Rated critical severity (CVSS

CVE-2022-0631 CRITICAL POC
9.8 Feb 18

Heap-based Buffer Overflow in Homebrew mruby prior to 3.2. Rated critical severity (CVSS 9.8), this vulnerability is rem

CVE-2022-0080 CRITICAL POC
9.8 Jan 02

mruby is vulnerable to Heap-based Buffer Overflow. Rated critical severity (CVSS 9.8), this vulnerability is remotely ex

CVE-2020-15866 CRITICAL POC
9.8 Jul 21

mruby through 2.1.2-rc has a heap-based buffer overflow in the mrb_yield_with_class function in vm.c because of incorrec

CVE-2020-6840 CRITICAL POC
9.8 Jan 11

In mruby 2.1.0, there is a use-after-free in hash_slice in mrbgems/mruby-hash-ext/src/hash-ext.c. Rated critical severit

CVE-2020-6839 CRITICAL POC
9.8 Jan 11

In mruby 2.1.0, there is a stack-based buffer overflow in mrb_str_len_to_dbl in string.c. Rated critical severity (CVSS

CVE-2020-6838 CRITICAL POC
9.8 Jan 11

In mruby 2.1.0, there is a use-after-free in hash_values_at in mrbgems/mruby-hash-ext/src/hash-ext.c. Rated critical sev

CVE-2018-11743 CRITICAL POC
9.8 Jun 05

The init_copy function in kernel.c in mruby 1.4.1 makes initialize_copy calls for TT_ICLASS objects, which allows attack

CVE-2018-10191 CRITICAL POC
9.8 Apr 17

In versions of mruby up to and including 1.4.0, an integer overflow exists in src/vm.c::mrb_vm_exec() when handling OP_G

CVE-2022-1106 CRITICAL POC
9.1 Mar 27

use after free in mrb_vm_exec in GitHub repository mruby/mruby prior to 3.2. Rated critical severity (CVSS 9.1), this vu

Vendor StatusVendor

Ubuntu

Priority: Medium
mruby
Release Status Version
xenial needs-triage -
bionic needs-triage -
focal needs-triage -
jammy needs-triage -
noble needs-triage -
upstream needs-triage -
oracular ignored end of life, was needs-triage
plucky ignored end of life, was needs-triage
questing needs-triage -

Debian

Bug #1109338
mruby
Release Status Fixed Version Urgency
bullseye vulnerable 2.1.2-3 -
bookworm vulnerable 3.1.0-3 -
trixie vulnerable 3.3.0-1 -
forky, sid fixed 3.4.0-2 -
(unstable) fixed 3.4.0-2 -

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy