GnuPG
CVE-2025-68972
MEDIUM
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAccess target running Alpine Linux with unpatched gnupg
-
ExploitDeliver crafted input to gnupg-dependent process
-
ExecutionTrigger unspecified vulnerability
-
ImpactAchieve unknown impact
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A04:2025 - Cryptographic Failures
ASVS 5.0
V11 - Cryptography Signature verification
|
| Exploitation Conditions | Exploitation conditions are entirely unknown due to the absence of a CVE description, CVSS vector, and CWE classification. No CVSS vector is present to determine whether exploitation is network-reachable or local-only, authenticated or unauthenticated, or requires user interaction. The only confirmed prerequisite is that the affected system runs Alpine Linux with a gnupg package version prior to 2.4.9-r0. Defenders cannot assess realistic exploitation conditions from this record alone and must await full vendor disclosure. |
| Impact | Risk cannot be quantitatively assessed from available data. No CVSS vector is present, so attack vector, complexity, privilege requirements, user interaction, scope, and impact metrics are all unknown. No EPSS score is available, meaning exploitation probability cannot be estimated. The CVE is not listed in the CISA KEV catalog, and no public proof-of-concept exploit has been identified. The sole confirmed signal is that Alpine Linux issued a fix (2.4.9-r0), which implies the defect was considered serious enough to warrant a dedicated package update. Given GnuPG's role in cryptographic operations and package integrity verification, any vulnerability in this component carries inherent systemic risk - particularly on container and server workloads built on Alpine Linux. However, the actual severity could range from critical (e.g., signature bypass) to low (e.g., information disclosure). Defenders should not rely on CVSS triage here and should apply the patch based on the vendor fix signal alone. |
| Exploit ScenarioDerived | Because the vulnerability type, attack vector, and impact are undisclosed, no realistic exploit scenario can be constructed from available data. If the vulnerability involves a signature verification bypass - a historically significant class of GnuPG flaws - an attacker could potentially supply a maliciously crafted signed artifact that passes GnuPG validation, enabling downstream trust abuse. This scenario is speculative and not supported by confirmed CVE details. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 27, 2026
GnuPG on Alpine Linux is affected by a vulnerability addressed in Alpine package version 2.4.9-r0. The CVE record contains only a fix-availability notice from the Alpine Linux vendor with no published description, CVSS scoring, or CWE classification, making the specific vulnerability class, impact, and attack vector unconfirmed at time of analysis. Security teams should treat this as a vendor-confirmed defect warranting patch application, while monitoring upstream GnuPG and Alpine advisories for full disclosure.
RemediationAI
Upgrade the gnupg package on Alpine Linux to version 2.4.9-r0 or later by running 'apk upgrade gnupg' on affected systems. This is the only confirmed remediation action; no workarounds are documented in available data. For systems where immediate patching is not possible, consider restricting access to gnupg-dependent workflows (e.g., package signature verification pipelines, GPG-signed artifact processing) as a temporary measure, though the trade-off is disruption to those operations. Monitor the Alpine Linux security tracker (https://security.alpinelinux.org) and the upstream GnuPG project (https://gnupg.org/download/index.html) for a full advisory with further guidance. No patch version beyond the Alpine package designation 2.4.9-r0 has been independently confirmed from this data.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
GnuPG (GNU Privacy Guard) is an open-source implementation of the OpenPGP standard used for cryptographic signing, encryption, and key management. It is a foundational system component on Alpine Linux, widely used in package verification, secure communications, and secrets handling. The Alpine package version 2.4.9-r0 corresponds to upstream GnuPG 2.4.x with Alpine's revision suffix (-r0 denoting the first Alpine package build of that upstream release). No CWE is assigned, so the root cause class - whether a memory safety issue, cryptographic weakness, input validation flaw, or logic error - cannot be determined from available data. CPE data was not provided in the source intelligence.
Know when Gnupg gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
1DescriptionNVD
Alpine Linux: gnupg fixed in 2.4.9-r0
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Affected Products (CPE)NVD
Remote code execution and denial of service in GnuPG before 2.5.17 stem from a stack-based buffer overflow in gpg-agent
GnuPG version 2.1.12 - 2.2.11 contains a Cross ite Request Forgery (CSRF) vulnerability in dirmngr that can result in At
cipher/elgamal.c in Libgcrypt through 1.8.2, when used to encrypt messages directly, improperly encodes plaintexts, whic
Stack-based buffer overflow in GnuPG's tpm2daemon (versions before 2.5.17) allows a local attacker to corrupt the daemon
GnuPG 2.2.21 and 2.2.22 (and Gpg4win 3.1.12) has an array overflow, leading to a crash or possibly unspecified other imp
Interaction between the sks-keyserver code through 1.2.0 of the SKS keyserver network, and GnuPG through 2.2.16, makes i
GnuPG through 2.3.6, in unusual situations where an attacker possesses any secret-key information from a victim's keyrin
The read_block function in g10/import.c in GnuPG 1.4.x before 1.4.13 and 2.0.x through 2.0.19, when importing a key, all
The ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two c
Libksba before 1.6.3 is prone to an integer overflow vulnerability in the CRL signature parser. Rated critical severity
Integer underflow in the ksba_oid_to_str function in Libksba before 1.3.2, as used in GnuPG, allows remote attackers to
Libgcrypt before 1.7.10 and 1.8.x before 1.8.3 allows a memory-cache side-channel attack on ECDSA signatures that can be
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB