Aromatica
CVE-2025-58948
HIGH
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSend crafted HTTP request with malicious file path parameter
-
ExploitTrigger unsanitized include statement
-
ExecutionForce inclusion of arbitrary local file (e.g., /etc/passwd)
-
ImpactAchieve information disclosure or further exploitation
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V5 - File Handling File inclusion prevention, allowlisting
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Command and Control The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | The Aromatica theme must be active on the target WordPress site. The vulnerable include/require function must accept user-supplied input without proper sanitization, likely via HTTP request parameters. No authentication is required (CVSS PR:N). Exploitation is limited by high attack complexity, requiring precise path traversal sequences or knowledge of file system layout. Success also depends on file permissions of the web server process and PHP settings (e.g., |
| Impact | CVSS score of 8.1 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H) indicates high potential impact but also high attack complexity, meaning successful exploitation requires sophisticated request crafting and is not trivial. The EPSS score of 0.08% (23rd percentile) suggests very low real-world exploitation probability. No active exploitation (CISA KEV) or public proof-of-concept code has been reported. Overall, while the technical impact is severe if chained with other techniques, the immediate risk is moderate due to high complexity and lack of active exploitation. |
| Exploit ScenarioDerived | An unauthenticated attacker crafts an HTTP request to a WordPress site using the Aromatica theme, manipulating a parameter (e.g., a file path) to traverse directories and include sensitive files such as |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 26, 2026
Local file inclusion in the Aromatica WordPress theme (versions <= 1.8) allows unauthenticated attackers to read arbitrary files on the server, potentially leading to sensitive information disclosure or remote code execution if combined with other techniques. The vulnerability is not known to be actively exploited, with a low exploitation probability (EPSS 0.08%).
RemediationAI
Upgrade Aromatica to version 1.9 or later, which fixes this vulnerability. The Patchstack advisory does not specify an exact fixed version, but versions beyond 1.8 are assumed safe. If immediate upgrading is not possible, disable the Aromatica theme and switch to a default WordPress theme as a temporary measure. As a general mitigation against LFI, restrict file system permissions for the web server user, disable allow_url_fopen and allow_url_include in PHP configuration if not required, and consider using a web application firewall to filter path traversal attempts. Note that these workarounds may alter legitimate behavior or require careful testing.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability arises from improper control of filenames for include/require statements in PHP (CWE-98). The Aromatica theme, as indicated by CPE data (cpe:2.3:a:axiomthemes:aromatica:*:*:*:*:*:wordpress:*:*), fails to adequately sanitize user-supplied input used in file inclusion functions, allowing path traversal and local file inclusion. Attackers can manipulate parameters to include any local file readable by the web server process, exploiting common PHP features like include or require without proper validation.
Know when PHP gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
LFI can enable code execution via log poisoning or PHP wrappers, so integrity/availability impact set to High; high complexity due to path crafting.
Primary rating from NVD.
CVSS VectorNVD
DescriptionCVE.org
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in axiomthemes Aromatica aromatica allows PHP Local File Inclusion.This issue affects Aromatica: from n/a through <= 1.8.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Local File Inclusion vulnerabilities occur when an application accepts user-controlled input to specify which file should be loaded or executed, typically through functions like PHP's `include()`, `require()`, or `fopen()`.
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Affected Products (CPE)CVE.org
In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not
(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear
The '/common/download_agent_installer.php' script in the Quest KACE System Management Appliance 8.0.318 is accessible by
ProjectSend versions prior to r1720 are affected by an improper authentication vulnerability. Rated critical severity (C
Roundcube Webmail contains a critical PHP object deserialization vulnerability (CVE-2025-49113, CVSS 9.9) that allows au
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP c
Palo Alto Networks PAN-OS management web interface contains an authentication bypass allowing unauthenticated attackers
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
The get_referers function in /opt/ws/bin/sblistpack in Sophos Web Appliance before 3.7.9.1 and 3.8 before 3.8.1.1 allows
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB