Fabric WordPress Theme
CVE-2025-58941
HIGH
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAccess public-facing WordPress endpoint
-
DeliverySend crafted HTTP request with path traversal
-
ExploitForce theme’s include statement to load attacker-chosen local file
-
ExecutionInclude malicious PHP snippet from polluted file
-
PersistExecute code under web server privileges
-
ImpactRead, write, or execute data on the target.
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V5 - File Handling File inclusion prevention, allowlisting
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Command and Control The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | No authentication is required (PR:N), but the attack has high complexity (AC:H) due to the need for precise file path knowledge and server conditions that allow file inclusion (e.g., log pollution, accessible temporary files). The theme must process attacker-controlled input in a file-include context-likely an endpoint that accepts a filename parameter without sanitization. Exploitation is not possible under default hardened configurations unless specific PHP settings or application logic permit injection. |
| Impact | CVSS 8.1 (AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H) reflects high impact but high attack complexity, reducing real-world risk. EPSS score of 0.08% (23rd percentile) indicates low exploitation likelihood, consistent with no active exploitation (absent from CISA KEV) and no known public exploit. Under SSVC, the vulnerability is unattested and not automatable due to AC:H. Overall, this is a moderate priority: patch when feasible, not an emergent threat. |
| Exploit ScenarioDerived | An unauthenticated attacker sends a crafted HTTP request to a vulnerable WordPress site, injecting path traversal sequences to force the theme’s include function to load a predictable log file containing malicious PHP code. If successful, the attacker executes arbitrary commands on the server. No public exploit code is available at this time. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 26, 2026
Local file inclusion in the Fabric WordPress theme (≤1.5.0) allows unauthenticated attackers to include arbitrary PHP files, leading to potential remote code execution or sensitive data exposure. Exploitation requires high attack complexity, and no public exploit or active exploitation (KEV) has been reported, with EPSS indicating a 0.08% probability of widespread use.
RemediationAI
Upgrade the Fabric theme to a version beyond 1.5.0; the exact fix version is likely listed in the Patchstack advisory. If a patch is unavailable, disable the theme until remediation. As a compensating control, deploy a WAF rule to block directory traversal and file inclusion patterns targeting the theme's URL endpoints-this may introduce false positives. Restricting server file permissions and disabling dangerous PHP functions (e.g., allow_url_include) reduces impact but does not eliminate the vulnerability.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is a PHP Local File Inclusion (CWE-98) in the Fabric theme for WordPress. Improper validation of user-controlled input passed to include/require statements allows an attacker to specify a local file path, potentially loading malicious PHP code from server files like logs or temporary uploads. The CPE cpe:2.3:a:axiomthemes:fabric:*:*:*:*:*:wordpress:*:* confirms the affected component is the WordPress theme. Successful exploitation can escalate to RCE if file content is attacker-controllable.
Know when PHP gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Unauthenticated remote exploitation with high complexity due to LFI constraints and need for file control.
Primary rating from NVD.
CVSS VectorNVD
DescriptionCVE.org
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in axiomthemes Fabric fabric allows PHP Local File Inclusion.This issue affects Fabric: from n/a through <= 1.5.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Local File Inclusion vulnerabilities occur when an application accepts user-controlled input to specify which file should be loaded or executed, typically through functions like PHP's `include()`, `require()`, or `fopen()`.
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Affected Products (CPE)CVE.org
In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not
(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear
The '/common/download_agent_installer.php' script in the Quest KACE System Management Appliance 8.0.318 is accessible by
ProjectSend versions prior to r1720 are affected by an improper authentication vulnerability. Rated critical severity (C
Roundcube Webmail contains a critical PHP object deserialization vulnerability (CVE-2025-49113, CVSS 9.9) that allows au
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP c
Palo Alto Networks PAN-OS management web interface contains an authentication bypass allowing unauthenticated attackers
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
The get_referers function in /opt/ws/bin/sblistpack in Sophos Web Appliance before 3.7.9.1 and 3.8 before 3.8.1.1 allows
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB