Skip to main content

Simple Membership EUVDEUVD-2026-41820

| CVE-2026-11855 HIGH
2026-07-06 WPScan GHSA-xmqj-cv3v-f292
8.8
CVSS 3.1 · Vendor: WPScan
View
This Week Schedule remediation this week. Why: HIGH severity (CVSS 7.0-8.9).
Patch available 0.2% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Jul 22, 2026

Stored/reflected cross-site scripting in the Simple Membership WordPress plugin before 4.7.5 lets unauthenticated attackers execute arbitrary JavaScript in a logged-in administrator's browser by abusing the Stripe webhook handler. When no Stripe signing secret is configured, the plugin fails to verify webhook authenticity and then renders an attacker-controlled value unescaped inside an admin notice. Publicly available exploit code exists (WPScan), though EPSS remains low at 0.18% and no active exploitation is reported (not in CISA KEV).

Affected VersionsENISA

Simple Membership 0 <4.7.5

Affected Packages

euvd simple_membership fix: 4.7.5

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Know when Simple Membership gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

Vendor (WPScan) PRIMARY 8.8 HIGH
AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Primary rating from Vendor (WPScan) · only source for this CVE.

CVSS VectorVendor: WPScan

Attack Vector
Network
Attack Complexity
Low
Privileges Required
None
User Interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Lifecycle Timeline

3
Patch available
Jul 06, 2026 - 09:01 EUVD
CVE Published
Jul 06, 2026 - 06:00 cve.org
UNKNOWN (no severity yet)
CVE Published
Jul 06, 2026 - 06:00 cve.org
HIGH 8.8

DescriptionCVE.org

The Simple Membership WordPress plugin before 4.7.5 does not verify the authenticity of Stripe webhook requests when no signing secret is configured, nor escape a value taken from them before outputting it in an administrator notice, allowing unauthenticated attackers to inject arbitrary web scripts that execute in the context of a logged-in administrator.

Executive ViewAI

Why It Matters

Simple Membership WordPress plugin prior to version 4.7.5 contains a cross-site scripting flaw in its Stripe webhook handler that allows unauthenticated attackers to execute arbitrary code in administrator browsers; publicly available exploit code exists. This enables complete website takeover and credential compromise for organizations running affected plugin versions. Organizations using Simple Membership should apply the patch immediately to prevent unauthorized administrative access.

Recommended Action

Within 24 hours, identify all WordPress deployments running Simple Membership and determine current plugin versions, with focus on production systems and those storing sensitive data. Within 7 days, update Simple Membership to version 4.7.5 or later across all affected instances after validating updates in non-production environments and preparing rollback procedures. Within 30 days, confirm patch deployment across all systems, enable alerts for future Simple Membership security updates, and verify that Stripe webhook signing secrets are properly configured to prevent unauthenticated webhook acceptance in the future.

Business Impact: High
Compensating Controls

Apply vendor patch: update Simple Membership plugin to version 4.7.5 or later. Interim mitigation: configure Stripe webhook signing secret in plugin settings to block unauthenticated webhook processing.

Threat Intelligence Overview

EPSS Score
0.2%
Top 92% exploitable
Exploit
POC
Public exploit code exists
Social Media
1
Sightings
Data Quality
6 sources
Confidence: High

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity HIGH
CISA KEV No
Public POC Yes
EPSS 0.2%
Patch available Yes
Active threat No
Deciding rule
HIGH severity (CVSS 7.0-8.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision
Scheduled
Exploitation
Poc
System Exposure· derived
Open
Automatable
No
Human Impact
High
Technical Impact
Total

Priority Score

64
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +44
PoC: +20
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Code Injection CRITICAL

Code injection occurs when an application accepts user input and passes it directly into a language interpreter or evaluator without proper sanitization.

CVE-2022-2317 CRITICAL POC
9.8 Aug 01

The Simple Membership WordPress plugin before 4.1.3 allows user to change their membership at the registration stage due

CVE-2026-15930 CRITICAL POC
9.4 Aug 03

Account takeover of the primary WordPress administrator affects the Simple Membership plugin in all versions before 4.7.

CVE-2022-2273 HIGH POC
8.8 Aug 01

The Simple Membership WordPress plugin before 4.1.3 does not properly validate the membership_level parameter when editi

CVE-2019-14328 HIGH POC
8.8 Jul 28

The Simple Membership plugin before 3.8.5 for WordPress has CSRF affecting the Bulk Operation section. Rated high severi

CVE-2022-0681 MEDIUM POC
6.5 Mar 21

The Simple Membership WordPress plugin before 4.1.0 does not have CSRF check in place when deleting Transactions, which

CVE-2026-15931 MEDIUM POC
6.1 Aug 03

Stored cross-site scripting in the Simple Membership WordPress plugin before 4.7.8 allows unauthenticated attackers to i

CVE-2022-1724 MEDIUM POC
6.1 Jun 13

The Simple Membership WordPress plugin before 4.1.1 does not properly sanitise and escape parameters before outputting t

CVE-2026-88764 MEDIUM POC
5.4 Sep 13

Privilege escalation in the Simple Membership WordPress plugin before 4.7.8 allows authenticated members to obtain highe

CVE-2026-88785 MEDIUM POC
4.7 Oct 11

Simple Membership, a WordPress membership plugin, transmits a newly registered member's plaintext password in a URL quer

CVE-2022-0328 MEDIUM POC
4.7 Feb 28

The Simple Membership WordPress plugin before 4.0.9 does not have CSRF check when deleting members in bulk, which could

CVE-2026-97337 HIGH
7.5 Oct 03

Unauthenticated attackers can redirect activation and registration-complete emails to an arbitrary address in Simple Mem

CVE-2026-34886 HIGH
7.5 Jun 15

Broken access control in the WordPress Simple Membership plugin (versions ≤4.7.1) allows remote unauthenticated attacker

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy