Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessCompromise renderer via prior exploit
-
DeliveryServe crafted HTML page
-
ExploitFeed malformed input to Cast
-
ExecutionBypass renderer input validation
-
ImpactEscalate privileges beyond sandbox
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V2 - Validation and Business Logic Input validation, allowlisting
|
| Exploitation Conditions | Exploitation requires that the attacker has ALREADY compromised the Chrome renderer process (a prior-stage exploit is a hard prerequisite, per the description), and then delivers a crafted HTML page that exercises Chrome's Cast component - so the Cast/media-routing code path must be reachable. Limiting factors: the CVSS vector marks AC:H (non-trivial conditions/timing) and UI:R (the victim must load attacker-controlled content), and Chromium rates this Low severity. It is not remote-unauthenticated against a default browser in isolation; it only escalates privilege for an attacker who already holds renderer-level code execution. |
| Impact | Signals point to a real but conditional, low-urgency issue. The CVSS base score of 7.5 is driven by high C/I/A impact, but the vector itself (AV:N/AC:H/PR:N/UI:R) encodes high attack complexity and required user interaction, and the description adds a hard precondition: the attacker must already control the renderer process. Chromium's own severity rating is Low, and EPSS is 0.18% (8th percentile) - consistent with no mass-exploitation pressure. It is not on CISA KEV and no public exploit is identified, so this is not a drop-everything item. The main caveat: the 7.5 CVSS overstates standalone risk because it does not reflect the 'renderer already compromised' chaining requirement - treat this as a component of an exploit chain, not an independent RCE. |
| Exploit ScenarioDerived | An attacker first compromises the Chrome renderer through a separate memory-corruption or logic bug (a common first stage), then serves a crafted HTML page that feeds malformed input into the Cast component; the browser process mishandles this input and grants the attacker elevated privileges beyond the renderer sandbox. Because AC is High and user interaction is required, the victim must load attacker-controlled content and the exploit is unreliable. No public proof-of-concept is identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 01, 2026
Privilege escalation in Google Chrome's Cast component before 150.0.7871.47 allows a remote attacker who has already compromised the renderer process to escape renderer-level restrictions and gain higher privileges via a crafted HTML page. Rated Low severity by Chromium despite a 7.5 CVSS, it functions as a second-stage sandbox-escape primitive rather than a standalone initial-access bug. There is no public exploit identified at time of analysis and EPSS is low (0.18%, 8th percentile), indicating minimal near-term mass-exploitation risk.
RemediationAI
Vendor-released patch: update Google Chrome to 150.0.7871.47 or later via the Stable channel and relaunch the browser to apply the fix (managed fleets should force-update through enterprise policy). Verify per the Chrome Releases advisory at https://chromereleases.googleblog.com/2026/06/stable-channel-update-for-desktop_0175352312.html. As an interim compensating control while patching, restrict or disable the Cast feature - for example via the enterprise policy that controls media routing / 'Cast' (EnableMediaRouter=Disabled), which removes the vulnerable code path's user exposure at the cost of losing local screen/tab casting to Chromecast devices. Network-level containment (limiting local-network access to Cast receivers) offers little benefit here since the trigger is a crafted HTML page in an already-compromised renderer, so prompt browser updating remains the only complete remediation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The flaw sits in Chrome's Cast subsystem, the feature that discovers and streams tab/media content to Chromecast and other Google Cast receivers over the local network. The root cause is CWE-20 (Improper Input Validation): Cast insufficiently validates untrusted input crossing the renderer boundary, letting a hostile renderer supply data that the more-privileged browser process trusts. Because Chrome's multi-process architecture isolates untrusted web content in a sandboxed renderer, any bug that lets a compromised renderer influence a higher-privilege component is a privilege-escalation/sandbox-weakening primitive. Affected builds are all Chrome desktop versions prior to 150.0.7871.47 (EUVD range 'Chrome <150.0.7871.47').
Know when the next one hits your stack
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
Sources disagree (Low–High)AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Network-delivered crafted page (AV:N) but requires prior renderer compromise plus timing (AC:H) and victim page load (UI:R); privilege escalation yields high C/I/A within the browser (S:U).
vuln.today treats the vendor’s rating as authoritative. A higher third-party CVSS (e.g. CISA-ADP) is shown for transparency but does not drive the headline severity.
CVSS VectorVendor: google
Lifecycle Timeline
3DescriptionCVE.org
Insufficient validation of untrusted input in Cast in Google Chrome prior to 150.0.7871.47 allowed a remote attacker who had compromised the renderer process to perform privilege escalation via a crafted HTML page. (Chromium security severity: Low)
Executive ViewAI
Google Chrome's Cast component prior to version 150.0.7871.47 contains a privilege escalation vulnerability that allows attackers to bypass renderer-level security boundaries. This attack requires prior compromise of the renderer process and carries minimal near-term exploitation risk (0.2% EPSS, no public exploit identified). Organizations should patch within standard timelines but can deprioritize relative to threats with simpler attack chains or higher exploitation likelihood.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Same weakness CWE-20 – Improper Input Validation
View allSame technique Privilege Escalation
View allVendor StatusVendor
SUSE
Severity: Important| Product | Status |
|---|---|
| SUSE Package Hub 15 SP7 | Fixed |
| openSUSE Tumbleweed | Fixed |
| SUSE Package Hub 15 SP7 | Affected |
EUVD-2026-40802
GHSA-3wq9-fwp9-c2mc
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB