Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | Risk is contextual and depends on deployment model. CVSS 3.0 reflects the protective factors: network-reachable but high attack complexity (AC:H), high privilege requirement (PR:H), and limited scope-only confidentiality of certificate metadata is affected (C:L; no integrity or availability impact). However, CVSS underweights the business risk in multi-tenant environments where organizational isolation is a security boundary; an attacker with administrative credentials could conduct competitive intelligence or reconnaissance against other organizations' PKI infrastructure. EPSS data is not provided, limiting probabilistic exploitation assessment. The lack of a KEV entry or public POC suggests this was likely discovered during internal security review or a limited third-party assessment rather than opportunistic exploitation. Given the requirement for PR:H (high privilege) and AC:H conditions, real-world exploitability is low outside of insider threat scenarios or compromised admin accounts. The tagging as 'Authentication Bypass' is somewhat misleading-this is an authorization (not authentication) flaw requiring valid credentials to trigger. |
| Exploit ScenarioDerived | An authenticated administrator or high-privilege MCP agent provisioned by an organization could send certificate queries to the runZero Platform API to retrieve certificate metadata belonging to other organizations in a multi-tenant instance, exposing public key details, issuer names, expiration dates, and subject information. No technical barrier (only organizational policy) would prevent this reconnaissance, allowing an attacker to build an inventory of competitors' or targets' PKI infrastructure. Such access might enable downstream attacks on certificate pinning mechanisms or supply-chain reconnaissance, though active exploitation would require existing administrative credentials and knowledge of other organizations' certificate identifiers. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 07, 2026
runZero Platform versions prior to 4.0.260203.0 allow authenticated high-privilege MCP agents to access certificate information outside their authorized organization scope, enabling lateral information disclosure across organizational boundaries. The vulnerability stems from improper authorization checks (CWE-863) and carries a CVSS score of 3.0 (Low) due to high attack complexity and privilege requirements; no public exploit code or active exploitation has been identified.
RemediationAI
Vendor-released patch: runZero Platform version 4.0.260203.0 or later. Organizations should upgrade immediately to the patched version via standard deployment channels. Pending upgrade, restrict administrative API access and MCP agent provisioning to trusted personnel; audit certificate access logs for unauthorized cross-organization queries. For detailed upgrade instructions and advisory context, consult https://www.runzero.com/advisories/runzero-platform-mcp-cert-infoleak-cve-2026-5379/ and the release notes at https://help.runzero.com/docs/release-notes/#402602030.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the Model Context Protocol (MCP) agent implementation within runZero Platform, a network intelligence and security platform (CPE: cpe:2.3:a:runzero:platform:*:*:*:*:*:*:*:*). MCP agents operate as trusted system components that should enforce organizational scope boundaries when accessing sensitive certificate metadata. The flaw represents a classic authorization bypass (CWE-863: Incorrect Authorization) where the platform fails to validate whether an MCP agent's organizational context permits access to requested certificate objects. This allows an authenticated agent with high-level privileges to enumerate or retrieve certificate information belonging to other organizations within the same multi-tenant deployment, violating the intended isolation model.
Know when Platform gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N
Primary rating from Vendor (runZero) · only source for this CVE.
CVSS VectorVendor: runZero
Lifecycle Timeline
2DescriptionCVE.org
An issue that allowed MCP agents to access certificate information from outside of their authorized organization scope has been resolved. This is an instance of CWE-863: Incorrect Authorization, and has an estimated CVSS score of CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N (3.0 Low). This issue was fixed in version 4.0.260203.0 of the runZero Platform.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Server-side request forgery in Huly Platform's /import endpoint allows authenticated workspace users to coerce the front
Affected 1E Platform versions have a Blind SQL Injection vulnerability that can lead to arbitrary code execution. Rated
Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dash
Pega Platform before version 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability in the comment tags.
The Richtext Editor in Pega Platform before 8.2.6 is affected by a Stored Cross-Site Scripting (XSS) vulnerability. Rate
Improper privilege management in runZero Platform allows organization administrators to escalate privileges to superuser
Improper link resolution before file access in the Nomad module of the 1E Client, in versions prior to 25.3, enables an
Incorrect access control in the component ApiPayController.java of platform v1.0.0 allows attackers to access sensitive
Incorrect access control in the component orderService.queryObject of platform v1.0.0 allows attackers to access sensiti
Incorrect access control in the component ApiOrderService.java of platform v1.0.0 allows attackers to access sensitive i
The 1E-Exchange-DisplayMessageinstruction that is part of the End-User Interaction product pack available on the 1E Exch
The 1E-Exchange-CommandLinePing instruction that is part of the Network product pack available on the 1E Exchange does n
EUVD-2026-19696
GHSA-pqp2-x3gp-9g37
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB