Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as low-privilege user
-
DeliverySubmit unsanitized payload to wishlist field
-
ExploitPayload stored by plugin
-
ExecutionAdmin/victim views affected page
-
PersistScript executes in victim browser session
-
ImpactHijack session or act as victim
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated account with at least low-level privileges (PR:L) on the target WordPress site running YITH WooCommerce Wishlist version 4.18.1 or earlier, plus WooCommerce installed. The attacker must store a crafted XSS payload through a plugin-controlled wishlist input, and the payload only triggers when another user interacts with/views the affected page (UI:R) - meaning the impact depends on a higher-privileged victim (e.g., an administrator) rendering the poisoned content. Limiting factors: no unauthenticated path (an account is required), mandatory victim interaction, and only partial confidentiality/integrity/availability impact; the plugin must be present and the vulnerable field reachable by the attacker's role. |
| Impact | This is a moderate-severity Stored XSS (CWE-79) in the YITH WooCommerce Wishlist plugin, scored CVSS 6.5 (AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L). The vector indicates a network-reachable but authenticated (PR:L) flaw that also requires victim interaction (UI:R), with a scope change (S:C) reflecting that injected script executes in another user's browser context. No EPSS score, CISA KEV listing, or public POC is present in the provided data, so there is no public exploit identified at time of analysis. The signals are internally consistent - nothing in the description contradicts the CVSS vector - but the combination of required low-level authentication plus mandatory user interaction and only partial (L/L/L) impact places this well below the urgency of unauthenticated or actively-exploited flaws. The practical risk is driven more by the plugin's large install base than by ease of exploitation: a low-privileged contributor/customer could persist malicious script that fires when a higher-privileged user (e.g., a shop admin) views the affected data. Treat as a standard-priority patch item rather than an emergency, absent any exploitation evidence. Missing data: no EPSS, no KEV, no POC confirmation, and no vendor advisory beyond the Patchstack database entry. |
| Exploit ScenarioDerived | A low-privileged authenticated user (e.g., a registered customer or contributor) submits input through a wishlist-related field that the plugin fails to sanitize, persisting a malicious script payload. When a store administrator or another user later views the affected page, the stored script executes in their authenticated browser session, enabling session/cookie theft or actions performed as the victim. No public proof-of-concept exploit is identified in the provided data, and successful exploitation depends on the victim viewing the poisoned content (UI:R). |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 19, 2026
Stored cross-site scripting in YITH WooCommerce Wishlist through 4.18.1 lets authenticated low-privileged users persist crafted input that executes in another user's browser when poisoned wishlist content is viewed. The plugin must be active alongside WooCommerce, and the attacker needs an account on the WordPress site, so exploitation depends on a victim, potentially an administrator, interacting with the stored payload. No public exploit identified at time of analysis; CVSS 6.5 reflects partial confidentiality, integrity, and availability impact with scope change.
RemediationAI
No vendor-released patch version is identified in the provided data; the advisory identifies YITH WooCommerce Wishlist through 4.18.1 as affected, so update to a release later than 4.18.1 once the vendor confirms it contains the XSS fix and verify the fixed version in the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/yith-woocommerce-wishlist/vulnerability/wordpress-yith-woocommerce-wishlist-plugin-4-18-1-cross-site-scripting-xss-vulnerability?_s_id=cve. If immediate upgrade is not possible, restrict wishlist creation and editing to trusted roles, temporarily disable the plugin if wishlist functionality is non-essential, and review or sanitize stored wishlist content. Deploy a WAF rule targeting stored XSS in wishlist requests as a compensating control, recognizing it may not catch all payload variants, and enforce least privilege for subscriber and contributor accounts.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This is a CWE-79 improper neutralization issue in a WordPress/WooCommerce plugin. The vulnerable wishlist input is stored by the plugin and later rendered without sufficient output encoding, allowing script execution in the browser of a user who views the affected wishlist content. The CVSS vector AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L indicates a network-reachable attack that requires an authenticated low-privileged account and victim interaction, with scope change because the injected script can act in the context of a higher-privileged viewer such as an administrator. The CPE cpe:2.3:a:yith:yith_woocommerce_wishlist:*:*:*:*:*:*:*:* identifies the YITH WooCommerce Wishlist plugin as the affected component, and WooCommerce must also be present for the wishlist functionality to be exposed.
Know when Yith Woocommerce Wishlist gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Network-reachable stored XSS requiring a low-privileged account (PR:L) and victim interaction (UI:R); script executes in another user's context (S:C) with limited C/I/A impact.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in YITH YITH WooCommerce Wishlist yith-woocommerce-wishlist allows Stored XSS.This issue affects YITH WooCommerce Wishlist: from n/a through 4.18.1.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
More in Yith Woocommerce Wishlist
View allUnauthenticated attackers can rename arbitrary wishlists on WordPress sites running YITH WooCommerce Wishlist before ver
Missing authorization on the wishlist rename endpoint in YITH WooCommerce Wishlist (WordPress plugin before 4.18.1) perm
Authorization bypass in YITH WooCommerce Wishlist through version 4.12.0 allows unauthenticated remote attackers to modi
plugin-fw/lib/yit-plugin-panel-wc.php in the YIT Plugin Framework through 3.3.8 for WordPress allows authenticated optio
EUVD-2026-104250
GHSA-r6q4-c8ph-4j9j
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB