Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V13 - Configuration Default permission hardening
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | An attacker with limited access can gain administrative or root privileges, enabling full control over the affected system. With a CVSS score of 9.8 (CRITICAL), this represents a critical risk. |
| Exploit ScenarioDerived | A local attacker exploits a vulnerability in a privileged service or misconfigured permissions to escalate from a standard user to root/administrator. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 15, 2026
pdns specific as packaged in Debian in version before 3.3.1-1 creates a too privileged MySQL user. It was discovered that the maintainer scripts of pdns-backend-mysql grant too wide database permissions for the pdns user. Other backends are not affected.
Earlier versions of this analysis (1)
RemediationAI
A vendor patch is available — apply it immediately. Apply the principle of least privilege. Keep systems patched. Monitor for suspicious privilege changes. Use mandatory access controls (SELinux, AppArmor).
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Privilege escalation allows a low-privileged user or process to gain elevated permissions beyond what was originally authorized. This vulnerability is classified as Incorrect Default Permissions (CWE-276).
Know when Pdns gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
Sources disagree (Medium–Critical)AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
vuln.today treats the vendor’s rating as authoritative. A higher third-party CVSS (e.g. CISA-ADP) is shown for transparency but does not drive the headline severity.
CVSS VectorNVD
Lifecycle Timeline
2Executive ViewAI
Organizations using Debian in face critical risk from CVE-2014-7210, a incorrect default permissions vulnerability rated CVSS 9.8. Attackers could escalate their privileges to gain elevated access beyond their authorized level. A patch is available and should be applied immediately given the critical severity.
Apply vendor patch. If immediate patching is not feasible: (1) Implement network-level access controls to limit exposure; (2) Enable enhanced monitoring and alerting; (3) Apply principle of least privilege.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Same weakness CWE-276 – Incorrect Default Permissions
View allSame technique Privilege Escalation
View allVendor StatusVendor
Ubuntu
Priority: Medium| Release | Status | Version |
|---|---|---|
| lucid | ignored | end of life |
| precise | ignored | end of life |
| upstream | released | 3.3.1-1 |
| utopic | not-affected | 3.3.1-4 |
| vivid | not-affected | - |
| wily | not-affected | - |
| xenial | not-affected | - |
| yakkety | not-affected | - |
| zesty | not-affected | - |
| artful | not-affected | - |
| bionic | not-affected | - |
| cosmic | not-affected | - |
| disco | not-affected | - |
| trusty | DNE | trusty/esm was DNE [trusty was needed] |
Debian
| Release | Status | Fixed Version | Urgency |
|---|---|---|---|
| bullseye | fixed | 4.4.1-1 | - |
| bookworm | fixed | 4.7.3-2 | - |
| trixie | fixed | 4.9.7-1 | - |
| forky, sid | fixed | 5.0.3-1 | - |
| squeeze | not-affected | - | - |
| wheezy | fixed | 3.1-4.1+deb7u1 | - |
| (unstable) | fixed | 3.3.1-1 | - |
EUVD-2014-7083
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB