Skip to main content

Pdns CVE-2014-7210

| EUVDEUVD-2014-7083 CRITICAL
Incorrect Default Permissions (CWE-276)
2025-06-26 security@debian.org
Critical
Disputed · 9.8 NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V13 - Configuration Default permission hardening
MITRE ATT&CK

1 technique across 1 tactic: Privilege Escalation

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Impact

An attacker with limited access can gain administrative or root privileges, enabling full control over the affected system. With a CVSS score of 9.8 (CRITICAL), this represents a critical risk.

Exploit ScenarioDerived

A local attacker exploits a vulnerability in a privileged service or misconfigured permissions to escalate from a standard user to root/administrator.

Act Now Prioritize within 24-48h. Why: CRITICAL severity.
Patch available 0.1% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Mar 15, 2026

pdns specific as packaged in Debian in version before 3.3.1-1 creates a too privileged MySQL user. It was discovered that the maintainer scripts of pdns-backend-mysql grant too wide database permissions for the pdns user. Other backends are not affected.

Earlier versions of this analysis (1)
v1 Mar 15, 2026 - 23:54 CVSS 9.8

RemediationAI

A vendor patch is available — apply it immediately. Apply the principle of least privilege. Keep systems patched. Monitor for suspicious privilege changes. Use mandatory access controls (SELinux, AppArmor).

Affected VersionsENISA

pdns 0 <3.3.1-1

Affected Packages

euvd pdns fix: 3.3.1-1

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

Privilege escalation allows a low-privileged user or process to gain elevated permissions beyond what was originally authorized. This vulnerability is classified as Incorrect Default Permissions (CWE-276).

Know when Pdns gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

Sources disagree (Medium–Critical)
NVD PRIMARY 9.8 CRITICAL
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Ubuntu MEDIUM

vuln.today treats the vendor’s rating as authoritative. A higher third-party CVSS (e.g. CISA-ADP) is shown for transparency but does not drive the headline severity.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
Low
Privileges Required
None
User Interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Lifecycle Timeline

2
Patch released
Mar 15, 2026 - 23:54 nvd
Patch available
CVE Published
Jun 26, 2025 - 21:15 nvd
CRITICAL 9.8

Executive ViewAI

Why It Matters

Organizations using Debian in face critical risk from CVE-2014-7210, a incorrect default permissions vulnerability rated CVSS 9.8. Attackers could escalate their privileges to gain elevated access beyond their authorized level. A patch is available and should be applied immediately given the critical severity.

Business Impact: Severe
Compensating Controls

Apply vendor patch. If immediate patching is not feasible: (1) Implement network-level access controls to limit exposure; (2) Enable enhanced monitoring and alerting; (3) Apply principle of least privilege.

Threat Intelligence Overview

EPSS Score
0.1%
Top 71% exploitable
Data Quality
5 sources
Confidence: Medium

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity CRITICAL
CISA KEV No
Public POC No
EPSS 0.1%
Patch available Yes
Active threat No
Deciding rule
CRITICAL severity
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Out-of-Cycle
Exploitation· derived
None
System Exposure· derived
Open
Automatable· derived
Yes
Human Impact
Very High

Priority Score

49
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +49
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.

Vendor StatusVendor

Ubuntu

Priority: Medium
pdns
Release Status Version
lucid ignored end of life
precise ignored end of life
upstream released 3.3.1-1
utopic not-affected 3.3.1-4
vivid not-affected -
wily not-affected -
xenial not-affected -
yakkety not-affected -
zesty not-affected -
artful not-affected -
bionic not-affected -
cosmic not-affected -
disco not-affected -
trusty DNE trusty/esm was DNE [trusty was needed]

Debian

pdns
Release Status Fixed Version Urgency
bullseye fixed 4.4.1-1 -
bookworm fixed 4.7.3-2 -
trixie fixed 4.9.7-1 -
forky, sid fixed 5.0.3-1 -
squeeze not-affected - -
wheezy fixed 3.1-4.1+deb7u1 -
(unstable) fixed 3.3.1-1 -

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy