Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessIdentify WordPress site with BookIt <= 2.6.0.3 active
-
DeliverySend unauthenticated HTTP request to BookIt AJAX/REST handler
-
ExploitBypass authenticity verification (CWE-345)
-
ExecutionPerform unauthorized booking operation
-
ImpactManipulate booking state (create/modify/cancel appointments)
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A08:2025 - Software or Data Integrity Failures
ASVS 5.0
V15 - Secure Coding and Architecture Data authenticity verification
|
| Exploitation Conditions | Exploitation requires only network access to a WordPress site running BookIt version 2.6.0.3 or earlier - no authentication, no special account, and no user interaction are needed (confirmed by CVSS PR:N/UI:N). The target site must have the BookIt plugin installed and active with its booking-related endpoints accessible over HTTP/HTTPS. No non-default configuration is required. Exploitation is limited in impact to integrity effects on booking data (I:L); attackers cannot read sensitive data (C:N) or cause service disruption (A:N), which constrains the practical harm to booking system abuse rather than site compromise. |
| Impact | The provided CVSS score of 5.3 (Medium) reflects a limited-impact bypass: integrity is affected at a Low level (I:L) with no confidentiality or availability impact, suggesting the attacker cannot read sensitive data or crash the service but may be able to create, modify, or cancel bookings without authorization. The unauthenticated, low-complexity attack vector (AV:N/AC:L/PR:N/UI:N) makes this trivially reachable from the internet - no special network position or credentials are required. However, the constrained impact (I:L, S:U) limits the real-world blast radius; this is not a path to site takeover or data exfiltration. No EPSS data, KEV listing, or public POC is present in the provided intelligence, so exploitation probability is unquantified and presumed opportunistic at most. The primary risk is booking system abuse - fraudulent reservations, appointment slot exhaustion, or unauthorized cancellations - which carries operational rather than security-critical impact for most deployments. |
| Exploit ScenarioDerived | A remote attacker sends a crafted unauthenticated HTTP request - likely targeting a WordPress AJAX handler or REST API endpoint exposed by the BookIt plugin - that omits or bypasses the expected authentication or nonce verification check. Because the plugin does not adequately verify the authenticity of the request, it processes the action as if it were legitimate, allowing the attacker to create fraudulent bookings, modify existing appointments, or trigger restricted booking-state transitions without holding any WordPress account credentials. No public exploit code has been identified, but the low attack complexity makes manual exploitation straightforward for anyone familiar with WordPress plugin architecture. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 03, 2026
Unauthenticated bypass in the BookIt WordPress plugin (versions <= 2.6.0.3) allows remote attackers to circumvent an authentication or authorization control with low-integrity impact. The flaw, rooted in CWE-345 (Insufficient Verification of Data Authenticity), enables attackers to perform actions that should be restricted - likely manipulating booking-related state without holding a valid session or credentials. The vendor CPE attributes this to Nexcess (cpe:2.3:a:nexcess:bookit). No public exploit code or CISA KEV listing has been identified at time of analysis.
RemediationAI
Update the BookIt plugin to a version beyond 2.6.0.3 as soon as a patched release is available from the plugin developer or the WordPress.org plugin repository. Patchstack is the disclosing reporter and their advisory at https://patchstack.com/database/wordpress/plugin/bookit/vulnerability/wordpress-bookit-plugin-2-6-0-3-bypass-vulnerability-vulnerability should be monitored for confirmed fix version details, as no exact patched version number is independently confirmed in the available data. As an interim compensating control, site administrators can temporarily disable the BookIt plugin until a patch is applied, or restrict access to WordPress AJAX/REST endpoints at the WAF or server level for unauthenticated requests targeting booking-related actions. Restricting the plugin's front-end exposure reduces attack surface but may impair the booking workflow for legitimate users.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
BookIt is a WordPress appointment-booking plugin distributed under the Nexcess vendor namespace (CPE: cpe:2.3:a:nexcess:bookit:*:*:*:*:*:*:*:*). CWE-345 (Insufficient Verification of Data Authenticity) indicates the plugin fails to properly confirm that a request originates from a legitimate, authenticated user before executing a privileged action - a pattern common in WordPress plugins that rely on nonce checks, capability checks, or REST API permission callbacks but implement them incompletely. In the WordPress ecosystem, this class of flaw typically manifests as missing or incorrectly scoped current_user_can() or check_ajax_referer() calls on AJAX/REST handlers, allowing unauthenticated HTTP requests to trigger restricted booking operations. The CVSS vector (AV:N/AC:L/PR:N/UI:N) confirms the bypass is reachable over the network with no credentials, confirming an unauthenticated attack surface.
Know when Bookit gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Unauthenticated network bypass with only low integrity impact; no confidentiality or availability impact confirmed by description and CVSS signals.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Unauthenticated Bypass Vulnerability in BookIt <= 2.6.0.3 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
The BookIt plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.3.7. Rated cr
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in StylemixThemes Boo
Authentication bypass in Liquid Web / StellarWP BookIt WordPress plugin versions before 2.5.4.1 allows remote unauthenti
Missing authorization in the BookIt WordPress plugin (Liquid Web / StellarWP), in all versions through 2.6.0.5, allows r
EUVD-2026-70579
GHSA-vg3m-xq6r-8qfh
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB